1. Registration issues have now been resolved. New accounts are able to be created

It is possible to install windows creator update

Discussion in 'NEO Z83-4' started by xixou, May 19, 2017.

  1. CptDobey

    CptDobey Member

    As you have nothing to lose:
    On another PC download the official MS Media Tools:
    https://www.microsoft.com/en-us/software-download/windows10

    Download the correct W10 version (Home) and create a bootable USB key (the tool handles this). This will be the Creator version, do not worry.

    Set the bios of the Minix to boot on the usb first. Plug it in. Boot.

    During the installation process, you will have the opportunity to wipe all existing partition. Do it. The installer will recreate everything, with the correct, default size.

    Once W10 is installed, you will have to install all Z83-4 drivers. There is a dedicated thread about this. Basically: download, extract everything, right click->install every .INF you will find.
  2. Wolfman 99

    Wolfman 99 New Member

    Also that's what exactly what happened to mine with the same error code. Did u try pressing F9 with a USB keyboard & getting into start up repair? It sorted my machine out & installed Creates update after the repair & works fine now.
  3. Peter Harp

    Peter Harp New Member

    You guys are fantastic. I tried the F9 rout first as that seemed the simplest and yes, so far (3hrs) all seems back to normal. If for any reason it goes doolally after that I'll give the ISO method a pop.

    Thank you both very, very much :)
  4. Wolfman 99

    Wolfman 99 New Member

  5. liad

    liad New Member

    didnt work here. only gave me the option to enlarge the system partitation to 200Mb and not to 500 as you explained. donno how but i still cant DL the new win ver.... thx anyways
  6. Caduceus26

    Caduceus26 New Member

    This works. Thanks!

    I played around with the partition size of 100 MB a couple of months ago and gave up after the update kept failing. Using your tip I got the system partition sorted out, however, I still needed roughly 15 GB on the active partition for the install to work.

    Remember to take into account the space requirements for windows.old and $WINDOWS.~BT. After the update, if satisfied that all is well and there is no need to rollback, that space can be reclaimed using the disk cleanup tool.
  7. liad

    liad New Member

    Hi again. I did something wrong and now it gives me only 18gb on the c drive. How can I fix it?
  8. Joe Shuster

    Joe Shuster New Member

    I'm writing the to close the loop on a challenge I had with disk partitions in Windows 10.

    I had to delete the MSR partition on my GPT drive. (It was not moveable with the partition management tool.) That step was part of a convoluted process to allow me to install the Creators Update (1703). I had resisted deleting the partition despite many people claiming it wasn't essential and didn't need to be replaced. Evidence on-line indicated the MSR partition was important in recovery situations and it was definitely not disposable.

    Eventually, I tracked down the way to recreate a new (better) MSR on my disk. Here's the link for the page I relied on:
    https://technet.microsoft.com/en-us/library/cc770438(v=ws.11).aspx

    The synopsis is the DiskPart system management tool has a "create partition msr" command.

    I still contend that the MSR is not disposable and might be essential in a problem situation. But now I'm confident I can delete it if I need to for complex disk management and then recreate a new MSR for normal operations.

    Finally, none of these disk repartitioning steps should have been necessary. It looks like whoever organized the factory partitioned disks didn't understand the Window 10 update process or anticipate a large update like 1703. Hopefully, newer versions of the Z83-4 will have a layout that doesn't require so much low-level surgery. (Otherwise, MINIX will alienate all the buyers who don't want to be PC doctors.)

    Joe
  9. Joe Shuster

    Joe Shuster New Member

    On part of my ordeal toward getting the Creators Update installed, I learned a couple of things that others might appreciate:

    1) If you need some space on the c:/ drive, you can disable hibernation, and delete the hibernation file. Here's a link to a page that helped me:
    https://www.techsupportall.com/hiberfil-sys-file-delete-windows-10/

    If you never want the option to hibernate, just leave it off. If you can afford the loss of disk space and want it hibernate option back, you can restore it.

    The process requires using some of the command-prompt management tools.

    I deleted the hibernation file while struggling to find enough c:/ free space for the over-sized Creators Update. And I restored it afterwards for normal operations.

    2) The Windows Cleanup app had some deceptive reporting. For the "Downloaded Program Files" category, my system always reports "0 bytes" to delete. When I checked that category for deletion, I got a substantial savings in disk space. So if you're scrounging for space, don't trust that "0 bytes" total. You might get some meaningful space cleared in the app.

    HTH, Joe
  10. nmodlin

    nmodlin New Member

    Thanks for the tip. Gonna implement this tomorrow

    Sent from my SAMSUNG-SM-G935A using Tapatalk
  11. Caduceus26

    Caduceus26 New Member

    A little utility that I've used since about 2008 called "DriveSpacio" (free and downloadable - Google) showed me that hiberfil.sys and pagefile.sys were occupying the lion's share of space on my drive. Removing the hibernation file gave me the space I needed to complete the update. The other things I did were in my earlier post but they are basically what xixou recommended.

    I will again mention the need to consider the space requirements for windows.old and $WINDOWS.~BT which can be reclaimed using the disk cleanup tool after the update is complete and there's no need or desire to go back to the previous version of Windows.
  12. asciicode

    asciicode New Member

    confirm working for me, tried twice. first time says restoring prev version. thanks xixou.
  13. Uno Ydostres

    Uno Ydostres New Member

    Nice to be here. I bougth recently (two days ago) a Minix Z83-4 and my oppinion is that the device is great for the price you pay, but is short of HD capacity thus making difficult to actualize the OS. I think we have to focus our effort in this forum to overcome this point. I like and appreciate very much the posts and method sugested by xixou (http://www.minixforum.com/threads/it-is-possible-to-install-windows-creator-update.16565/), but I would like to be sure that Minix agrees and approves this procedure to assure updating of the OS with its short Minix HD capacity. I will try it again following the steps of xixou, anyway, and I will post my findings here, but I think a litte compromise of the experts of the supplier would be welcome. If I cannot succeed with the update of Windows (until now I got always an error message when I've tried to install last update of W10), I would have to try to change the W10 OS by a good Linux, like Mint or Zorin. To be continued...
    Last edited: Sep 11, 2017
  14. xixou

    xixou New Member

    no problem, win 10 uses 13 GB out of the 28 GB of the flash memory.
  15. Uno Ydostres

    Uno Ydostres New Member

    I am glad to say that, following the method posted by xixou I have been able to install the last version of Windows, the 'creator update'. Thank you xixou for your help!

    Now I have installed also the Office 2016. My small Minix acting as a 'big box' computer. :)
  16. miguel87

    miguel87 New Member

    Hi

    I made a full recovery and the suggested changes in drive partitions from first message. I still got 0x80070070 error while updating.

    I can't understand why... It is a new and clean windows installation. I haven't even installed chrome yet in order to save a few extra MB. What else can I do? It is impossible to make any extra space
  17. RyanRyan98

    RyanRyan98 New Member

    Hello. Sorry to bump this thread but I've run into some issues trying to resize partitions so that I can complete a creators update. I d0wnloaded the program and opened it. There was no partition named MSR. There is the *system one (64mb), Unallocated (16mb), C:Windows (24 GB) and *Recovery (373mb). I tried deleting the unallocated one but its stil there, just grayed out. When I try to resize the *System partition it doesn't let me. It will not go above or below the 80MB partition size (not sure why it says 80 there but 64 where all partitions are listed.

    Any idea where to go from there?
  18. RyanRyan98

    RyanRyan98 New Member

    Well I ended up being able to resize the partitions, not really sure how but the I got the small 16mb removed and was able to get the *system partition over 500 mb. The computer forced me to reboot and now I am getting error messages that go as follows (one example):

    Failed to read disk. error:121 LBA: 61146312
    Resize partition 48% processing files 100% (49:03)
    Failed to read disk. error:121 LBA 61165896

    The same error message displays every minute or two with the partition % keeps climbing slowly. However I am not sure it really matters since if the disk can't be read does that mean the computer is shot?

    I'm probably way over my head here. Tried my best to follow the instructions I found but doesn't seem to be working well. Maybe I should just stick to Macs lol.