1. Welcome to the official forum for MINIX devices!

It is possible to install windows creator update

Discussion in 'NEO Z83-4' started by xixou, May 19, 2017.

  1. CptDobey

    CptDobey Member

    Is it this one : https://technet.microsoft.com/fr-fr/library/cc770438(v=ws.11).aspx ?

    One interesting info is it is mentioning a GPT formatted disk. If I do understand well, it means an MSR partition is useless on an MBR formatted disk. This is confirmed (somehow) by this Wiki page: https://en.wikipedia.org/wiki/Microsoft_Reserved_Partition

    So, the question is: is the Minix SSD formatted as a GPT disk or an MBR one ?
    That's easy to konw: https://www.howtogeek.com/245610/ho...pt-or-mbr-and-how-to-convert-between-the-two/
  2. alexf

    alexf New Member

    This worked great, and is much better than partitioning!
    I think this deserves its own thread and sticky.
  3. pusb87

    pusb87 Well-Known Member Trusted Helper

    I'm sure I was given the option when updating my Z83-4 Pro to use a USB flash drive to overcome storage space issues
    I got to this bit by selecting the " Fix It" option ( or similar) whilst updating
    not sure whether this applies to the Z83-4 though
  4. 1000

    1000 New Member

    I have tried the method above and it didn't work on my Windows 10 Updates on my NEO Z83-4 - I have less space than before - can you please help - I don't know how to fix - have tried cleaning disk space but its still not enough
    upload_2018-1-13_4-46-13.png
  5. skynet

    skynet Well-Known Member Trusted Helper

    No need to change anything with partitions.
    Uninstall all personnal apps, clean your windows and you should be able to upgrade your windows.

    Another model with same SSD space : http://www.minixforum.com/threads/upgrade-win10-to-creative-fall-1709-version.18429/
  6. Sally3

    Sally3 New Member

    Here's my update problem.
    Received a new Z83-4 today, and it of course wanted to update. After the initial failure I looked on here and took the advice. Increased the System partition to 1GB. The update proceeded almost to the end but then ran out of memory.
    Windows did a lot of updating before and after restarting, but the update still wasn't finished.
    I decided to increase the System partition to 2GB, and then restarted the update. It then failed to start because it 'hadn't got the 8GB memory needed.' It seems that the Windows partition had suddenly become nearly full.
    I've looked through that partition with a file manager, removed all temporary and download files, can't see what has taken up so much memory.
    Does anyone have any ideas what has happened, please?
    Capture2.PNG
  7. brooksa

    brooksa New Member

    EDIT: Created a Tutorial for the following process...
    __________________________________________________
    Just do a fresh install of Windows 10 Fall Creators Edition Update.

    1. FIRST: Download the Z83-4 drivers found here:
    http://www.minixforum.com/downloads/download.php?file=Z83-4_device_drivers_Win10_64bit.rar
    PUT THEM ON A NETWORK OR EXTERNAL DRIVE. YOU WILL NEED THEM LATER

    2. Then READ and FOLLOW the Microsoft Instructions. You will need a USB Drive that can be Erased (8GB minimum).
    https://answers.microsoft.com/en-us...f/aef0ae63-2117-41ee-a8ea-4a3181625b08?auth=1

    Perform a Clean Install on an Empty Hard Disk/SSD by Booting from Install Media USB Thumb Drive

    Note: You can safely delete ALL partitions currently on the device during the install. The install will recreate everything it needs and you will likely end up with additional free space when the process is complete.

    3. Windows will auto Activate... Graphics card driver will auto install. (give it 10 minutes) and for the remainder of the missing drivers, just point them to the extracted RAR file location that you saved in a safe place from step 1.

    4. Fresh, Clean, Shiny & New, Enjoy!

    PS: The System Reserved partition does not need to be more than 500MB maximum. The Windows Install will automatically create it after you delete ALL partitions.
    Last edited: Jan 22, 2018
    Sally3, skynet and Villa like this.
  8. Sally3

    Sally3 New Member

    Great! Thanks so much for that.
    I'll get on to it over the weekend. (y)
  9. brooksa

    brooksa New Member

    No problem! Last thing I would add is that in order to take advantage of the on board HEVC decoder also install this [Microsoft HEVC Video Extension]
    Last edited: Jan 20, 2018
  10. Sally3

    Sally3 New Member

    First failure!
    When starting from the Install Media USB drive, I get the first screen to select the region, then the Install Now screen.
    When I click on that there is an immediate prompt "A media driver your computer needs is missing".

    I browsed to the unpacked driver package on another USB, and installed the drivers from there one by one (a few don't install)
    But an error message "No device drivers were found" still comes up and I can't get any further.
    Where can I find the missing media driver?

    Edit to say: I tried browsing the drivers directory in the original Windows installation to see if it could find the driver it wanted, but no luck there.
    Last edited: Jan 20, 2018
  11. brooksa

    brooksa New Member

    Try This:
    You should not need the drivers until AFTER Windows is completely installed. A Google search tells me there might be something wrong with the install USB:
    https://support.microsoft.com/en-ca...uter-needs-is-missing-or-a-required-cd-dvd-dr

    Can you re-create the install media using a spare USB drive (8GB or >) and try again?

    Also use one of the USB 2.0 ports and avoid the blue one for the install.
    Last edited: Jan 20, 2018
    Sally3 and Villa like this.
  12. Sally3

    Sally3 New Member

    Unfortunately I don't have another suitable USB drive to hand. Have reformatted this one and created a fresh Install Media. But the same error happens.
    I'll get a new drive in the morning and try again.

    Thanks gain for your help - it's very much appreciated!
  13. brooksa

    brooksa New Member

    Did you try this: when it asks for driver, click Cancel. Once you are at the welcome screen, insert the USB drive to a different USB port. Then click Install Now to install.
  14. Sally3

    Sally3 New Member

    Yes, should have said I tried that. Put it in two different ports.
  15. brooksa

    brooksa New Member

    Boot into the BIOS by tapping the DELETE key while powering on and report the BIOS version when you have a moment.

    BTW - I created a Tutorial Page
  16. Sally3

    Sally3 New Member

    BIOS info:
    5.011
    UEFI 2.4; PI 1.3
    CHT0A 1.50 x64
    11/10/2016 11:44:27
    0.2

    I haven't checked for a later BIOS, this is a new unit bought from Amazon,

    Must sign off now, will be back in the morning.
  17. Sally3

    Sally3 New Member

    Success!
    I borrowed a new USB drive from a neighbour, created a fresh Install Media and it worked straight away. Have just connected the WiFi, all looks good. I will update the BIOS, but that can wait for the moment. I do have other drives but they have other jobs and I didn't want to overwrite them.

    I have no idea why the previous drive didn't work, other than it is a very old and slow 8GB unit. Think I will bin it to save further problems, they are so cheap now.

    Anyway, thanks again for your advice brooksa which has supported me to press on and get this done. (y)
    brooksa and Villa like this.
  18. brooksa

    brooksa New Member

    "nieghbour"? are you Canadian?
  19. Sally3

    Sally3 New Member

    No. There are "neighbours" in the Old World too. :LOL:
  20. Matti Broza

    Matti Broza New Member

    Hello

    How did you exactly move the partition to the right? i do not see any option , btw i did delete the 16meg partition