1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Just a disappointing

Discussion in 'Official Firmwares' started by Wush14, Oct 29, 2017.

  1. wrxtasy

    wrxtasy Well-Known Member

    There seems to be this "Myth" that just because ANY media players Tech Specs lists hardware support of a certain feature then it must be 100% true that the software can actually use those hardware feature out of the box.

    For example the NVIDIA Shield is well known as a 4K HDR capable device, but did you know it's Google's Nougat OS does not even have support for colorspace switching/conversions ?
    What this means is that to get correct SDR and then 4K HDR color outputs you have to manually each and every time dig deep into Android settings and manually change settings between BT.709 and BT.2020. That equals a long term PITA.

    4K DolbyVision Rips in a .m2ts container contain a seperate 1080p DV metadata layer. There is no external media player software I know of that can process this 1080p DV layer and output it to a DV TV. Don't believe the bullsh1t you read on forums like Reddit.

    https://forum.libreelec.tv/thread/1...lec-on-the-minix-u9-h/?postID=79839#post79839

    People that buy ANY hardware without first reading reviews to ensure a box can do things they might actually need like 4K Netflix, 4K Amazon Video, 4K YouTube are frankly Fools.

    At the moment the most advanced 4K HDR / DolbyVision media player in the market is the Apple TV 4K, due to some really nice features in it's Firmware.
    But it cannot do 4K HDR YouTube - just like the NVIDIA Shield.
    ATV 4K cannot output DV metadata from DV Ripped .m2ts container either nor can you directly install Kodi Krypton.
     
    Last edited: Feb 3, 2018
  2. CLT

    CLT New Member

    Wrxtasy is correct.

    Hardware specs are there but software needs catching up. No firmware support from Minix for DV.

    DV does not work on the U9, the .m2ts plays in kodi after installing add-ons, DV profile is active then it falls backs to hdr10.

    I have tested many devices, currently only way is to use Apple TV 4k running Infuse 5 can play DV files from local / network sources but you lose audio bitstream, no DA.

    If want DV and DA together (this what I am looking for) I can only get this working by using a usb drive attached to my LG TV and using media play app to play the file.
     
  3. Grencola

    Grencola Member

    Yeah, this is exactly what I've read and figured was the case. I only asked because CLT said:

    "Running LibreELEC 8 via SD card on it now. Everything runs very smooth, 4K HDR10, Dolby Vision and Dolby Atmos audio pass through via HDMI.

    Even auto resolution / framerate switching works now based on media format, the U9 plays 4K media up to 400mbps bitrate @60fps over the network."

    That sounded to me like he had figured out a software method of accessing the DV Metadata, that's all.

    CLT, I too can plug my external hdd into my tv and watch my 4k DV files but, again, since they're .mkv I only get hdr10 out of them :( You can confirm your tv is actually displaying Dolby Vision right from external? If so, then do I need to convert them to .m2ts? Have you tried mkv using your tv player? If I must change container types, would I need to start fresh and rip directly from source to m2ts or could I convert the .mkv's I already have (that show the 1080p dv metadata inside when I check with mkvtoolnix) instead? Have you tried .mp4? The official dolby site says dolby vision works only in .ts and .mp4, not sure if that still holds true or needs some updating.

    Thanks!
     
    Last edited: Feb 3, 2018
  4. CLT

    CLT New Member

    All my files are m2ts, they are untouched rips from uhd blu ray disk.
    Mkv - don't work (HDR10 only)
    Mp4 - don't know, aint got any mp4 DV files
     
  5. Grencola

    Grencola Member

    Ok Cool! Thanks! Which program do you use to convert the bdmv folder to .m2ts?
     
  6. CLT

    CLT New Member

    Am using DVDfab
     
  7. Grencola

    Grencola Member

    Thanks!
     
  8. Grencola

    Grencola Member

    Ok well, I got DVDFab up and running, but when I try 'UHD Ripper' to make a passthrough lossless .m2ts file, it removes the Dolby Vision data from the file because:

    "Due to lack of playback device which can recognize it from the non-Blu-ray video files, Dolby Vision, another HDR10 equivalent format, is not retained in the conversion process."

    Then it suggests that I use 'UHD Copy' method instead, which indeed does retain Dolby Vision, but it makes it an .iso file (which my tv cannot play) as it expects me burn a bluray disc :( Are you positive the .m2ts file that DVDFab made you retains Dolby Vision?!? Like your tv actually says Dolby Vision when you play the file? The program itself and the website and forums say that it doesn't. If you know of any little trick I'm missing, please help! Perhaps I can then convert the iso to m2ts somehow?

    Thanks! :)
     
  9. gufone

    gufone Big Owl Super Moderator

    Please continue your discussion about video conversion in an another thread. The discussion is deviating here.
     
    Grencola and Villa like this.
  10. Grencola

    Grencola Member

    Sorry! I was just excited cuz I was so close to figuring it out. I pm'd instead :)
     
    Last edited: Feb 8, 2018
  11. CLT

    CLT New Member

    Mine is on ebay since there zero updates and f**k all works.
    Upgraded to Nvidia Shield TV.
     
  12. midnight

    midnight Moderator Moderator

    Nothing works ?? ...... really ! :rolleyes:
     
  13. Harley777dude

    Harley777dude Member

    Love my U9!
    No disappointments here!
     
    midnight likes this.
  14. CLT

    CLT New Member

    yep (everything i purchased it for dont work or only works with hacks etc..)
    Netflix - No UHD, No HDR, No FHD - only 720p (before you say there's modified apk for FHD - aint interested in hacks or sideload - if the official app from PlayStore dont work then it dont work)
    Amazon - Same as above
    Google Movies - Same as above
    Kodi - keeps crashing (during playback / post playback - I play 50GB+ ISOs or MP4 or TS files) / and so many HDMI audio issues even tho the device as a Dolby license
    Plex - sucks on the U9, working fine on Nvidia Shield TV even works on my 4 year old Intel i5

    The fact its been on eBay over 2 weeks now and not sold - tells you the story. - only looking to get 50% back - am willing to write off 50%.
    Also MINIX team lie and lie about updates which will never be released.
     
  15. midnight

    midnight Moderator Moderator

    I use mine daily and my kids use one in the basement also..... if nothing worked, trust me, I would hear about it !;)
     
  16. CLT

    CLT New Member

    if you have low standards and considers this U9 as working then great for you.

    I upgraded to NS TV 2017 and everything the U9 cant do the NS TV does.

    PS - my kids rather used their mobile phone and £35 Chromecast than the U9
     
    Last edited: Mar 12, 2018
  17. skynet

    skynet Moderator Moderator

    Everything works here too.

    @CLT : Have you tried LibreElec ? Works perfectly.
    Only Netflix is limited to 720p ...
     
  18. Harley777dude

    Harley777dude Member

    Out of curiosity went on eBay to check out CLT's listing and didn't see it. All U9-H are new devices.
     
  19. CLT

    CLT New Member

    Hi skynet

    I was using LibreElec on the U9 - works quite well on the U9
    As there was too many compromises on the U9 I purchased a NS TV 2017 - which are wife and kid friendly and approved.

    I had high hopes for the U9, just let down down firmware / OS
     
    Last edited: Mar 12, 2018
  20. CLT

    CLT New Member

    am in the UK - check UK eBay - it's still there