1. Welcome to the official forum for MINIX devices!

Kitkat HLS configuration

Discussion in 'NEO X7' started by HardwareGuru, Apr 9, 2015.

  1. HardwareGuru

    HardwareGuru Developer Administrator

    Hello Guys.

    I hope you can help us solve the bugs in streaming.
    We introduced the first official kitkat firmwares for X5/X5min/X7/X7mini.

    You might noticed that inside the android settings there is a new option in Display settings called "HLS configuration" with the option to change to 0,1,2 and 3.
    ( Android Settings > Display > HLS configuration)

    We build this feature to make the firmware compatable with more streaming apps.
    Most apps will run just fine under the default ( 0 ).
    But when it does not you can try to set one of the other and see if your app will work.
    Mostly one configuration will work.

    What we would like to kow is;
    1. )
    Wich apps do not work with HLS configuration 0, and wich configuration they need to get working.
    2.)
    Wich apps do not work at all.

    Can you guys post the link to the playstore or .apk file and tell us at wich configuration it works or if they do not work at all?

    We need this information to improve HLS configuration 0(default) to suite more apps so people dont have to switch.

    Thanks a lot.

    PS.. please do not post apps that work good under HLS configuration 0 to keep this thread clean.

    The forum Dev Team;
    @gufone
    @KAR
    @HardwareGuru
  2. Villa

    Villa Well-Known Member Super Moderator

    What about app combinations?
    For example:
    When I use MX Player directly, all is ok with HLS config 0.
    When MX Player is accessed via my Synology NAS through another app, ES Explorer or Synology DS video, I have to set HLS config to 2.
  3. HardwareGuru

    HardwareGuru Developer Administrator

    Anyting out of the ordinary(0) is welcome ;)
  4. lardybarstow

    lardybarstow Member

  5. ati

    ati New Member

  6. arritrancos

    arritrancos New Member

    Hi,

    I tried Yomvi app on a Minix X7 with Comunity ROM 230 and it doesn't work on any mode (0,1,2,3) and any HDMI mode.

    More details, I have just posted at Thread Official ROM x7-kitkat-230, page-18 #post-47815

    I just try yomi app in 210 CE ROM (after flash it) and this app works!.
    Last edited: Apr 11, 2015
  7. oneofusers

    oneofusers New Member

  8. Toyoda

    Toyoda New Member

    Yelo play, Belgian Telenet tv app doesn't work with hls conf. 0 Works Well with conf. 1.
    Finally!

    Great job!
  9. Golgajack

    Golgajack New Member

    Hi. Tagesschau App video and audio out of sync. in HLS 1 ok.
  10. mgrthom

    mgrthom New Member

    Hi, I upgrade my Minix Neo7 to Kit Kat yesterday. 2 x Apps that were working on the previous firmware are not working correctly now. They are both Australian based television players. ABC's iview app has an audio / video sync issue. And Channel 10's TENplay app drops to a black screen with audio once the program starts playing, but is okay for the lead in advert. I haven't tried the other HLS configurations but will try them tonight with the apps and post. Sorry I am a new member and could not post links to the Apps in the Play Store .......
    MaxeL likes this.
  11. thewootts

    thewootts New Member

    All4 TV stream in UK not working? It asks for device reset.

    YouTube also not working on any his setting.
  12. gufone

    gufone Big Owl - Developer Super Moderator

    Please wait and test with the next ota.
    GI-Jou likes this.
  13. hacii

    hacii Member

    uyanik tv app is not working on hls 2 and higher
  14. hacii

    hacii Member

  15. benster

    benster Member

    Foxsports NL works great on hls 0 !! Perfect and finaly!!
  16. Villa

    Villa Well-Known Member Super Moderator

    Glad to hear it! But, in post #1, did you not read this...
    "PS.. please do not post apps that work good under HLS configuration 0 to keep this thread clean."
  17. Villa

    Villa Well-Known Member Super Moderator

    So, does it work on HLS 0 or 1?
  18. hacii

    hacii Member

    Only on hls 0 but then i have sync problems...
  19. Villa

    Villa Well-Known Member Super Moderator

  20. mohamed.awami

    mohamed.awami New Member

    Need help i cant seem to get streaming apps to work with any of the HLS configurations.

    CloudTV - The bundled app with premium package
    showbox apk