1. Registration issues have now been resolved. New accounts are able to be created

Kodi 17.3 extremely slow on Minix Neo U1

Discussion in 'Kodi/XBMC for MINIX' started by Juan Forero, Jul 26, 2017.

  1. Juan Forero

    Juan Forero New Member

    Hello everyone. I installed kodi 17.3 in the Minix Neo U1 but everything is very slow to open, it takes like a minute to open any folder. I use the integrated kodi and it works fine but the Kodi 17.3 doesn't. Any suggestions? Anyone has the same problem or it's just me? Thank you in advance for any help.
  2. orig1

    orig1 New Member

    Hi Juan

    I had similar issues with kodi 17.3, XBMC 17.3 and also with spmc 16.7. I have tried them all and they all were very slow. Movie search and some menus were very slow to open too.
    Kodi 17, xbmc 16.3 and spmc 16.6 were all OK and very fast. I have tried on another android box and it seem to have the same behaviour which made me think that the problem is the modem.
    I have then factory reset my modem and to my surprise, the latest version of kodi, xbmc and spmc were all back to normal and running fast again.

    Please try and reboot your modem first and if that does not help then factory reset it.

    Good luck.
    Last edited: Jul 30, 2017
    Juan Forero likes this.
  3. Juan Forero

    Juan Forero New Member

    Thank you very much, I will try that and will see if that works.


  4. Michael Ekborg

    Michael Ekborg New Member

    Modem? Do you mean the Minix box?
  5. Villa

    Villa Well-Known Member Super Moderator

    I think he is referring to router/modem!
    Michael Ekborg likes this.
  6. orig1

    orig1 New Member

    No, not the minix box.
    I meant your actual modem.
    A friend had a similar issue and we factory reset his modem over the weekend which solved the problem.
    More than that, certain modems were fine with the latest kodi/xbmc/spmc versions (the subtitle security version) while others required factory reset.
    All I am saying is that your modem may require factory reset, I am not saying it will solve your problem, but it worth trying.
    Michael Ekborg likes this.
  7. Nickel

    Nickel New Member

    i had the same problem with Kodi XBMC 17.3 alpha after i made several changes to the System settings. Minix started freezing so badly i couldn't watch anything.
    thankfully i had created a backup using the Backup Addon (in Programs); i uninstalled the Kodi XBMC 17.3 alpha, installed it anew and i restored the backup i had created 2 hours back - it's no longer freezing.
    i don't know exactly the setting that had caused the freeze, but one of the major changes i had made before the freezing started was to activate the rss ticker, and adding about 5 new rss feeds. it might be that, or something else, but it definitely had something to do with the Settings.
    From http://www.minixforum.com/threads/rss-player-issues-in-u1.17283/ it looks like it might be an issue with updating the rss addon.
  8. frankmar

    frankmar New Member

    I have a Matricon G-Box Q, which I was suppose to give it to my son, so I bought the MINIX U1, installed kodi 17.3 and came late to the party finding out fusion is closed. Any way I was able to get the necessary app. But find 17.3 very slow also I find the menu not high def as kodi 16.1 in my Matricom. Switch to Matricom box to compare and the matricom is fast. Is it Version 17.3 that is slow any reason. Is version 17.0 ok. tia