1. Welcome to the official forum for MINIX devices!

Kodi 17.6, Freezing, Out of Sync, Stuttering

Discussion in 'Kodi/XBMC for MINIX' started by Chris Richards, Dec 22, 2017.

  1. dabig25

    dabig25 New Member

    I just picked up a Minix U-9H because of the nice reviews it got. I just joined this forum and this is my first post on here

    Since I've gotten it my U-9H watching almost anything in Kodi 17.6 has been very frustrating. Was about to start a thread about the stuttering issue but have seen quite a few about this issue already on here. I also have an Nvidia Shield that I have no issues at all with.

    The issues with stuttering I'm having are ONLY when using Kodi. I also have a paid iptv service that I use and no playback issues at with it. I'm not even having buffering issues it's just the stuttering while streaming something on Kodi.

    Any more suggestions ?
  2. DylanMcD

    DylanMcD New Member

    Hi I also recently bought a U9-H and have been working through the same issues. You would hope that with the octocore processor you would get smooth playback but unfortunately it's not that simple.
    Luckily Kodi isn't the only game in town. I found that installing SPMC 17.6 alpha-2 helped my problems greatly, although my playback isn't problem free, it is greatly improved. See Marty's second last post for the location of the file. You will also need to go to Settings > Apps > SPMC and clear the cache every couple of days. You may also need to alter your settings (see rest of discussion).
    I have a question for the community myself - How does the SPMC update work? Will I be prompted, or will it be an option in Settings > Aps > SPMC, or will I need to uninstall and reinstall? And if so how will I know when a new compatible version is ready?
  3. Marty

    Marty Active Member

    Unfortunately you need to check if there are any updates manually, book mark this link and check back periodically, I have it sorted by date, newest on top:
    http://download.semperpax.com/spmc/android-arm/?C=M;O=D
    When an update is available download and install over the existing one and all data remains untouched.

    You will be looking for updates named SPMC 17 or SPMC Krypton.
  4. DylanMcD

    DylanMcD New Member

    Right, so sort by date and install the newest Krypton or higher than 17.6. Bonus points for preserving my data.
  5. DylanMcD

    DylanMcD New Member

    Is it normal to sometimes have to choose a couple of different streams before finding one with stable playback, or do most users usually get a stable stream on the first attempt?
  6. Marty

    Marty Active Member

    So, wife and kids have gone on holiday which gave me the whole weekend to test various ROMs and configs to get to the bottom of this issue. First up, I have only been testing on my trusty old X8H-Plus so what follows is for the X8H-Plus only!! This is for the Lollipop version by the way so don't attempt this if you are still on KitKat!!

    I have narrowed it down to the boot.img, what exactly is causing it I have no clue and would need more time to figure it out. Be warned, I have totally stripped down the original boot.img so the SMB has been removed, I will play around next weekend and see if this can be put back in without affecting smooth playback. So with no further a do, download the instructions in the following link and try it out for yourself, feedback appreciated so we can get Minix on board if this proves to be a solution.

    And as always, do so at your own risk, this is not for the feint hearted and comes with no support:
    https://www.dropbox.com/s/qxfcd94g5m0q2el/Ported boot.img Install.docx?dl=0

    Once you have flashed the boot.img then give SPMC a whirl:

    http://download.semperpax.com/spmc/android-arm/SPMC-spmc-krypton-1f9a682-armeabi-v7a.apk

    In the player settings of SPMC do the following:
    Set "Adjust display refresh rate" to Always
    Set "Enable HQ scalers for scaling above" to 100%
    Select "Allow hardware acceleration - amcodec"
    Deselect both MediaCodecs
    Set MPEG2, MPEG4, h264 and hevc to "Always"

    Restart SPMC and see if it makes a difference, this has given me smooth playback. If you have an airmouse then press "O" on the keyboard during playback to make sure amcodec is working, hardware decoding must show Active.