1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

KODI 17.6 immediately closes

Discussion in 'NEO U1' started by MrBig, Apr 19, 2018.

  1. MrBig

    MrBig Active Member

    My Son has a U1 and has had this problem since he purchased it. KODI will not run on his system.
    So I got the U1 from him and completely wiped and restored it to factory settings. I performed all necessary updates and downloaded KODI 17.6 from the play store. It installed fine. But when I run it, it shows the logo and immediately closes. I have removed the old XBMC and tried again with the same results.
    Is anyone else experiencing this and is there a fix for it? All android apps run fine with no issues and the U1 appears to be stable.
     
  2. pusb87

    pusb87 Well-Known Member Trusted Helper

    what youve tried seems right but if that were my U1 and a fairly clean install i would

    uninstall any apps i didnt want
    clear all caches
    reboot
    factory reset
    remove any apps i didnt want
    clear all caches
    reboot
    install kodi from the main kodi site and not the playstore
     
  3. midnight

    midnight Moderator Moderator

    I personally haven't had a lot of luck with 17.6 from the Play Store on my U1 or my U9. I've been using MINIX.. 17.3 version without any issues. I will say I just have a basic set-up, HDMI directly to the tv.
     
  4. pusb87

    pusb87 Well-Known Member Trusted Helper

    on my U1 17.6 from kodi.tv has been rock solid...i use passthrough using spdif
    on my U9 not so solid and kodi very occassionally just closes.... sketchy firmware ?
     
  5. MrBig

    MrBig Active Member

    I already cleared all caches, rebooted, factory reset and removed unneeded apps. Still same issue.
    I'll try the direct download from Kodi's website.
    Thanks
     
  6. MrBig

    MrBig Active Member

    I'm the opposite. My U9 has been rock solid with KODI 17.6 and pretty much any build or add ons I install.
     
  7. Adam Foreman

    Adam Foreman Member

    I have a MINIX NEO U1 too, and I run the Play Store version of Kodi 17.6 and it's flawless. In fact I have 2 U1's, one upstairs in my bedroom and downstairs in my front room. Both rock solid and no issues. The only thing I do is run the app by moving the data to the SD card. Kodi had a tutorial to tell you how to do that. That is the only thing I do differently.

    Sent from my Moto G (5) Plus using Tapatalk
     
  8. MrBig

    MrBig Active Member

    I'm storing to the SD card as well. I'm beginning to think it was a defective unit from the beginning. Because it randomly re-boots and locks up. Could have bad ram.
     
  9. Adam Foreman

    Adam Foreman Member

    I'm tending to agree with you. Sounds like a dud device from the store. Also, make sure that your SD card is fast ie class 10 or above. Anything slower will cause issues.

    Sent from my Moto G (5) Plus using Tapatalk
     
  10. Raghu

    Raghu New Member





    Sent from my iPhone using Tapatalk
     
  11. FullGlass

    FullGlass New Member

    I have the same problem with my U1. I'm with Kodi 17.6 downloaded from Playstore. Most of the time, it immediately closes. What I do is I try to run it again as soon as it closes, again and again. And eventually it will run and not closes anymore. Sometimes it takes me 3 to 5 times, but I think never more than 5 times and it will run smoothly.
     
  12. Adam Foreman

    Adam Foreman Member

    I'm not sure why your U1 doesn't run Kodi 17.6 from the Play Store. As I mentioned previously, I have two MINIX U1's and they both work flawlessly. Sometimes the U1 doesn't see the SD card and need to reboot it, but normally it runs fine.

    Sent from my Moto G (5) Plus using Tapatalk
     
  13. midnight

    midnight Moderator Moderator

    Perhaps try this
     
  14. shmbenisra

    shmbenisra New Member

    Don't use the arrow with the air mouse, use the button with the Android figure instead; drag the arrow to the icon of kodi and then push. At least for me it works.
     
  15. Richard L Cooper

    Richard L Cooper New Member