1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Let's share our experiences with installing the Spring Creators Update (1803)

Discussion in 'NEO Z83-4' started by Markus88, May 9, 2018.

  1. Markus88

    Markus88 New Member

    Hi all,

    So I had everything ready to install the W10 1803 update. I'd freed enough space and reserved some on an external drive. I was gonna do the update 'headless', meaning without a screen hooked up. I was using TeamViewer. I knew from updating my desktop (which updated flawlessly) that the pc would reboot a few times and end up back in Windows, with several prompts that ask you to set several privacy variables. I'd try to BS my way through those by hooking up a KB, pressing enter a few times, hoping to end up in W10 proper, where TeamViewer would load and I would take it from there.

    Didn't work.

    The Enters didn't result in TeamViewer loading, which I could see from my desktop. Hooking up a screen gave no picture. I even waited 15 minutes for that.

    So I shut down the Minix manually, started it up again and Windows told me it was rolling back the update. Fine, I thought. I'd just give it another go, non-headless this time.

    Only problem was that the attempted update had left so much clutter on the drive that I couldn't meet the free space requirements for a 2nd time. Deleting the hidden upgrade folders in the root drive and wiping SoftwareDistribution didn't help either. Pruned a lot of other stuff as well, to no avail.

    I ended up doing a complete reset of W10. Now, with as much free space as I can muster, I'm giving it a 2nd try. It's in the rebooting process now, so I expect it to work.

    32GB drives are large enough to store Windows 10 on, but the larger updates MS publishes are a complete pain in the ass to install with so little space. This would be impossible for an average user to do.

    In the meantime I found one workaround here: https://www.askwoody.com/2018/patch-lady-finally-got-an-hp-envy-8-note-5000-upgraded/ though I haven't tried it myself as of now.

    Share your stories and, hopefully, solutions here!
     
  2. skynet

    skynet Moderator Moderator

  3. Markus88

    Markus88 New Member

    Good to hear. I couldn't for the life of me get it to install with only a small handful of applications installed. When was your last fresh install?
     
  4. skynet

    skynet Moderator Moderator

    With my N42-C i just upgraded Win10 by OTA, i never flashed a full system. 2 major upgrades were installed (1709 and 1803).
    I let the maximum space on the small 32GB disk and no issue.
     
  5. Markus88

    Markus88 New Member

    Do you remember how much space you had before first downloading 1803? I had 8GB, which was enough, and also pretty much the max I could muster. On the 2nd try, I could not free up enough to get back to 8GB space again. Hence the complete reset.

    Mind you, again, this was with a handful of small programs installed and disk cleanup/ccleaner run regularly.
     
  6. skynet

    skynet Moderator Moderator

    I don't remeber exactly, but i'm sure it was more than 8 GB.
    Win10 was clean with only Kodi and MPC-HC installed, nothing more.
    I only use it to help people ;)

    Perhaps you can flash clean Win10 1709 then upgrade to 1803 ?
     
  7. Markus88

    Markus88 New Member

    My install is similar: QB, Plex, Sonarr, Radarr, PIA, Firefox. That's about it.

    I ended up doing the complete system reset from inside Windows. Even then I had to prune more stuff to free space. The reset resulted in a fresh install of 1709, after which I immediately updated to 1803 with few problems.

    Wonder how my drive got so full.
     
  8. mickwall

    mickwall New Member

    Hi

    I had made sure I had as much space as possible and 1803 installed with no problem


    Sent from my iPhone using Tapatalk
     
    skynet likes this.
  9. DylanE

    DylanE New Member

    Had a nightmare time trying to update:
    Got the low space error when using the upgrade assistant.
    Deleted files and managed to free 10Gb, still the update would fail.
    Then tried increasing the EFI system partition to 500Mb but messed that up and could not boot.
    Then had to use a recovery disk to get the device to boot.
    I then used the Windows 10 media creation tool to create a USB drive with all the windows 10 setup files on.
    I then booted into windows and inserted the setup disk, ran setup and the update worked! I also managed to keep all my data and programs intact.
    I really wish the disk was at least 64Gb so we did not have to fight so much to update.
     
  10. skynet

    skynet Moderator Moderator

    32 GB disk is a choice, we can have Win10 pro for a very small price. With a larger disk the whole system will be more expensive.
     
  11. Steven Burnand

    Steven Burnand New Member

    My update took a long time and I would call that re-install and not an update as it created another windows old folder. Apart from the long wait all is OK. I update the Intel video driver too. Cheapskate Bill Gates has no Bitlocker on Windows 10 Home, so still get that TPM nag on a systems info.
    Has anybody tried Linux on this box? If so, what is the best distro? I have increase the partisan, so got the EFI issue sorted.
     
  12. Villa

    Villa Administrator Administrator

  13. gdf

    gdf Member

    Are you referring to the Z83-4? .. I went down that route and MCT downloads the 1507 V and then goes about the series of updates SO for those trying itcould be for them as was for me a waste of effort .. I did get to see 14.6 GB of free space before the updates started … My guess and advice is to wait for the Minix Team to package an updated image file. My N42C-4 had no issues and is running very well.
     
  14. Agrelis

    Agrelis New Member

    I moved update folder to external disk, which is even encrypted. I'm using z83 headless, so I did everything through remote desktop. Update went completely successful, no worries about free space.
    Cant't post links. Google for "move windows update folder".
     
    Villa likes this.
  15. mr_lollix

    mr_lollix New Member

    My experience is very difficult to understand because is very different with my 3 Z83-4.
    With the first PC I have made a clean installation without any problem some time ago with win10 1709 and after that, it upgrade automatically to 1803 without any problem.
    With second PC I have made a fresh installation with a usb key made with media creation tool, installed all the driver and it work without any issue.
    With the third PC start the problem. I have tried to do a clean installation with usb, but during installation BSOD happened and installation failed. The EFI partition is gone so after I couldn't boot again to windows. After that i downloaded the win 10 image from this forum ( http://www.minixforum.com/threads/re-install-windows-10-os-on-minix-neo-z83-4.18759/ ) and after flashing it boot again into windows but with an extremely old version of windows.
    The problem now is that after every reboot it goes into BIOS and i don't know how to fix it. In the next days i tried again to do a fresh installation, hoping BSOD not happened again.

    Any suggestion on how to fix the problem are welcome.
     
  16. Dr Dave

    Dr Dave New Member

    Hi everyone,

    I have a NEO Z83-4, I did a clean install of the lastest Win 10 Pro and applied all the updates from Microsoft.

    All is good but the OS is not detecting the sound card.

    Any suggestions of how to fix it and get a driver for it?

    Thx,
    Dr. Dave