1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Malicious Subtitles Threaten Kodi

Discussion in 'Kodi/XBMC for MINIX Releases' started by antcj, May 24, 2017.

  1. antcj

    antcj New Member

    Hmm i think this has got off point. There are a lot of owners of the x8Hplus who cant upgrade and those are the people in trouble. Not owners of newer models of minix, that are able to upgrade
     
    Last edited: May 25, 2017
    dssv likes this.
  2. Cizzz

    Cizzz Active Member

    Im almost sure that some hack will become available soon. Can not be more than some lines of code.


    Sent from my iPhone using Tapatalk Pro
     
  3. Villa

    Villa Administrator Administrator

    Related to Thread title...
    Malicious Subtitles Threaten Kodi
     
  4. linuxlewis

    linuxlewis New Member

    Man, i have 2 Minix that i can't upgrade to Android 5.x and therefor can't upgrade Kodi. That sucks... Hope that you guys can figure out a solution...soon. i really love my minix

    Enviado do meu Nexus 7 através de Tapatalk
     
  5. bachikho

    bachikho Member

  6. midnight

    midnight Moderator Moderator

    Villa likes this.
  7. me who

    me who Member

    Since Minix seems to like to keep its customers in the dark most of the time, I hope they can now see the benefit in keeping their software up to date! Instead of putting down anyone who asks when they will release an update or if they are working on an update, hopefully they will provide useful answers! In the past all they say is why do you need the upgrade! Well I think this exploit is a darn good reason. Maybe many companies were caught with their pants down on this one but if Minix even had pants it would be out at the dump somewhere under 1 ton of garbage :) Hopefully they will find them so we can get an update!
     
  8. antcj

    antcj New Member

    Villa,
    Forgive me if ive got this wrong, but are you saying that all those stuck on kodi 16 ie with kitkat can now upgrade to latest kodi 17?
    If that is so all well and good, no problem.
    But im pretty sure if you have an x8hplus, (and possibly others, i dont know) at this point in time there is no fix.
    In which case this issue is not resolved.

    And yes there are other variants out there as mentioned above.
    Personally i run all new software via virus total and when i ran ebmc through it came back with malware. which makes me concerned.

    In any case this is up to Minix to sort out , who after all did promise 2 months ago to do just that and then have disappeared.
     
    me who likes this.
  9. pusb87

    pusb87 Well-Known Member Trusted Helper

    out of curiosity what trouble are those people in using minix software exactly...under what circumstances and how does it manifest itself ?
     
  10. linuxlewis

    linuxlewis New Member

    Man, this is spreading... I called the store were i purchased Minix, i have a good relationship with the IT guys that work there. They said that since the news came out they received a lot of calls asking what to do.

    Enviado do meu Nexus 7 através de Tapatalk
     
  11. antcj

    antcj New Member

    as the thread heading states.
     
  12. Cizzz

    Cizzz Active Member

  13. me who

    me who Member

    Frederick,
    You might want to open a new topic for your question! This is for he subtitle exploit that minix software will allow to install trojans! The other issue everyone has is the XBMC versions don't handle HTTPS sources! Come on minix, last official version was 15.3! There are addons that people use that don't run on their old verions! Being on these old version means that when exploits happen it takes much longer to get them fixed on our "top of the line" boxes! I think there are other issues too with surround sound or something that you can't do on this very old version of Android but can on the next version but that doesn't affect me so I can't speak to those issues. I will say that my U1 and Kodi 17.1 works much better than my x8h+ with minix xbmc but the processor on the U1 is less powerful but just newer. :( But the point here is Minix needs to address this exploit and inform its customers of its intenctions on this! The clock is ticking!
     
  14. antcj

    antcj New Member

    Me who, no you are wrong .
    The subtitle issue is fixed via kodi 17.2 if i remember correctly.

    If one owns an x8H plus then you cannot upgrade to 17. 2
    which means apart from not being able to use the HTTPS streams, one is also at risk from subtitles.
    Unfortunately we don’t all use the open subtitle addon.
     
  15. me who

    me who Member

    antcj,
    How am I wrong? Kodi 17.2 is NOT minix software! The minix XMBC version is 15.3, 16.3 minix XBMC is just a beta. I replied to Frederick question about what is wrong with MINIX software. If you have a x8h+ like I do then I am waiting for Minix to come out for something or at leaste let us customers understand what their plans are, or wait for another box developer to come out with a version that fixes it. I don't like to do this because these versions are designed to work on other boxes primarially but what other choice do we have Minix? Does everyone here the crickets??
     
  16. antcj

    antcj New Member

    yes in that sense you are correct, but to have the issues fixed we need to be on 17.2 at the very least and for that to happen minix need to get their act together and get us all on a level playing field. whether you install vanilla kodi 17.2 or minix version, makes no difference.
    Hypothetically If for example minix said that there are no more minix versions from them , but you can run kodi 17.2 :
    Are u going to stay on 15.3 with the current security issues and https problem or install vanilla kodi 17.2?
    If we were able to run vanilla kodi 17.2 i personally wouldn’t be posting here as it would be a non issue.

    Essentially that is what this thread is all about, putting pressure (some hope of that) on minix to do the right thing and enable us all to run a variant of 17.2.

    At the end of the day if you are on kitkat you are stuffed and that needs to be addressed.
    Currently minix are burying their heads.
     
  17. Villa

    Villa Administrator Administrator

    Kodi 17.3 is the latest update.
     
  18. linuxlewis

    linuxlewis New Member

    Indeed! I'm so happy that the guys that bought cheap Chinese boxes can download Kodi 17.3 and upgrade android. Meanwhile , in Minix Lands...But the quality, the quality...

    Enviado do meu Nexus 7 através de Tapatalk
     
    Ricki likes this.
  19. Ricki

    Ricki New Member

    This thread is so sad, I only bought my U1 in February.
    Everyone acts like we are supposed to know everything tge day we unbox it. Half the stuff I read is still jibberish that Im learning and there are so many of US out there.
    1 week in I registered the product. It said I'd get an email. I never did.
    I imagine it's very frustrating for those of you that speak the Android box language.
    Cheers
     
  20. midnight

    midnight Moderator Moderator

    Install the latest version of Kodi (17.3) on your U1 and enjoy your box (y)..... everyone here is at different levels of experience and knowledge, it will come ! ;)