1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

X8-H Minix freezes Kodi completly with NFS

Discussion in 'Kodi/XBMC for MINIX' started by rickklh, Jul 28, 2017.

  1. rickklh

    rickklh New Member


    I am new here, but used the forum couple of times for input. But now I am stuck. I have an X8-h Plus for while and used to run Kitkat with Kodi 16.3 most of the time without any problems, I connected it with a Synology DS716+II with NFS but after some time Kodi couldn't reach the NFS server anymore. UPnP was no problem but it doesn't work that well with subtitles etc. I thought lets upgrade to Lollipop with 17.3 so I did, clean install and it had also some trouble finding the NFS share but after some puzzling he found the share and I connected.

    Only now it hangs 9 out of 10 times when you start a movie, it freezes so bad you can't even ping the Minix most of the times. I made a Wireshark trace but couldn't find any strange things or errors, just Read call, read reply from and too the NFS share. The 10th time it will play a movie if I am lucky but most of the time it hangs. Only thing left to do is unplug and restart

    CPU3 is most of the time 100% in the log, do I have a faulty Minix or what else can cause this problem? NFS share looks fine, it is accessible after all.

    Hope you folks have any ideas, I am out...

  2. Nickel

    Nickel New Member

    i had the same problem with Kodi XBMC 17.3 alpha after i made several changes to the System settings. Minix started freezing so badly i couldn't watch anything. thankfully i had created a backup using the Backup Addon (in Programs); i uninstalled the Kodi XBMC 17.3 alpha, installed it anew and i restored the backup i had created 2 hours back - it's no longer freezing. i don't know exactly the setting that had caused the freeze, but one of the major changes i had made before the freezing started was to activate the rss ticker, and adding about 5 new rss feeds. it might be that, or something else, but it definitely had something to do with the Settings.
  3. Nickel

    Nickel New Member

  4. Villa

    Villa Administrator Administrator

  5. rickklh

    rickklh New Member

    I installed an old NAS to rule out the DS716, still the same issue. Difficulty finding the NFS and eventually it works but again extremely slow/freezes, I tried SMB and that works pretty good. So that is a good work around only it stutters slightly, you only see it when there are moving parts (cars, trains etc.) or zoom in or out. Otherwise it is hardly noticeable. Strange thing is that the FPS is between 40 and 60 constantly (on 720p or 1080p doesn't matter) so i don't understand how it is still possible to stutter slighty. Tried different player settings but no change unfortunately.

    Played around with the HQ scaler (default 20%) raised it to 80% no difference. Hardware acceleration disable makes it worse (seems logical) I believe Villa that the RSS feed has nothing to do with this (seems logical as well) I am clueless for now, not sure if this is 'fixable'
  6. rickklh

    rickklh New Member

    Final update: Unable to fix the stuttering... Unable to fix the connection to NFS. Tried the same settings with a basic LibreElec device with Kodi 17.3 and both problems didn't occur, NAS connected immediately with NFS and no stuttering so the problem is absolutely with the Minix or in combination with Android Lollipop. I regret to say but the Minix is going out the door and is not coming back unfortunately, it worked pretty good for a while but never without problems. I don't expect this problem is going to be solved.