1. Welcome to the official forum for MINIX devices!

Minix Neo X7 and ftp.

Discussion in 'NEO X7' started by ycancer, May 7, 2017.

  1. ycancer

    ycancer New Member

    Hi.
    Anyone has any good experience with ftp on this box or on Android in general? (And I noticed that 2.50 firmware has issues with external SDcard. Even if an empty card is plugged in, device won't start)
    I tried Andftp, total commander, and few others, but either connection gets lost (i. e broken) or down speed is slow using ethernet (much slower than normal).
    It's same whether I download to internal SD or to external SD.

    Poslano sa mog K4000_PRO koristeći Tapatalk
  2. Villa

    Villa Well-Known Member Super Moderator

    Well that's a first!
    I've never had any issues with an SD card and have never seen it reported here as an issue.
  3. ycancer

    ycancer New Member

    I know. I searched the forum when it happened. Nothing. But I came to live with it, since i store everything on NAS. Tried 3 different brands (Kingston, Toshiba ans no-name). Stock firmware has no issues.
    Any ideas about ftp?

    Poslano sa mog K4000_PRO koristeći Tapatalk
  4. Dr Goodvibes

    Dr Goodvibes The Doctor

    So if we wrap what I currently know around FTP and the Minix X7 and then start to work outwards.

    Model: Minix X7
    Firmware: 2.4.0 (Android 4.4.2)
    SD Card: SanDisk Extreme 45MB/s U1 32GB. (Benchmarked at 45/37MB/sec seq read/write )
    SD Card IO: 14/7-14MB/sec read/write (Minix X7)

    ftp> put "The Martian-2ch.mkv"
    local: The Martian-2ch.mkv remote: The Martian-2ch.mkv
    200 Command PORT okay.
    150 File status okay; about to open data connection.
    226 Transfer complete.
    841101359 bytes sent in 116.73 secs (7036.6 kB/s)
    ftp>

    FTP from an 'olde' QNAP TS-112 NAS provides a binary download of 56.2Mbit(~7MB/sec write/download) over 1Gbit Ethernet to the Minix X7 SD card.
    This is effectively a download to the SD card of a 821MB movie file.
    This takes ~2mins.

    I use FTP Server Pro for testing bandwidth on Android devices and their storage, also for large file downloads.
    I use Solid Explorer built in FTP client on an Android device to upload/download large files from servers/NAS.

    Using what I know, a file download to a 'good' SD card could expect a write/download speed of ~7-10MB/sec over 1Gbit Ethernet.

    I've not seen or noted any SD card nor FTP problems within the known limitations on the Minix X7 running firmware 2.4.0
    Firmware 2.4.0 worked well, so never upgraded to firmware 2.5.0
  5. ycancer

    ycancer New Member

    thank you for your information.
    I was referring (thinking) of ftp-ing to Internet, does solid explorer works?
    Whichever I tried, wasn't able to complete download for a file larger than 1gb.
    Here comes strange part. The same microsd card, plugged in usb adapter and then into minix works well. Tested this weekend.
  6. Dr Goodvibes

    Dr Goodvibes The Doctor

    That's the beauty of an Internet standard, FTP is just FTP and it works as expected in any known environment. (That's the theory)
    So, yes, FTP works fine over the Internet using Solid Explorer file manager.
    I've only used it to transfer 1-10MB files, so no experience with 1GB files over the Internet. o_O
    Solid Explorer transfers 32GB blu-ray files over the LAN using FTP without problems.
    I think Solid Explorer is one of the best file managers and I was an ES File Explorer refugee after it went bad a couple of years ago and turned into a pile of steaming brown stuff.

    FTP over the Internet 'should' be fine, BUT you are subject to the ISPs and the Web providers and there access-list/throttling/restriction on IO AND/OR any firewalls in your path.

    I'm not going to test a 1Gbit Internet sourced file download ...but... I would expect it to be OK to/from a well supported site, where the data is written to the Minix X7 on a (good quality) SD card. :)
  7. ycancer

    ycancer New Member

    You are right in almost every aspect. But when desktop pc and Filezilla works as they should (i.e. reconnect, resume) then one expects the same with all platforms. As you said, all isp factors should be the same for ftp.
    So i assumed it was app issue and sdcard slot/firmware.
    But i will try solid explorer. I too find es little bit too much sometimes
  8. Dr Goodvibes

    Dr Goodvibes The Doctor

    Give it a go and see how things pan out.
    I'm not sure any Android FTP app has a reconnect and continue service.
    That said, FTP is designed for slow and unstable connections with TCP.
    Interested myself, as some of the previous FTP apps you've tried are fairly good too, so if Solid Explorer can provide the service, it bodes well going forward.

    Update

    OK, I admit it, curiosity got the better of me. :whistle:

    Solid Explorer FTP

    Moved a 802MB movie from my NAS to the Minix X7 SD card.
    Uploaded a 802MB movie to an Internet site somewhere in the USA at 128Kbit and two hours later....
    Deleted the original movie file from the Minix X7 SD card.
    Renamed the movie file on the Internet site.
    Then downloaded the 802MB movie from the Internet back to the Minix X7 SD card and compared the checksum.

    Same. All OK.

    So what does that tell me.
    Well on a 'normal' (really slow upload of ~128Kbit) Internet connection, after a 802MB movie had been uploaded and downloaded from the Internet, back to the SD card, it was verified via checksum to be the same file.

    So... crap Internet connection and there's a chance of corruption or the file not being downloaded.

    Will Solid Explorer FTP client be able to retain a file in a queue for later restart/continue like Windows FileZilla??

    I don't think so and you'd have to check with the developer.

    I rebooted an ADSL2 modem during an FTP download while using Solid Explorer FTP and it didn't resume/continue the download afterwards.
    I could see no obvious way of 're-queuing' the existing FTP download, so it just failed. :eek:

    You probably need to check each FTP client on Android and/or find one that states it re-queues a failed file download and can restore from that point of failure and continue.

    I did the same ADSL2 modem reboot while using Windows 10 FileZilla FTP and after the reboot FileZilla FTP reconnected and continued the download to successful completion.

    Good luck with trying to find an FTP client that can reconnect and continue a failed FTP download.. ;)

    Update

    I have just downloaded and checked FtpCafe FTP Client
    and that has a resume feature.
    I did my test of rebooting the ADSL2 modem during the download and then restarting the FTP download and this app has a list of options, one of which is resume.
    I was able to resume at 42% download and completed the FTP download to Minix X7 SD card successfully.
    FtpCafe FTP Client also looks like it's being actively maintained with 2017 updates.

    Sent from my NEO-X8H-PLUS using Tapatalk
    Sent from my Window 10 Intel NUC i5 using eight stubby fingers.
    Last edited: May 16, 2017