1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

MINIX NEO Z83-4 V1.7 BIOS Update

Discussion in 'NEO Z83-4' started by MINIX - John, Mar 1, 2018.

  1. MINIX - John

    MINIX - John MINIX Team Member Administrator

    Official V1.7 BIOS for MINIX NEO Z83-4 is available to download from the link below:


    Fast MEGA link : https://mega.nz/#!Ngg3CTzY!LNBwh4Wu7nDQqo2bk4IhKSbtyHKqXiNe71_7-G1Dn0Q

    Update Procedure

    1.) Download the V1.7 BIOS zip package.
    2.) Extract this package to your Windows' local storage, e.g. Desktop.
    3.) Run the "update.bat" by double-clicking it.
    4.) Choose "Yes" to proceed when Windows prompts for your administrative rights.
    5.) Patiently wait for the update to complete, DO NOT disconnect the power source during the process or the BIOS will be corrupted!
    6.) Restart the system to take effect, please notice that the system will restart for several times before re-entering the OS.
  2. Electric_Bikes_Pdx

    Electric_Bikes_Pdx New Member

    When I click on the link, it does not work. For some reason, the ':' after 'ftp' is not there. Link works when I add the ':' manually.
  3. Electric_Bikes_Pdx

    Electric_Bikes_Pdx New Member

    would you verify that 'update.bat' file is in the download?
  4. Leonell Dayao

    Leonell Dayao New Member

    It does not have update.bat
    But it has a.bat which calls efi shell for bios update. my guess is that you can copy afuwinx64.exe and afuwinx64.sys from older releases and modify bat file to use latest bios file and afuwinx64.exe.

    @MINIX - John , what's new in this release? do you have release notes? I will wait for it before updating.
    rodrigokfw likes this.
  5. Alexdroid

    Alexdroid New Member

    Hello the link does not work
  6. Oldman-Ich

    Oldman-Ich New Member

    Hello, the link does not work and the a.bat does not work properly.
  7. Sa7375

    Sa7375 New Member

    Hi John! Your link for the "latest Windows 10 OS image for MINIX NEO Z83-4" on Thursday at 3.03 AM on another post works fine: regrettably, the link for BIOS ver v170 (above) is still not working.
    Last edited by a moderator: Mar 3, 2018
  8. Villa

    Villa Administrator Administrator

    I found I had to copy the link text in to a new tab and then it will download!
    MINIX - John likes this.
  9. ChevyZ83

    ChevyZ83 New Member

    Well I tried to post the correct link for you, but it seems I cant :oops:

    If you try to clic directly the link in the address bar, you end up with an fff te pe // link.
    If you try to copy/paste the link in the address bar, you end up with an Hache Te Te Pe link.
    You should replace it manually with an fff te pe :// instead.

    Wow that was hard ! I hope you understand the "code" above... Whatever form of abbreviated link I tried to write was detected as "sneaky link" :ROFLMAO:

    Hope it helps :)
    Last edited: Mar 4, 2018
    Villa likes this.
  10. darec

    darec New Member

    link work, bios work(y)
  11. darec

    darec New Member

    copy link a new tab and enter
  12. sattelite5

    sattelite5 New Member

  13. darec

    darec New Member


    Attached Files:

  14. MAS1

    MAS1 Member

    Change log ?
    mrbt and rodrigokfw like this.
  15. orlando1999

    orlando1999 New Member

    Hi, when i paste the link as text in a new tab, i get a login screen. With filezilla i get an expired certificate. At last with windows ftp it says 530 Login incorrect.
    Am i doing something wrong? Thanks!
  16. darec

    darec New Member

    copy link
    paste and go opera, or edge
    click green button download
  17. orlando1999

    orlando1999 New Member

    Thanks Darec, in Edge the image flicker one time, no download or message at all. In Chrome at least it ask me for Username and Password.
    Tried with WinSCP it says "Access denied".
  18. q2p0

    q2p0 New Member

    Unfortunately the link (the one from ftp.minix.cloudftp.hk) does not work.
  19. q2p0

    q2p0 New Member

    I have been able to download the oficial one.

    The problem was with my ISP, I tried from different browsers and OS.

    When I tried to download it with an android phone disconnected from the WIFI (Also copy the text and paste on mobile chrome) it worked and it did not ask for username and password. The file CHT0A170.bin contained in the @darec link has the same MD5SUM, so it is trusted, and the ZIP is better prepared for update than the original one.
  20. SAGB

    SAGB Member

    Wouldn't work for me either... This is the link I used...
    :-/ Frustrating.

    I got this to work though!!! :)


    Easy Option #1

    This works if you open note pad and copy the following code into it. Save it as Download.HTM on your desktop then double click the file and click the link.

    <a href="ftp://f104556.public:public@ftp.minix.cloudftp.hk/MINIX%20Z83-4-V170-update-BIOS-within-system.zip" download>Click Here to download Minix Z83-4 v170 BIOS Update</a>

    Easy Option #2:

    1. Click the “This PC”.
    2. Right-click in the right pane and select “Add a network location”
    3. Go through the wizard that appears and select “Choose a custom network location”.
    4. In the “Specify the location of your website” dialog, enter the address of the ftp server: ftp://f104556.public:public@ftp.minix.cloudftp.hk
    5. Type a name for this network location: Minix FTP
    6. Open the location :)
    7. Then look for this file: "MINIX Z83-4-V170-update-BIOS-within-system.zip"

    Option #3: (For those of you who would rather use an FTP Client)

    Download FileZilla FTP client and login using this in the host field and click quick connect:
    Then look for this file: MINIX Z83-4-V170-update-BIOS-within-system.zip
    Right click on it and select download. Then log out. (CTRL+D or Disconnect from the "Server" menu)


    1. Drag the file to your desktop, and extract it.
    2. Open the folder and find the Update.bat file. Click in the address bar and highlight the folder location minus the "C:" and copy it.
    3. Type in "command" in the search bar on the task bar and open a command prompt as an administrator by right clicking on it and selecting "Run as Administrator".
    4. Change to the directory where the Update.bat is located by using this command: CD\[paste folder name here] [ENTER]
    5. Type in "Update" and press enter, and wait patiently. (Please Read Note #5 and #6 at the top of this thread)
    6. When it is finished, type "Exit" then re-start your computer.

    Then come back to this site and like my post :)
    Last edited: Mar 17, 2018
    MinmanCM, Tonya, Seto and 2 others like this.