1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

MINIX NEO Z83-4 V1.7 BIOS Update

Discussion in 'NEO Z83-4' started by MINIX - John, Mar 1, 2018.

  1. orlando1999

    orlando1999 New Member

    Thanks for you help, i suppose that the encryption is the issue why the above mentioned method wasn't working on my computer.
     
  2. SAGB

    SAGB Member

    It is because their link is using the wrong HTML directive.

    It is also that they posted the wrong file name... The file name they posted doesn't have the software for the update, just the binary files. I posted the correct filename. And even then, their filename had a space in it so the location should have looked more like:
    ftp://f104556.public:public@ftp.minix.cloudftp.hk/MINIX%20Z83-4-V170-update-BIOS-within-system.zip

    Unfortunately their "add link" option does not include an "add download link" option. This works if you open note pad and save it as Download.HTM then double click the file and click the link.

    <HTML>
    <BODY>
    <a href="ftp://f104556.public:public@ftp.minix.cloudftp.hk/MINIX%20Z83-4-V170-update-BIOS-within-system.zip" download>Click Here to download Minix 783-4 v170 BIOS Update</a>
    </BODY>
    </HTML>

    I'm going to add it to my other post as another alternative. :)
     
    Last edited: Mar 10, 2018
  3. ciberciccio

    ciberciccio New Member

    Which of the two files :
    1) MINIX Z83-4-V170-update-BIOS-within-system.zip
    2) MINIX-NEO-Z83-4-BIOS-V170.zip
    present in the ftp site should be used?
    binary comapre shows that the two 'CHT0A170.bin' are different.
    md5 #1 : a6ea4d080f4479195df283cc4036e54d
    md5 #2 : eb0b73735e38aa8509e6e2ddfcd009cc
     
  4. SAGB

    SAGB Member

    MINIX Z83-4-V170-update-BIOS-within-system.zip is the only one with the correct software in it for the update.
    The BIN file date is newer as well.
     
  5. ciberciccio

    ciberciccio New Member

    Weird, they leave same name, and so bios version 1.70, but different content... no readme file, no info at all...
     
  6. emanuelsj

    emanuelsj New Member

    There is no "update.bat" file into the downloaded archive, but only an "a.bat" one. I tried to follow the procedure by launching this one, but a command prompt appears for less then a second, then it goes away. Anyway who managed to update BIOS, who could advise?
     
  7. ciberciccio

    ciberciccio New Member

    open a shell first, go to the dir where you put the files and run a.bat. You will be able to see the software output.
    Alternatively add a line at the end of a.bat with the command “pause”, it will pause batch file execution waiting for a keypress and allow you to see the output
     
  8. SAGB

    SAGB Member

    If you are using the file with a.bat, you are using the wrong file.

    There are three files on the FTP site:
    MINIX-NEO-Z83-4-BIOS-V170.zip
    MINIX NEO Z83-4 170version.zip
    MINIX Z83-4-V170-update-BIOS-within-system.zip

    The one you want is: MINIX Z83-4-V170-update-BIOS-within-system.zip

    Please see post: MINIX NEO Z83-4 V1.7 BIOS Update
     
    Last edited: Mar 15, 2018
  9. emanuelsj

    emanuelsj New Member

    Thanks, SAGB, I was able to find the correct archive here:
    ftp://f104556.public:public@ftp.minix.cloudftp.hk/MINIX%20Z83-4-V170-update-BIOS-within-system.zip
     
  10. mlweb

    mlweb New Member

    Thanks, that works.... But
    What's new in this Bios V170?
     
    rodrigokfw likes this.
  11. SAGB

    SAGB Member

    I'm not sure, but I haven't noticed my SD card slot cut out since the update. Hope that is one of the fixes. I will just have to see how it goes.
     
  12. Seto

    Seto New Member

    John - can you please provide the Change Log for this update.
    Several people at waiting to see this.
    Thanks.
     
    rodrigokfw likes this.
  13. Joetheman

    Joetheman New Member

    It worked but it rebooted three times at the minix splash screen, I thought it was going to brick. But all good Thx!
     
  14. MINIX - John

    MINIX - John MINIX Team Member Administrator

    The rebooting is to be expected. As mentioned in the update procedure the system will restart several times before re-entering the OS.
     
  15. SAGB

    SAGB Member

    Also note that you may need to change some of the start up features in the BIOS after the update (start on A/C power and start on LAN) if you do not want them active. When I adjusted mine the first time I had an audio glitch (no sound) but it has since corrected. The second machine I updated, it failed to use the correct video port until I unplugged the HDMI cable and plugged it back in (scary because all I had was a black screen). Just minor side effects.
     
    Last edited: Mar 20, 2018
  16. rodrigokfw

    rodrigokfw New Member

    what is the changelog?
     
    mrbt likes this.
  17. passage52

    passage52 New Member

    I wish that some of the Links would just work without all the confusion,[bios upate, win10 updates] click on the link, download file and install, instead of trying to paste, copy,ftp,and every other confusing instruction in the book!!!
     
  18. Dalaienator

    Dalaienator New Member

    Perfect, download ;)
     
  19. Sa7375

    Sa7375 New Member

    Hi SAGB,

    For me, everything worked perfectly and without any hiccups. The link mentioned in your Option #3 worked by copying & pasting that link into another tab in Google Chrome. So thank you for a very precise tutorial.

    After the update, my BIOS reads as BIOS 5.011 dated 2017-04-10. Is this how this should be?

    A quick question on booting from a USB drive. I have a USB UEFI bootable disk (for Acronis) and despite configuring it in the BIOS as the No.1 device for booting it doesn't boot from there. Any ideas?

    Thanks
     
  20. Villa

    Villa Administrator Administrator

    You should be looking at...
    Project Version CHT0A 1.XX x64