1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

MINIX NEO Z83-4 V1.7 BIOS Update

Discussion in 'NEO Z83-4' started by MINIX - John, Mar 1, 2018.

  1. Sa7375

    Sa7375 New Member

    Thanks. My one is showing CHTOA170. Would that be correct?
     
  2. Villa

    Villa Administrator Administrator

    (y)
     
  3. Sa7375

    Sa7375 New Member

    Wonder if you have some experience with imaging. I have an Acronis 2016 UEFI Bootable USB-stick. It boots fine but doesn't see the internal eMMC drive, hence I can't create an image of Win 10. Any ideas? Thanks in advance.
     
  4. Crispy

    Crispy New Member

    Running the update.bat I get

    update
    C:\Users\******\Desktop\MINIX Z83-4-V170-update-BIOS-within-system\MINIX Z83-4 V170 update BIOS within system>afuwinx64.exe CHT0A170.BIN /P /B /N /X /R
    +---------------------------------------------------------------------------+
    | AMI Firmware Update Utility v5.08.00 |
    | Copyright (C)2015 American Megatrends Inc. All Rights Reserved. |
    +---------------------------------------------------------------------------+
    46 - Error: Problem getting flash information.

    Any ideas?

    C
     
  5. Crispy

    Crispy New Member

    Sorry - Disabled BIOS protection and it ran. But still no SD Card! Arrrrgh!

    After a full OS wipe and reinstall, about eight hours of windows updates and BIOS update I find that a little disappointing.
     
  6. Villa

    Villa Administrator Administrator

    Last edited: Apr 6, 2018
    Sa7375 likes this.
  7. Crispy

    Crispy New Member


    So back to an unsigned win8 driver. http://www.minixforum.com/threads/possible-solution-sd-card-problem.16628/ - incidentally I found it necessary to disable driver signing at the BIOS level, test mode alone was not sufficient.
     
  8. Sa7375

    Sa7375 New Member

    Thanks, Villa. Your help is greatly appreciated.

    Going the WinPE route was much too long, hence I tried creating a boot disk with Acronis TI 2017 that solved the problem. It worked flawlessly and I was able to successfully create an image of my W10 in under 4-minutes.

    To benefit others, I've created and posted my experience in a new thread titled "Creating USB Boot-Disk (Step-by-Step) and Acronis Imaging" about 30 minutes ago.

    .
     
  9. Villa

    Villa Administrator Administrator

  10. mrbt

    mrbt New Member

    Change log for this bios update??
     
  11. Dome

    Dome New Member

    not working.

    I downloaded, yes and placed into C: however, despite I ran it as administrator and authorized to proceed after win 10 security warning, nothing happened.
     
  12. Markus88

    Markus88 New Member

    Any update on this? I just found this update and I'm hoping it'll resolve the cut-outs with external storage that still bug this machine on a daily basis.

    Edit: context here http://www.minixforum.com/threads/usb-3-0-drive-randomly-disconnecting-reconnecting.15061/

    Edit2: installed this update, will test this myself as well
     
    Last edited: May 1, 2018
  13. SAGB

    SAGB Member

    So far, I haven't had it cut out on me since the update, but I have had other drives attached to my USB 3.0 hub cut out (probably something to do with the power save on the hub itself). But I will keep watching for it. I haven't been using my machine as frequently. I've been busy.
     
  14. Markus88

    Markus88 New Member

    Alright. Thanks for the info! I always got frequent cut-outs with my external HDDs (1 usb 3.0 dock for 2 drives) on the usb 3.0 port and less frequently on a usb 2.0 port. Had no cut-outs since the update, but it was always random so I'll need to keep it all running for a while longer before I'm confident it's gotten better. Then I'll try the 3.0 port again as well.

    Would be nice if Minix would just give us a changelog. 'Yo we fixed the external storage connectivity issues, peeps' would be enough.
     
    mrbt likes this.
  15. Eddga

    Eddga New Member

    Could please somebody upload the BIOS update files on a third party one click hoster like Mega, or zippyshare?
    It's just frustrating that a manufacturer seems not to be able to provide a working and simple way to download a BIOS update for ones product.
    I'm not getting the download to work as I'm told that the login credentials were wrong. Tried everything SAGB described in his post on the end of page one in this thread.

    Thanks in advance.
    Best regards
     
  16. skynet

    skynet Moderator Moderator

    I will do it, but as you said the credentials changed;

    @MINIX - John : Can you check it ?
    Connection is OK but login is not.
     
  17. Markus88

    Markus88 New Member

    Darec's post on page 1 contains a txt file with a link to a polish host where he uploaded the correct archive. I just checked it, it works.
     
  18. skynet

    skynet Moderator Moderator


    Here is a working MEGA link : https://mega.nz/#!Ngg3CTzY!LNBwh4Wu7nDQqo2bk4IhKSbtyHKqXiNe71_7-G1Dn0Q
     
    Eddga likes this.
  19. Eddga

    Eddga New Member

    Ah Nice. Didn't see that one. But now already used @skynet 's link.

    Thank you very much!
     
  20. dpjanda

    dpjanda New Member

    USB update?

    Is it possible to update via USB?

    Am on alternative OS, so cannot go the windows route.

    Regards