1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

MINIX NEO Z83-4 V1.7 BIOS Update

Discussion in 'NEO Z83-4' started by MINIX - John, Mar 1, 2018.

  1. MarcoDruid

    MarcoDruid New Member

    Hello,
    are there any special settings to configure to improve the Minix?
     
  2. archblaze

    archblaze New Member

    I just applied the BIOS update for V1.7 yesterday and then I noticed that my firmware also needs updating. The last firmware update came with the V1.6 BIOS update. Will it be okay to apply V1.6 over V1.7 to get the firmware update?

    I just recently applied the V1.7 BIOS update but then found that my firmware needed updating as well. Would it be okay to apply the V1.6 update over the V1.7 install I just performed? V1.7 did not update my firmware so it looks like I need to use the V1.6 update to do this.
     
    Last edited by a moderator: May 18, 2018
  3. raster23

    raster23 New Member

    A couple of updates:

    1. It is possible to apply this update on a non-windows machine. Follow the instructions here: http://www.minixforum.com/threads/recommended-z83-4-v1-66-bios-mcu-firmware-update.16421/

    a. download the above firmware folder and extract it to a USB drive with a fat32 format.
    b. copy CHTDA170.bin from this (170) bios update
    c. edit the update.nsh file as follows:

    Code:
    @echo "Notice:auto shutdown after update successed! "
    AfuEfix64.efi CHT0A170.bin /p /b /n /x
    d. boot off the usb and run update.nsh, as described in detail in the instructions in the above link.

    2. My bios is now the latest, but sadly I still have issues with usb3 drives disconnecting and reconnecting. I was and still am hopeful that minix will fix this issue.
     
  4. Wonko

    Wonko New Member

    @raster23

    Can I ask what version of Windows 10 Home you are currently running.

    I ask because in the one 2 feature updates ago (16xx I think) there were definite issues on my Z83 with the USB 3 port, the update to 1703 fixed these, after this update was installed the only remaining "disconnects" were caused by my external drives power saving/sleep mode, and these were not "disconnects" in the sense that the drive would disappear, only that it would take a while to respond and lock up the system until it did, which was easily fixed.

    I also have a Z83 running the current "BIOS" and USB 3 has no issues I am aware of, so if you are up to date, the issue persists, and it's a case of the drive disappearing from file explorer rather than just not responding immediately after it's been idle, then it would seem possible you have a hardware issue.
     
  5. raster23

    raster23 New Member

    I'm running ubuntu, not windows, so there may be some kernel issues. That said, I'd be interested in the kinds of transfer rates you're getting on Windows 10. I don't see anywhere near what USB 3 should be delivering .. copying across disks was around 10 MB/s.

    I'm using the z83 primarily for file storage, and the disconnects occur during file writes.
     
  6. Wonko

    Wonko New Member

    @raster23 I can copy from my NAS into a drive connected to the Z83s USB 3 port at 100Mb/s plus - I assume the limit is largely down to my networks speed - nothing moves much faster than 100-120Mb/s. I can sustain this for the time needed to fill a 4TB drive, which is several hours. Under Windows 10, running the current updates, on either BIOS 1.3 or 1.7, there doesn't appear to be a USB 3 issue on the Minix Z83-4, at least not on my one.

    *Insert - I typically got about 40Mb/s copying between a USB 2 port and the USB 3 port, the limitation obviously caused by the USB 2 port, this was faster than expected.

    The Z83's primary purpose has been as a kodi player, connected to an external drive, plugged into the USB 3 port, loaned to a friend, I've had it for over a year, or rather they have, with no reported issues other than the external drive dropping into standby and playback stuttering when pulled out of pause (easily fixed once I was aware). It came back a couple of months ago when I upgraded them to a Beelink S1, as it had windows update issues, and prior to any updates I did come to the conclusion the USB 3 drivers were a tad iffy, not on the scale you are describing but not quite right, but as soon as I updated it to 1703 these went away.

    If I was in your position I'd image your emmc to an external drive using a PE version of macrum reflect (to keep a copy of your current running setup), install windows 10 using a current windows 10 MS download, install all the drivers which are available on here somewhere, and do a test. |That is the only way you'll know if you have a faulty unit, or a faulty ubuntu driver.

    It will probably take a couple of hours to back up your current configuration and install windows 10, several hours to test (or until it fails if it's going to), and 20 minutes or so to copy your current configuration back in.

    But that's the simplest way I can think of to establish if the problem is hardware/firmware or a ubuntu driver - assuming of course you are confident in using disk cloning software.

    ETA - if you get stuck I may be able to try a test under ubuntu, somewhere I think I have a live usb version, I haven't used it for that sort of thing, I only had a brief play, and I'm not really a Linux person these days, but it should be simple enough to run a similar test even for me. Of course if it fails I will have no idea why, only that it didn't work ;)

    ETA2 - come to think of it I did previously have another Z83, that did have issues copying files to/from usb, under windows 10, no idea if it was USB 3 specific tho (I think the main error message was something like insufficient space on destination drive, copying to an empty usb device - telling it to try again generally worked but definitely a problem was there), it was also slower, I put the 2 side by side and compared and it was significantly slower - I came to the conclusion that either the emmc was faulty, the ram was faulty or the usb controller was faulty and so returned it.
     
    Last edited: May 22, 2018
    raster23 likes this.
  7. raster23

    raster23 New Member

    I'd love to resolve, but I'll probably not install windows 10. I've ordered a USB3 hub, as some have reported that putting the hub between the drive and minix resolves the issue. I've also tracked down some posts related to Ubuntu and Cherry Trail which is probably the real problem. Seems there's 2 implementations for the USB3 spec, and the latest ubuntu releases implement just 1. I'll update here if I manage to resolve.

    Thanks very much for the detail, that is super helpful.
     
    Wonko likes this.
  8. raster23

    raster23 New Member

    I think I've found a work around on Ubuntu for USB3 device timeouts. I was seeing the device reset under high write loads:
    ...
    usb 1-2: reset high-speed USB device number 2 using xhci_hcd

    I came across a thread for archlinux with a similiar issue, and their solution was to disable the read-ahead portion of the driver. In ubuntu it's applied like this:

    Code:
    root@media2:~# cat /etc/modprobe.d/usb-storage.conf
    options usb-storage quirks=4971:8034:u
    where 4971 and 8032 are the vid and pid for your drive. Then rebuild the kernel:

    Code:
    update-initramfs -u
    and reboot.

    After I wrote a 1 GB file to the drive, which would always cause the reset issue:

    Code:
    root@media2:~# dd if=/dev/urandom of=/mnt/storage/local_file count=2048000
    2048000+0 records in
    2048000+0 records out
    1048576000 bytes (1.0 GB, 1000 MiB) copied, 46.7285 s, 22.4 MB/s
    

    I'm still not convinced that I'm getting the transfer speeds I should be for a USB3/7200 RPM disk, but it's fast enough to stream video and for time machine. I hope this fix helps someone.
     
    Wonko likes this.
  9. Wonko

    Wonko New Member

    22.4mb/s would suggest you were copying from/to 2 drives plugged into the same usb2 controller, not one plugged into a usb3 and one plugged into a usb2, or doing a copy from the emmc to a usb device..

    but if it's stable and fast enough for your purposes......
     
  10. sland

    sland New Member

    Why on earth do we have to go through hoops like this? Bloody amateurish way of doing things!!!!!!!!!!!!!!!!!!!!!!!!!!
     
  11. Markus88

    Markus88 New Member

    I'm happy to report no cut-outs since this update. One torrent in QB randomly got errored, but that looks to be the result of data corruption from a previous, pre-patch cut-out.