1. Welcome to the official forum for MINIX devices!

Minix U1 FW13 - Finless superfast ROM 1.0

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by Finless, Oct 31, 2017.

  1. mark2

    mark2 Active Member

    Reflashed with update all working great fast as well
    Thanks @Finless great work
  2. Eligos

    Eligos New Member

    Bob, thanks so much for sharing your build with us, this is a really really fast ROM... like Libreelec fast!
  3. Sebby64

    Sebby64 New Member

    Bob, something like "Sentio Desktop" ... but more compatible (in sentio dont work resize font option for me) with minix functions... maybe weather widget transparent on desktop... minix launcher is so simply in my opinion...
  4. hayohoekstra

    hayohoekstra New Member

    Installed it, and it works like a charm. Super fast. After using it for 3 hours intensively I didn't find any bugs or any other problems. The only issue I have with this rom and the minix rom is that my location doesn't seem to work. Anyway, thanks Bob for the knowledge and energy you put in it.

    Verstuurd vanaf mijn SM-G930F met Tapatalk
  5. Eligos

    Eligos New Member

    Rocksolid for me so far, no freezes or crashes running latest Kodi for android and Plex Kodi addon.
  6. John69

    John69 Member

    How to "install" this ROM ?

    Is it possible later on to go back to original ROM ?

    Is anyone checked if "AirPin" is working with iOS 11 and youtube ?
    KellyND1 likes this.
  7. mark2

    mark2 Active Member

    First download the rom on page 1 extract/unzip
    Download this if you want to go back to original also includes the USB burn tool you will need on the page
    http://www.minixforum.com/threads/neo-u1-fw013-20170629.17083/
    Now get your otg cable supplied with the U1 connect cable between box and pc/laptop plug in the power adapter
    switch on U1 now open USB flash tool windows will tell you it’s installed
    Pull the power from U1 then put back in power up U1 holding power button for 6 seconds
    The USB burn tool should say connect success top left select import file select the rom you downloaded and unzipped
    Select start and in just over minute and 40 seconds it should be done
    Once finished plug your U1 into tv connect up and away you go
    Don’t forget to follow any instructions that @Finless wrote in the opening of this thread
    As for airpin not tried I just use YouTube on the box (and breathe)
    KellyND1, John69 and pirsquared8 like this.
  8. Labsdj

    Labsdj New Member

    i Installl well this rom and go back without any problem works fine i want one rom to run from sd card like one linux version to trie on minix neo u1 i not found a link of any other rom for my minix neo u1
  9. SaEt9000

    SaEt9000 Member

    @ Finless - thanks a lot for sharing this innovative ROM.
    At the moment I am satisfied with my minix U1 with FW 013. minix xbmc 16.3 runs really well, kodi 17.5.1 runs also well with smooth video - although framerate-switching is not working.

    Thats why I am interested (before starting to test it by myself) - which tweeks or improvements has this ROM compared to the minix firmware - especially related on kodi 17.x? Is framerate switching working at this ROM at kodi 17?

    Thanks
    SaEt9000
  10. John69

    John69 Member

    Well I tried those steps, but my NEO U1 always get to "Android system recovery" where I can choose: "reboot system now, apply update from EXT, apply update from cache etc..."
  11. mark2

    mark2 Active Member

    How would you possibly see that menu with your U1 plugged into pc/laptop you are talking about trying to reflash with @Finless rom
  12. John69

    John69 Member

    Yes Finless rom; Well after several tries, I connect also HDMI cable to see what is going on and I see that screen. When I plug USB to Neo I heard sound that windows detect device...

    I tried everything,
    - Input power on NEO and USB connected to PC and then take power cable off from NEO and hold power button ON (6 seconds) and connect power again to NEO -> nothing detected inside "USB_Burning_Tool"
    - Input power on NEO and USB connected to PC and then take power cable off from NEO and connect power again to NEO and then hold power button ON (6 seconds) nothing detected inside "USB_Burning_Tool", but when I pressed power on button I heard windows sound that device is connected...

    USB_Burning_Tool is version 2.9.6.2 build 2, in both cases I first import "image" and then it should detect device so I can start procedure...
  13. mark2

    mark2 Active Member

    You are using the otg port on the box
  14. John69

    John69 Member

    Yes, of course.
  15. mark2

    mark2 Active Member

    Try this open burning tool connect otg cable between box and pc then connect power hold power button in for 6 or so seconds release the burning tool should say connect success
  16. John69

    John69 Member

    I tried, "burning tool nothing detect", I just heard windows sound when I'm holding "power button" for 6 seconds on NEO.
  17. Villa

    Villa Administrator Administrator

  18. mark2

    mark2 Active Member

    First time you run the burning tool did windows pop a box saying ready to use
  19. John69

    John69 Member


    It's like that (1.jpg)
    After I load image: (2.jpg)
    Then I tried to connect device as described before....

    Attached Files:

    • 1.JPG
      1.JPG
      File size:
      79.7 KB
      Views:
      28
    • 2.JPG
      2.JPG
      File size:
      87 KB
      Views:
      26
  20. mark2

    mark2 Active Member

    It seems you maybe letting go of the power button either too quickly or leaving it too long
    Keep trying as all you need to see in that pic above is connect success
    You could also try a different version of the burn tool that may help