1. Welcome to the official forum for MINIX devices!

Minix U1 FW13 - Finless superfast ROM 1.0

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by Finless, Oct 31, 2017.

  1. pusb87

    pusb87 Well-Known Member Trusted Helper

    Yes, I don't think he's holding the power button long enough.... 6 secs has never been long enough for me, more like 10-15 secs
  2. je73

    je73 New Member

    This sounds really interesting as I'm really interested in getting a cleaner build.
    I only use my U1 for Kodi, netflix and Youtube. As playstore now works I take it it handles the last two?

    How is it with 4K videos on Kodi 17.x? On the minix 17.x build the video stutters alot and I couldnt seem to get 4k resolution.

    My set up is, all my videos are on Nas drives (SMB & NFS) and the U1 is connected to a Onkyo TX-NR626 which is then connected to the TV (Samsung 4K).
  3. Dirtylarry

    Dirtylarry Member

    Im curious if anyone has any screenshots of it or video? Mine is still stock but curious to install this.
  4. DutchDiversion

    DutchDiversion Active Member

    Installed just fine here.
    After install, had a small bootloop, in which the Astronaut showed for a few seconds, and then the box restarted.
    Fixed this by clearing the cache, good to note for others.

    to clear cache:
    Power down the U1 (if you cannot because of the bootloop, just unplug the cable and re-insert.
    Hold down the power button for more than six seconds (I usualy hold it for 10)
    Chose the Wipe Cache Partition Option in the menu shown.
    Chose the reboot system now option (top option).

    All was fine after that, will run soms tests over the coming days.

    Thanks for the Rom Finless, greatly appreciated!
  5. John69

    John69 Member

    Tried also that for 15 or 20 seconds but nothing; perhaps is cable as I can not found original one, but I have at least 6 different USB cables; what I'm not sure if they are OTG; but if cable is not the right one then PC should detect it in "device manager" ?
  6. mark2

    mark2 Active Member

    The cable could be your problem as some OTG cables are for data some are for charging
    the Minix OTG cable the tip where you push into the box is just that little bit longer
    i read somewhere you could try cutting back a small bit of the black plastic so the tip goes in a little further
    worth a try good luck
  7. Dave500

    Dave500 New Member

    I can't get Netflix to work. Says Netflix doesn't work with this version.
    Is there A version I can download?
    Last edited: Nov 10, 2017
  8. Hayo

    Hayo New Member

    It seems that location works fine with WiFi turned on. If I use the ethernet cable, witch I normally do, location is not working...
  9. John dejevij

    John dejevij New Member

    Works like a charm, thx Finless!
  10. Swigger

    Swigger New Member

    Flashed great, but I had to install Jarvis instead, as Kodi 17.x was still a bit jittery for some streaming apps that don't seem to lag/jitter on Jarvis.
  11. indashmp3

    indashmp3 New Member

    Just installed it..no problem. Couple questions..
    1.) I am using a VPN (or at least I am trying to). I was able to have the VPN working fine through a manual L2TP. ON official Fw13 I never had the VPN indicator in the top of the interface turn green, ,although I verified the VPN was working via "whatismyipaddress". I decided to try this ROM to see if that helped. It did not. One thing that changed though, is with this FINLESS rom I cannot access my LAN when the VPN is connected.
  12. sojourner353

    sojourner353 New Member

    Thanks Finless, been hoping for a U1 Custom ROM for ages and now this box is perfect thanks to you.
  13. arko

    arko Member

    Installed without any problems and works like a big charm but ViperFX still dont work with KODI.
    I rembember your roms #Finless on Minix x8 and there was not any problems beetwen ViperFX and Kodi.
    It is possible for you to make any fix for that?
  14. Veslolet

    Veslolet New Member

    what kernel version does it use?
  15. SaEt9000

    SaEt9000 Member

    Hi @ all,

    installed the finless ROM on my U1. Really great (short review will follow in my next post ;)).

    But I have on question: is someone else here, who had problems after reflashing U1 connecting the U1 with a windows PC via SMB (\\ip_of_U1\U1) ?
    I am using LAN only and it worked with all minix Firmwares before without problems in my LAN.

    A feedback that it works for anyone else would help as well ;)

    Thankyou

    SaEt9000
  16. SaEt9000

    SaEt9000 Member

    Because asking myself reflashing my U1 with the fineless ROM, I would like to write some sentences here about improvements and non-improvements on my U1.
    Thats what I missed a little bit here in all the posts and I think it could help someone to decide whether testing the custom ROM or not. And: until testing the ROM I did not really expect anything more from my U1... It is always a question of expectations ;)

    But first i would like to send my thanks and appreciation to "Fineless Bob" for building this ROM and sharing it with us. Thanks so much (y)(y)(y)

    issues:
    - as I described in the post before, I have a problem to connect my U1 now on a windows10 PC. At the moment all other network functionality is working, only the connection of a share on a windows PC is not working. But maybe i will find a solution therefore.

    neutral or not better then before:
    - videos running still smooth via local network
    - no improvements regarding autoframerate-switch in kodi 17 or 18
    - the box is not really faster then before... may be a few seconds here and there but not significant
    - german skygo is still played with a visible black border
    - vidon.me xbmc working well including bluray-menu and full passthrough (incl. ATMOS and DTS:X)
    - minix xbmc 16.3 still working well
    - german skygo addon for kodi is not working because of missing playready DRM-certification of the box

    improvements
    - reliable and stable as hell (y) - since reflashing the box I had not one single freeze of the box. Thats what I had in some cases with the minix-FW
    - SPMC 16.7.2 and FTMC 16.2.31 working well - no isues visible in video-quality, but still not all audio-HD-formats working (AC3 and DTS working well)
    - kodi 18 alpha is working stable and smooth, although no franerate switching is working the video is in most cases smooth, no stutters
    - all widevine based kodi addons (inputstream, for instance: amazon, DAZN, netflix, youtube, 7TV) working really, really well - great improvement related to the minx-FW (here i had a lot of device-freezers); That makes fun now (y)(y)
    - root and SU
    - only really needed alls are installed - the box seems to carry on only the rellay needed things

    So, thanks again fro this great work. (y)(y)

    If you decide to go one with developing your ROM - I would be one of the firsts testing it this time ;)

    SaEt9000
    pirsquared8, Eligos and Finless like this.
  17. arko

    arko Member

    Does anyone know how to force ViperFX cooperation with KODI?
  18. Pingouin

    Pingouin New Member

    Anyone can comment on USB and bluetooth devices support?
    I'm still on FW12 rooted because I don't want to loose compatibility with my bluetooth Rii mini i8 keyboard and my wired Xbox 360 controllers.
    Thanks!
  19. skazza

    skazza Member

    Hi all,
    could anybody tell me please if stock smb server works? Thanks
  20. SaEt9000

    SaEt9000 Member

    I am really not sure and would be happy if someone could confirm it here.
    In my environment the SMb-access from a windows-client is not working anymore. Thats why I assume the stock SMB-server does not work in this ROM.

    It's the one issue I have with this ROM, but alle the other advantages predominate.

    To avoid missunterstandings: the SMB-access from the minix to any SMB sources in my network works well and f.i. the ftp-access from a windows-client on a remote source from ES explorer on minix U1 too.

    SaEt9000