1. Welcome to the official forum for MINIX devices!

Minix updates

Discussion in 'General - Guides and FAQ' started by tkoll, Nov 4, 2017.

  1. tkoll

    tkoll New Member

    I got the newest Minix neo box and it won't finish it's update...it keeps spinning. I left it spin once overnight. I even tried resetting the box to factory settings but it won't even do that. Is there some kind of manual reset button or hole that you have to put a safety pin in to get it to reset? Tbanks
  2. Villa

    Villa Well-Known Member Super Moderator

    You can try clearing Data/Cache and Force Stop of the System update app then run the System update app again.

    If that doesn't work then try a Factory reset.

    I don't know how you tried to reset it but you should enter the Recovery menu.
    Switch off the device then Press and Hold the power button for around 8 seconds.
    Soon you should see the Recovery menu.
    Select wipe data/factory reset.
  3. gufone

    gufone Big Owl Super Moderator

    What's your device model and actual firmware version?

    Sent from my SM-T810 using Tapatalk
    garolfe likes this.
  4. tkoll

    tkoll New Member

    Thank you! It took me to hold down the button for 8 seconds to get to the recovery screen to wipe and restore to finally Get It to work! Thanks a ton!