1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

MINIX X8-H 2% loop flashing with USB Tools, No video, Trying to flash official firmware

Discussion in 'NEO X8-H, X8 Plus & X8' started by akav05, Oct 11, 2017.

  1. akav05

    akav05 Member

    Hi guys, this is my first time starting a new thread so forgive me if I done it wrong. Im trying to fix my friends Minix X8-H which has being working perfect up until yesterday. It switches on but nothing comes on screen. The firmware on it, I’m almost sure is the most recent available and the blue light powers on when pushed but I get no visual no matter what. I tried to hook it up to the computer and using the latest Burning tool v2.0.6.2 I tried to flash the 009 firmware I get Connect Success but am not sure where it’s going wrong because I get the error:

    [0x10105002]Romcode/Initialize status/Read initialize status/USB Control setup error after the dreaded 2%.

    No matter how many cables I tried same result. I get "connect success" even if I plug it in and press Power only(without the reset button being held). I hear the ping which leads me to believe it's not in recovery mode. How do I get passed the 2% reset where it disconnects and reconnects in an endless loop.

    Is there a way to flash?

    Any help would be appreciated.
     
  2. Pippo Pelo

    Pippo Pelo New Member

    I have a terrible suspect, many and many X8h have the same problem, is it a manufacturing defect or a firmware defect?

    Inviato dal mio Mars pro utilizzando Tapatalk
     
  3. akav05

    akav05 Member

    Well hopefully someone from Minix can give me some information on how to fix the issue.
     
  4. Villa

    Villa Administrator Administrator

  5. akav05

    akav05 Member

    Thanks for the response @Villa i see in one of the threads u sent the box was basically infix able and in the other shortening the TP15 and 13 chips maybe a fix to mine. I will try that method after work tomorrow and see where that gets me. What I don't understand is why nobody from the minix team has responded to anyone having this issue from looking at the posts there seems to be many users with the same problem. They would be the most knowledgeable people regarding these units but no one has got a response from them. There has to be a reason why this would be happening to so many people and if there's not a fix there should be a explanation as to why? These units are not cheap so to think that some of us ate getting little over a year out of them is unimaginable. I am a big supporter of minix anyone I have spoken to regarding android boxes I have sent them in the direction of minix boxes and most have went onto purchase them but to think that this problem could happen to others makes me think twice about recommending them. Forgive me if I'm coming across as in the wrong way but I'm extremely annoyed and upset that my box has just become a expensive paperweight.
     
  6. Pippo Pelo

    Pippo Pelo New Member

    I tried this solution, but for my X8-H never happened

    Inviato dal mio Mars pro utilizzando Tapatalk
     
  7. akav05

    akav05 Member

    I think it works for some people and for others it doesn’t. So u have to be lucky I guess. I’m gonna try mine today.
     
  8. akav05

    akav05 Member

    I have also tried this method and have not being successful. Is that it now the box is just useless to be cast aside. That was €180 well spent.