1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Minix X8-H - Finless Lollipop ROM 1.0

Discussion in 'X8-H & X8/Plus Custom ROMs, Kernels & Discussion' started by Finless, Nov 1, 2017.

  1. dricelo

    dricelo New Member

    Fixed! I installed the ROM, but I didn't do the SuperUser process 'cause my HDMI cable had a problem. So, I reflashed it, did all the process again (with a new HDMI cable) and everything is working just fine.
     
  2. dricelo

    dricelo New Member

    Can you please describe here exactly how you are trying to flash? I was having the same problem, but I found a solution. Maybe you are doing exactly the same way I was.
     
  3. Flagonard

    Flagonard New Member

    Nice rom thanks!

    I was having trouble with my x8-h to play any type of video using the latest Kodi from the play store, the rendering, decoding and hardware accelatation played a black screen or lagged frames on h.264, MP4, mkv, etc.

    I tried with the mygica port that I was using on 4.2.2 without issues, but it seems like the problem could be on lollipop because the issue appear as well.

    The only solution is to use SPMC and tweak a little the hardware acceleration removing the surface option, with this way several files can be played smoothly, except h.264. The downside is that subtitles cannot be showed on SPMC even though its being detected, could be a problem with this version.

    Any one has encounter this issue?

    @Igorian the subtitles problem appeared in your review?

    Overall the ROM is very fast and awesome.

    Edit: if the amlogic option is disabled in advanced video, subtitles can work but the video can be choppy and not smooth.
     
    Last edited: Jul 9, 2018
  4. Flagonard

    Flagonard New Member

    @Finless is this 1.0 the updated version of the 2.0 posted on freaktab?

    Thanks.
     
  5. Luks

    Luks New Member

    I love this ROM, it's so much faster. Thank you very much @Finless . I was about to throw my MINIX Neo X8-H away, because Android 4.4 is just to old for many apps and my system lagged all the time.
    First I had trouble with the USB Burning Tool and I accepted the shitty stock firmware. But yesterday I gave it another try and now I'm very happy.

    I will explain how I did it because I wished I had an instruction like this all in one place.

    1. Download the image from Bob @Finless (the author of this Custom ROM) in the first posts of this thread (I can't post own links because I'm a newbie here)
    Just download and extract on your PC (I have Windows 10)

    2. Download and install the USB Burning Tool. I followed this instruction thread (how-to-flash-firmware-image-x6-x8-series.116) which contains the download link and also explains the flash process but I will say some words to this too. Open the USB Burning Tool after installing.

    3. Now the flashing: Disconnect all cables from your Minix. Now plug in the power cable and connect your Minix (OTG Micro USB port) with a standard Micro USB data cable with your PC (USB port). As I said I had some trouble with this step. I think the crux was disconnecting HDMI (for whatever reason!?). Then boot you Minix in recovery mode: Hold the Recovery-Button on the back with a toothpick while pressing the power button for 3-5 seconds and keep holding the Recovery-Botton for another 5 seconds. Then wait until the USB Burning Tool shows something like "HUB2-5 Connect success". If the message doesn't show up repeat step 3 from the beginning (for me it worked the third time but I did not disconnect HDMI before).

    4. Import the downloaded image from Bob (over "File" and wait a second. Verify the "Configuration" on the right: only tick "Erase flash" (normal erase) and "Erase bootloader". Then you can start the installation by pressing the big Start-Butten at the top-right. Please be patient.

    5. At the end you get the message "Burning successfully" and it's safe to unplug the power for shut down. Reconnect to power and start the Minix for the first time. You can plug in the HDMI while waiting and observe the first boot. This can also take very long so be patient!

    For me this method worked perfectly. From what I've read in this forum there might be some problems:
    - no sound from the audio jack --> use the speakers of you TV (over HDMI) or a Bluetooth speaker
    - no sound in some apps --> switch the USB-audio in the settings Thanks @butsch
    - external HD is no more recognized --> fixed after formatting it only FAT32 (before it was 2 partitions FAT32 / NTFS) Thanks @morais
    - no Netflix app in the Play Store (only problem I had) --> download the apk directly from the official Netflix website (just search "netflix apk") Thanks @glockman4519