1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Movie just stops playing in Kodi?

Discussion in 'NEO U9-H' started by Fjodor2000, Nov 11, 2017.

  1. Katalyst

    Katalyst Member

    We are trying to help you here Fjodor. We are giving you troubleshooting/problem isolation suggestions based on our past experiences and the small amount of information you've provided but you seem rather quick to dismiss whatever we say. Before you cry "bug" you really need to be willing to try some stuff out to try and narrow down what is causing the problem. For example, if there were a problem in the Minix code that reads data from network shares there would be a heck of alot more than a handful of people reporting this issue. I'm almost positive pretty much everyone on this forum that's willing to help is using a NAS or some form of network share with their box. When there is an actual bug in Minix's firmware trust me, it gets known here awfully quick because people start screaming bloody murder haha.

    I'll tell you a little story about when I was having an issue similar to yours. Likely isn't the same as yours but might give you another idea or two. I'd be playing a TV show/movies or whatever from my NAS and then playback would suddenly stop and I'd get kicked back to the Kodi list where I started from and have to hit play on the file again to continue watching. No buffering no nothing just stopped dead. (On a side note, I've never seen "buffering" come up on the screen when playing a file off my NAS with all 5 Minix boxes over 3+ years. I've only seen buffering when streaming from an internet source). I tried clearing caches, factory resets, and everything else under the sun to no avail.

    I'm a proud owner of 3 teenage bandwidth bandit youtubing boys. I narrowed my problem down to them. Whenever one of the boys started a youtube video, started a DLC download on the Xbone, etc I'd get the boot when watching my show. And those boys are on youtube ALL the time so it was annoying as heck. Although my network was "gigabit" blah blah, it was still creating a split second bottleneck that interrupted my data stream causing my playback to stop cold. My solution? I switched out a Netgear Nighthawk for an Asus AC3100. Not that the Asus was much faster but because it had bandwidth throttling controls. So the boys devices got throttled to limit the horrendous hit youtube creates when it first starts up. I also setup QOS and device prioritizing etc etc.

    At the same time I also switched to all CAT7 wiring. That by itself tripled my transfer speeds. Many people think they have a true gigabit network but until you ditch the CAT5, you really don't. So between those two things I solved my problem.

    My point? It could have been easy for me to sit back and cry that Minix or Kodi has a bug. But through some troubleshooting I found the real cause of my problem and fixed it.

    I'd suggest again, although it might be time consuming or inconvenient, to try and narrow down the problem. Is there other traffic on your network like as in my scenario? What is serving up your files? NAS, Home PC? Is it running a virus scanner? Are you using static IPs? Are you using SMB or NFS protocols? Do you have or can you borrow a spare router for a couple of days to eliminate that as a possibility? Have you tried playing files locally via USB to see if anything changes? Not saying any or all of these apply to you, just explaining there are a crapload of factors to consider.........
     
  2. Villa

    Villa Administrator Administrator

    It's a configuration issue not a bug! ;)
     
  3. Fjodor2000

    Fjodor2000 Member

    Hmmm... not sure what you mean. If it's a config issue, what should I change in the MiniX config to solve the problem?
     
    Last edited: Dec 21, 2017
  4. Fjodor2000

    Fjodor2000 Member

    It might not occur on all configs & setups. Obviously it occurs on some.

    I have no problem reproducing the buffering. When I have heavy I/O load on my server (backing up desktop PC to server, sharing movies, etc at the same time) I can reproduce the Kodi buffering progress easily. And when the buffering is done, the movie starts playing again. It's 100% reproducible. But that is not what I'm seeing for the case reported in this thread.
    Might have been the root cause for you, but it certainly is not for me. I get a stable ~90 MB/s speed on my network, way more than necessary to play the movies I'm watching. As mentioned before I've measured it several times. Also, when the server gets I/O overload, it manifests itself as Kodi buffering progress being shown. But that is not what I see in this case. For the problem I'm describing, the server is under low I/O & CPU load, the movies I'm playing can be both low (and high) bitrate, and the problem still occurs. Kodi just stops playing, as if I've pressed stop on the remote, despite that I haven't. So trust me it's not a network transfer speed issue in my case. Nothing points in that direction.
     
    Last edited: Dec 21, 2017
  5. Fjodor2000

    Fjodor2000 Member

    Just wondering, to get some more clues, is it possible to pull Android and kernel logs from the MiniX (e.g. via adb), or is it locked down?
     
  6. Villa

    Villa Administrator Administrator

    I mean the configuration or setup that one has - ie: MINIX device, TV, receiver, NAS, HDD etc....
     
  7. Fjodor2000

    Fjodor2000 Member

    Sure. But all the other stuff is standard equipment; Netgear gigabit switch, Windows PC server, 8 GB RAM, Intel Haswell CPU. HDD should not matter as long as it's fast enough. All worked well with other MediaPlayers before. So it points to the MiniX being the cause of the problem.

    But to get more clues, is there any way to get logs from the MiniX? E.g. Android or kernel logs?
     
  8. Godenzoon

    Godenzoon New Member

    Hi guys, is there any update on this issue? I'm experiencing the same issue... sometimes the same file crashes 4-5 times in a row before successfully playing the complete file. I also see no pattern in the file size; I just played my 1080p GoPro skiing movie and it stopped multiple times :(
     
  9. wrxtasy

    wrxtasy Well-Known Member

    In any trouble shooting situation video files HAVE to be played back from local directly connected storage - simply to eliminate networking problems either with the media player itself or connected equiptment.

    This is regardless of how any other media player performs on a local home network.

    Windows 10 itself has had a LOT of networking updates recently disabling SMB1 due to the Wannacry Ransomeware. There are also changes now needed when SMB Networking in Kodi as well - like Usernames and Passwords that are now required.

    Kodi Logging:
    https://kodi.wiki/view/Log_file/Easy
     
  10. Godenzoon

    Godenzoon New Member

    Hi wrxtasy, the problem is that the issue doesn't always occur. Like yesterday, the file stopped like 5 times but the 6th time it continued playing. It isn't possible to put all my videos on the local storage and test all the content from there. I will have a look at the logging!
     
  11. Hitekk

    Hitekk New Member

    I have same the same problem here any fix for this yet? Tried the cache thing but it didnt help.
     
  12. Leeroy17

    Leeroy17 New Member

    I have a similar problem. Kodi stops halfway, during a movie and returns to the movie list. I can resume back to the movie where it stops, and continue to play to the end. As for TV episode, it will stop halfway through and return back to the episode list.

    I have Kodi ver 17.6, Neo U9-H, and connects to external Seagate 2TB HD.
    Kodi is reading directly from the ext HD and no streaming.

    I Google this issue, and it appears to be a known issue but no resolution to date.
    Would appreciate if anyone has a resolution. Thanks.

    Update: Install SPMC, and it played fine. So the problem is Kodi. Not a setup issue, definitely a BUG. NO RESOLUTION. Wait for next upgrade, hopefully, they fix this issue experienced by countless of users.
     
    Last edited: Mar 4, 2018
  13. piotom70

    piotom70 New Member

    The test version <kodi-20171115-a4359ce-notsoshitty-armeabi-v7a> of the game is great.
     
  14. piotom70

    piotom70 New Member

    Testowałem wersje> kodi-20171115-9acd2d3-shitty-armeabi-v7a , kodi-20180225-9dcbabf-shitty-armeabi-v7a> te nie grają dobrze.
     
  15. Marm

    Marm Active Member

    Fjodor2000: Here is an alternate approach that might help you play movies and TV from your LAN without Kodi or isolate the problem.

    Download MediaHouse from the Playstore. It will access your shares on your network. If the problem still occurs, likely the problem is your network, the encoding of the video or the codecs on your machine. MediaHouse has far less overhead than Kodi and often sees shares on my LAN that no longer are visible with ES File Explorer. You could also do the same thing by navigating to the files on your LAN with ES File Explorer and playing the files directly. Lastly try many media players such as the ES media player, MXplayer, VLC etc. After doing all that you should have a much better idea of the cause of the problem.

    Next I would try a fresh install of Kodi with no add-ons. If that did not work, start with a fresh install of a prior version of Kodi with no add-ons. And if that does not work, do a factory reset of your box, try a fresh install of Kodi etc.

    Lastly change the power supply.

    If after all that, nothing improves, you might have MY problem. I have what appears to be a bad flaky MiniX U 9H that experiences numerous freezes, crashes and other problems that few people here have had. I must say the problems did improved somewhat after changing the power supply but overall the unit is still terrible compared to my other MiniX boxes and other brands I have had for resale.

    Oh, I own the Pro version of MediaHouse but the free one works fine.

    Good luck.
     
    Last edited: Mar 3, 2018
  16. kernerman

    kernerman New Member

    I also started to encounter these intermittent stops quite often. The effect is like someone presses "stop" (X) on the remote, the playback stops and Kodi returns to the file listing. **Sometimes** it will remember the playback position and clicking Play again will suggest to proceed from where it stopped; and sometimes it just starts from the beginning.

    This is clearly not caused by network/buffer underrun (which simply shows the spinner while it buffers more data).
     
  17. crea

    crea Member

    Just want to add that I have exactly same bug with Kodi on Sony Bravia Android TV.
     
  18. ConorT1

    ConorT1 New Member

    Had this problem and I ran a malware detection app found one and after removing it the problem with video playback dropping out was gone.
     
  19. steveg32

    steveg32 Active Member

    Which app?
     
  20. Leeroy17

    Leeroy17 New Member

    You have exactly the same issue as me. Refer my post a few above. My movies are played directly from my HD, without network. Definately a BUG. Hopefully a fix in the next upgrade.