1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

FAQ Need help with external hard disk - exFat

Discussion in 'NEO U1' started by sidhu, Jun 12, 2016.

  1. JeroenR

    JeroenR Member

    Do you have the drives in NTFS or another format?
     
  2. dav003r

    dav003r Member

    Yes I have them all in NTFS format( because EXFAT limits your file size to 3GB and some of my files are 20GB- 32GB) The one thing I noticed when using multiple drives is KODI uses udisk0 for whatever drive it reads first so I always plug my 5TB drive in first and let the u1 read it so it doesnt mess up my libary order in KODI.
     
  3. JeroenR

    JeroenR Member

    Strange, according to Wikipedia (I'm still not 'old' enough to post links, here was a link to the Wikipedia page :LOL:) the max file size should be the same as NTFS and HFS+, so well more than 3GB!? Can anyone confirm?

    This doesn't make it very easy if you have to plug- and unplug every time. The option for the HDD plugged in my modem becomes more appealing now. But thanks for sharing! Good to know that it should work.
     
  4. dav003r

    dav003r Member

    I keep the 5TB pluged in all the time so that way my KODI will stay intact. I just meant when using multiple drives I wait until the u1 reads my 6TB then I plug the other drive in. Sorry if I was confusing you.
     
  5. JeroenR

    JeroenR Member

    Thanks for clarifying! (y)
     
  6. newbie99

    newbie99 Ex Moderator

  7. dav003r

    dav003r Member

    My mistake, I was thinking about the FAT32. Thanks for the correction
     
    newbie99 likes this.
  8. marco87roma

    marco87roma New Member

    I have same problems with 4TB ExFAT
     
  9. JeroenR

    JeroenR Member

    I'm going for the option to connect the HDD behind my Apple AirPort Extreme router. Seems like the minix isn't to stable with big hard drives. Maybe what the FAQ's says that HDD's are supported up to 2,5TB (See the official Minix website Support page) is more true and that bigger sizes don't always work, but sometimes do.

    With the HDD behind my router I can format it in HFS+ and easily copy files to it trough my network. So I'm not going to try exFAT, but going straight for HFS+ option.

    To bad we can't figure out why en when this happens with large HDD's.
     
  10. This is exactly how I do things with my 6 TB NAS drive. I then input the shared drive (Movies; TV Shows; Music and Various) to Minix (using Kodi). Works a treat.
     
  11. Bryce

    Bryce New Member

    Hi All

    I just received my new Minix Neo U1 today and I'm unable to get my external hard drives to work on it.
    I have a seagate 3tb, wd 4tb, seagate 500gb, flash drives (all are exFAT) which none of them are being recognized on the U1.

    I use a Macbook pro

    When I plug the EHD into the U1 sometimes it pops up in file browser as udisk0 > part0 folder with nothing in it then it will disappear. I've also tried going Kodi > file manager > browse > root > mnt with no luck, I've also tried going into the external hard drive section in Kodi with no luck.

    Is this purely a problem just from plugging my hard drives into a MBP as I've read in another post.
    Or can this be fixed?

    Please help

    Thank you
     
  12. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    firmware version of U1 please?
     
  13. Bryce

    Bryce New Member

    Thanks for getting back so quick

    Current firmware version is: LMY47V.20160816 (saying it's up to date)

    I reformatted my flash drive to NTFS and it recognizes it but not all the time :(
    Haven't tried with the 3&4TB HD's yet

    Would reverting back to a earlier firmware fix the problem?
     
    Last edited: Oct 25, 2016
  14. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    My simple logical thinking? --> Bad physical contact, try to pull out a little after you fully plugged into the USB port.
    Because it doesn't make sense that "it recognizes sometimes and sometimes don't",
    if it's a file system compatibility issue, then it should be "always not being recognized".
    3TB/4TB drives, I assumed they are powered by external power adapter.
     
  15. Bryce

    Bryce New Member

    Yes the 3tb/4tb drives are powered by an external power adapter

    The flash drive seems to be working all the time now, it just changes name (USB1029, udisk0, sdcard) every time I unmount.

    Does this mean I have to reformat all my HD's to NTFS?

    Is there possibly an easier way to view everything on my HD's without reformatting and transferring everything back over?
     
  16. Bryce

    Bryce New Member

    Do you have to have your HD's format as NTFS?
     
  17. newbie99

    newbie99 Ex Moderator

  18. uvax

    uvax New Member

    The U1 can support other formats but NTFS is the easiest most problem free format to use.
     
  19. dav003r

    dav003r Member

    I'm also using a Seagate 5TB external drive NTFS format with absolutely no problems.
     
  20. Bryce

    Bryce New Member

    I still can't get this to work.
    As soon as I turn off the U1 it won't recognize the HD properly, it just appears as USB0011 with nothing in the folder.
    The only time I can get it to work is when I reformat it to NTFS then don't turn off the media player.

    Anyone able to help?
    This is quite annoying