1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

FAQ Need help with external hard disk - exFat

Discussion in 'NEO U1' started by sidhu, Jun 12, 2016.

  1. Bryce

    Bryce New Member

    I've formatted my HD to NTFS via a MacBook and it still has problems, I've tried this with multiple HDs so they're not the problem.
    Is the problem purely because I formatted it with a mac?
     
  2. JeroenR

    JeroenR Member

    I had the same problem with a 6TB WD drive (see topic: http://www.minixforum.com/posts/111947/ ). You can try exFAT format on your mac. exFat is also supported on Minix and can hold files the same size as HFS+ and NTFS. I never tried this option, because of all these non certainties I've read, I'm going for the option to connect the drive in HFS+ (Apple's own format) to my Airport Extreme. This way I can easily share the content to the Minix, but also easily see and use it in my network.
    By the way, I formatted my drive on Windows 10 trough VMware Fusion on my Mac. But this didn't work. I also have Paragon NTFS for Mac, but I never tried it that way to format for NTFS. As suggested in my topic was to format NTFS on a real Windows machine, but also didn't tried that. Like the conclusion in my topic, we never found what the real problem was, I went for another option. So maybe you can try the exFAT option and report if that works?
     
  3. JeroenR

    JeroenR Member

    There are many reports of big drives that work and don't work. Like you I never found a solid solution. You can read my topic like newbie99 mentioned: http://www.minixforum.com/threads/minix-neo-u1-with-6tb-hdd-problem.14395/ or another topic of a Mac user like me: http://www.minixforum.com/threads/external-hard-drive-support.13582/
    It seems to all come down to formatting on the Mac. My best guess is that Mac OS puts hidden files on the drives which cause problems on the Minix. But this is a wild guess. In your case (like Ken mentioned) if they do works sometimes and sometimes not, this could be a Minix thing. Either it works or it doesn't.

    I've hooked up my drive to my router. Solved it for me.
     
  4. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    If that's the case, we need to buy a 6TB drive to check further.

    We don't have such as big drive now.
     
  5. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    exFAT is working, we tested it with smaller size, but we don't have a 6TB drive to test, need to buy one.
     
  6. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    I've merged 2 similar threads regarding external drive support, please note.

    Easier to manage.
     
  7. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    4TB is ok, 6TB we need to test.
     
  8. JeroenR

    JeroenR Member

    Would be great if you can test the big drive questions. I would have liked to test this also, but it takes me 24 hours just to copy 3,5TB to another disk so I can format the drive. Then another 24 hours to copy everything back. This isn't very motivating to try a few options. So I went for the easiest...
     
  9. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    We shall purchase a 6TB HDD + a USB dock that support 6TB HDD to test.

    @JeroenR , which dock are you using with the drive?

    Asking because not all docks support 6TB, depends on the chip they use.
     
  10. JeroenR

    JeroenR Member

    I never used a dock. My simple thought was 1 big drive that contains all my movies. And with 3 USB ports on the U1 there was room for an additional drive if needed.
    Or I misunderstand what you mean with 'USB dock'
     
  11. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Then how to connect a 6TB 3.5" drive to U1's USB port without a dock? I don't understand...

    via network??? but the topic was EHD (external hard drive)?
     
  12. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Just ordered this dock which the seller confirmed to support 6TB drive.

    20161026191055.jpg
     
  13. JeroenR

    JeroenR Member

    In my case I have a 6TB Western Digital MyBook. It has his own power supply and a USB 3 connection.
    I think we all talk about external hard drives with enclosures.

    WD-MyBook.jpeg
     
    Last edited: Oct 26, 2016
  14. Lock

    Lock Member

    This Minix is a constant source of disappointment.

    I'm leaving for a travel and formatted a WD 3TB hard disk in FatEx, and put all movies I want to see.
    Connected to Minix and it can't see anything.
    Formatted a USB key in Mac format (just a test, before formatting all the hard disk) and same result.

    I connected the HD to my old Mede8er player (the one whose place was taken by Minix) and it has no problems at all to browse the full hard disk. Too bad it can't play H265 movies, or else I've chosen it.

    I usually use Minix via ethernet but of course, during vacation, I can't use network.
    Is there a way to connect an external hard disk to Minix or it's already time to look for a substitute? :(

    P.S. I don't know if it's a limit of Android or Minix, but in 2016 I expect I can connect an external hard disk to a multimedia player without issues!

    Update: I've found this that could add support for the FS I need:
    https://play.google.com/store/apps/details?id=com.paragon.mounter

    But it need Minix to be rooted. Quick question: how to root U1?
    I don't mind about warranty, I just want to use my Minix the way I need.
    Thanks.

    Update: Is this app good?
    http://freaktab.com/forum/tv-player...ols-au/544002-new-minix-u1-ez-root-zip-method

    I never rootet anything. Is it ok to run an app to root a device or it depends by the current OS version?
     
    Last edited by a moderator: Oct 26, 2016
  15. newbie99

    newbie99 Ex Moderator

  16. Lock

    Lock Member

    Yes, I found it there. But so far no luck in rooting.
     
  17. Lock

    Lock Member

    Meh, giving up.
    Time to look for a new mediaplayer.
     
  18. pusb87

    pusb87 Well-Known Member Trusted Helper

    goodbye :cry:
     
  19. JeroenR

    JeroenR Member

  20. JeroenR

    JeroenR Member

    Last edited by a moderator: Oct 27, 2016