1. Welcome to the official forum for MINIX devices!

FAQ Need help with external hard disk - exFat

Discussion in 'NEO U1' started by sidhu, Jun 12, 2016.

  1. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    If it's true, then it sounds more like a formatting issue of Mac OS.
    Now I'm clear about the issue, will proceed to check.
  2. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    So, Windows exFAT ok, Mac OS exFAT not OK?

    Why it sounds like an issue of Mac OS? Not Android friendly?

    Anyway, we are going to check.
  3. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    How to format my USB drive in Mac OS? I don't see the option :ROFLMAO:
    JeroenR likes this.
  4. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    I've merged all threads related to Mac OS exFAT to here, grouping together and discuss.

    Issue is copied and we shall follow up.
    Villa likes this.
  5. rmaijala1

    rmaijala1 Member

    How about making a live linux disc or usb stick and use gparted to partition and format to the file system of your choice?

    Sent from my SM-T715Y using Tapatalk
  6. rmaijala1

    rmaijala1 Member

    Knoppix is a good choice because it's made to be run off a live stick or disc

    Sent from my SM-T715Y using Tapatalk
  7. JeroenR

    JeroenR Member

    I've made some time to do a little testing. And I think I'm on to something. I still think it's a Mac thing, and not a Minix thing. I had a spare Western Digital MyBook 500GB laying around, which I used for this test. After every format I copied 1 mkv movie to it, 8GB large.
    1. Formatted the WD Drive on a Dell laptop with Windows 10 in NTFS format. Plugged it into the Minix, worked fine.
    2. Plugged the WD into my Mac and ejected it again. Plugged it into the Minix, worked fine.
    3. Formatted the WD Drive on the Dell in ExFat format. Plugged it into the Minix, worked fine.
    4. Plugged the WD into my Mac and ejected it again. Plugged it into the Minix, worked fine.
    5. Formatted the WD on my Mac in ExFAT (I selected the top drive, not the partition), Plugged it into the Minx and nope. Instead of the drive name "Transport" appearing right top in the Minix Launcher, it said "EFI". Besides the part0 folder with "LOST.DIR" in it, it was empty and there were no files visible.

    Before I ejected the drive in step 5, I disabled a little prog I have running, which is called "CleanMyDrive2" from MacPaw Inc. I run a company were I deliver a lot of USB drives and Hard Drives to customers who probably use Windows. This little prog delete's garbage from external drives as soon as you eject them. (btw, I found out about "CleanMyDrive2" after I was already using "CleanMyMac 3" on my Mac. Great tool to keep your Mac clean of useless files!). Anyhow, because I knew CleanMyDrive deletes garbage, and probably none of you is using this, I made sure this prog wasn't running when I ejected the drive.

    So step 6. Plugged the WD into my Mac again and let CleanMyDrive do it's work. It mentioned 131kb of garbage. I let it delete (don't know what it deleted). Plugged it into the Minix and it worked!!!

    Just for fun I also formatted the WD in HFS+ (Apple's own format). Same result, the disk showed up as "EFI" and it contained only the "part0" folder with "LOST.DIR" in it.

    So before we jump into any conclusions, can anyone else confirm? CleanMyDrive 2 is a free program as far as I know. It's available in the App Store on your Mac. (wanted to place a link, but again I'm not allowed to!?!)
    Can somebody else with a Mac try this program and see if the drives works after CleanMyDrive cleaned it?

    Just a side note, with step 2 and 4 CleanMyDrive was running. So It's possible that it automatically deleted garbage files. Maybe if it wasn't running step 2 and 4 may have failed too because MacOS changed or added something to the drive which CleanMyDrive then deleted. But after 14 times up and down the stairs for testing, I'm done for now! :LOL:

    And just out of curiosity, whats with the "part0" and "part1" folder structure?
    Last edited: Oct 27, 2016
    newbie99 and HardwareGuru like this.
  8. JeroenR

    JeroenR Member

    @Lock Can you try my solution? Clean your drive as you eject it from your Mac with CleanMyDrive 2.
  9. Bennett83

    Bennett83 Active Member

    I have a 2tb WD my passport usb 3.0 drive formatted exfat in windows 7 and it' worked in a U1 and my own X8h plus. I know someone who formatted his usb drive using an iMac and it didn't work in his shield,he had to use a windows 7 mini PC to format it. It's an osx issue
  10. Bennett83

    Bennett83 Active Member

    Any usb drive I've formatted exfat with windows 7/10 works in android,its a load issue
  11. Moonwalker

    Moonwalker Member

    My first time here , found this great forum for minix U1 device and i have a question.

    i see that there are people saying the U1 can work with an ext 4 tb drive HDD , what i would like to know is can it work with an external portable HDD ( not powered ) I have a Seagate 4tb Fast backup Plus USB 3.0 portable HDD .
  12. pusb87

    pusb87 Well-Known Member Trusted Helper

    your probably the best person to answer this, you will find out if you try it ...no harm in trying.... :)
  13. Villa

    Villa Administrator Administrator

    What @Frederick_99 said and if it doesn't you should try with a powered USB hub.
  14. Moonwalker

    Moonwalker Member

    um, i have not bought it yet, but its one that i want to buy , but b4 i do i need to know if it will work, so i cant try , i thought there would be people here that have portable 4tb hdd's and they can help out . or the minix people them selves could have an answer .
  15. cm127

    cm127 New Member

    I'm having the same issue as @JeroenR . I have a 4TB, USB 3.0 external hard drive, formatted in exfat, connected to a U9. Nothing is recognised. I formatted it using a Mac and the standard Disk Utilities app. This whole thing might be Mac issue, but i'll try the CleanMyDrive to see if that helps.
  16. cm127

    cm127 New Member

    Okay that didn't work. Any other options?
  17. JeroenR

    JeroenR Member

    I only had the disk formatted in exfat for test purposes, NTSF (Windows) or HFS+ was the solution I wanted. Problem with a Mac is that besides Apple's HFS+ or the new Apple File System nothing else is well supported, only with 3rd apps. And every drive you connect to the Mac, OS X places folders on it that can break your usage with other operating systems. My hard drive (HFS+) is currently connected to my Synology router. Even better, because now I can stream some movies directly to my 4K HDR tv without the Minix. You can find out if the Minix supports EXT4, I read somewhere this is a file format the Mac also recognises, but I'm not sure. On the topic of 3rd party apps, besides "CleanMyDrive" which deletes certain Apple folders on the drive so that the Minix recognises it, "Paragon NTFS for Mac 15" is also a very handy program when you're on a Mac and have to deal with a Windows environment.
    But if you have a modem or a router with a USB port, this is probably a better option.
    Last edited: Nov 9, 2017
  18. Calico2

    Calico2 New Member

    Hello to All.. Information that may be of use to some.. I'm using a 4TB portable hard drive (without power hub). Formated to NTFS on a GPT partition, the U1 reads full capacity in esExplorer .
    However i am seeing a folder called "Part1", all Media I have stored on the drive is in this folder. This was not created when I copied the files and folders to the root of the drive from my PC and neither does this "Part1" folder exist when I plug the drive back into the PC.
    The drive is detected in Kodi (Android) but I have to navigate into this Part1 folder to get to my Media. Not to much of a problem but I would appreciate any input if anyone has had this experience?