1. Registration issues have now been resolved. New accounts are able to be created

neo g4 not loading after boot logo

Discussion in 'NEO G4' started by prdvi, Dec 22, 2014.

  1. prdvi

    prdvi New Member

    Hi guys,
    My neo g4 when connected to TV and powered on... Its showing logo MINIX but its not going beyond that. That MINIX logo keeps glowing.
    Any suggestions??
    Thank you.
  2. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    You should reflash the firmware.
  3. movie1234

    movie1234 New Member

    Hi. I have the same problem. Could you help please how to reflash the firmware? Thank you very much
  4. Snakebite

    Snakebite Moderator Moderator

  5. EdT586

    EdT586 Member

    Finally had the same condition happen on one of my customer's G4 ...I have over 50 G4s in the field.
    She complained that it was starting to take longer to boot and error messages such as "system not responsive" started appearing after each reboot and she called me to come take a look.
    When I got there, it booted once with those error messages kept reappearing and then after another reboot it hanged at the Minix logo blinking forever. I then took it back to my shop to reflash the original stock firmware from 0117 to 005 and now everything is working as it should. Now the question I have is it normal for the firmware to get corrupted after about two years of use for Android ?, my customer normally just uses the stock browser to watch her day time soaps online everyday is basically all she use her G4 for.