1. Registration issues have now been resolved. New accounts are able to be created

NEO U1 Ethernet speed

Discussion in 'NEO U1' started by Kieran Morrissey, Feb 29, 2016.

  1. Kieran Morrissey

    Kieran Morrissey New Member

    I have Virgin Media 240Mbps broadband, the modem/router is Technicolor TC7200.U which has Gigabit Ethernet.

    The best speed I can get with my U1 wired to the TC7200.U is 95Mbps using Zoltán Pallagi's speed test. This uses up my PC as the server (via Ethernet) and tests direct through the TC7200.U to the U1 (via Ethernet).

    If I test the U1 via the internet using Ookla test I get a bit slower 80Mbps. I should be getting close to the 240Mbps as I have tested my PC via the internet using Ookla test I get 240Mbps

    Why is the U1 so slow?
  2. newbie99

    newbie99 Moderator Moderator

  3. Kieran Morrissey

    Kieran Morrissey New Member

    I tested the U1 on the same cat.5e cable and port that the PC was achieves the full 240Mbps on on so it's not the cable or TC7200.U. The ISP (Virgin Media) sent out their technician who also checked out the broadband installation and could find no issues.

    Previously I had a NEO X6 and it could only do 30Mbps connected to the TC7200.U via Ethernet and I brought that back to the store who upgraded me to the U1. Now I find that the U1 is also running slow.

    Has anyone else out there tested any of these boxes via Ethernet? What speeds do you achieve?
  4. newbie99

    newbie99 Moderator Moderator

    I had only done a short/quick test (10 times) with
    - Jperf 2.0.2 at NB (w7)
    - iPerf for Andriod 2.06 at U1 (as server)

    NB -> cat.5e UTP -> TP-Link TL-SG108E (switch) -> cat.5e UTP -> U1 => ~ 170Mbits/sec

    NB -> cat.5e UTP -> TP-Link TL-WDN4200 -> TP-Link TL-SG108E (switch) -> cat.5e UTP -> U1 => ~ 165Mbits/sec
  5. Kieran Morrissey

    Kieran Morrissey New Member

    @newbie99

    Is NB(w7) a Note Book running Windows 7 ? If so I assume it has a Gigabit Ethernet if it achieves 170Mbps?

    Also would you not expect higher speeds than 170Mbps through a Gigabit switch with two Gigabit devices at each end?

    Have you run something like Ookla speed test on the internet on the U1 wired to your router/modem via Ethernet?
  6. Dr Goodvibes

    Dr Goodvibes The Doctor

    I would have expected a LOT more than 170Mbit using iPerf.
    Stupid question, but you do have WiFi disabled and 1Gbit Ethernet Enabled?
    I say that as 802.11ac at around 170Mbits would seem about right for that technology. (I have no idea what a Minix U1 can obtain)

    I'd also turn off any WiFi spoofing over 1Gbit Ethernet while testing.

    Using a Minix X8H-Plus I get around ~800Mbits using iPerf to a 1Gbit LAN NAS just as a rough guideline for your testing.
  7. newbie99

    newbie99 Moderator Moderator

    @Kieran Morrissey
    Yes, Note Book running Windows 7 and of course via Gigabit Ethernet...
    As you wrote, at the NEO X6 with 100BaseT you only got 30Mbit/sec, so we know, these kind of SoC "implemented" eths never reach the possible/theoretical maximum...
    Ookla speed is senseless because I have less than 170Mbit/sec ISP speed at ADSL ;)
    Anyway, I only done this test to show you, as I already wrote, that you have a problem with your TC7200.U because it seems to work at 100BaseT and not at 1000BaseT with the U1...

    @Dr Goodvibes
    There never existing stupid questions but stupid answers ;)
    eth and wifi never works at the same time, and I never used wifi, because I prefer eth...
    AC could also reaches 1300 and more (but this is only brutto, at wifi netto is nearly the half of the brutto)...
    I thought the X8H+ only had a 100BaseT but you are right, it also have 1000BaseT... so ~800Mbits is really nice and maybe means there is a lot of potential to optimise the 1000BaseT at the U1 (but I have to say, as I wrote, my iperf test was only a quick shoot, so maybe the firewall at w7, the java at jperf, something at my configuration, at the 1000BaseT at the NB and so on, is not optimal, but I don't really need this speed, because I handle all via portable HDD's (1000BaseT is useful, as you wrote at NAS (but also not really, because how often do you have videos with more than ~90Mbit/sec? I think never ;) ) and only if you also have USB 3.0 but then only if you use SDD at it, because normally you use HDD with at best case ~80 Mbit/sec so USB 2.0 with ~230Mbit/sec netto is enough))...

    EDIT
    Bullshit, I mixed MB and Mbit, so of course 1000BaseT is better at read/write at HDD's
    btw: how did some of you guys get it handle to strikethrough text?
    Last edited: Mar 1, 2016
  8. newbie99

    newbie99 Moderator Moderator

  9. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    X6 = >80Mbps
    U1 = >700Mbps.
  10. Kieran Morrissey

    Kieran Morrissey New Member

    @ MINX -Ken,

    What does you post mean? are those speeds that you achieved with those devices and if so what did you test them with?

    I have been dealing with John Scutt of MINX support since 21st February and have not recieved an explanation or resolution to this issue.

    If my PC can do 240Mbps over the internet (using Ookla) using cat.5 Ethernet cable connected to modem/router tested why can't my NEO U1 do the same speed connected to the same Ethernet cable?
  11. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    @MINIX - John has shown me the email and that's why I am here.
    Those are the test results we obtained from iPerf with a Gigabit router. (Linksys WRT1900AC)
    http://minix.com.hk/downfile/WiFi Speed Test.rar
    (It has the option to run also tests for Ethernet in settings)
  12. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    [​IMG]

    I can get over 90Mbps upload from my 100Mbps line, I think you should get better than this.
    P.S. This is a only <US$20 router in my mother's house...
  13. Kieran Morrissey

    Kieran Morrissey New Member

    @ MINIX - Ken

    John Scutt already sent me the WiFi Speed Test.rar file. I ran server (.exe) on my PC which has Gigabit Ethernet wired to Technicolor TC7200.U gigabit router-modem and NEO U1 also wired to Virgin router modem via Ethernet. I set the app on the NEO U1 to Ethernet mode.

    The tests came out a little higher at 90-95Mbps because it wasn't going via the internet but still extremely poor, this setup should be doing 500-1000Mbps across my network.

    Why can't the NEO U1 perform as specified? lease HELP
  14. Sean369

    Sean369 Active Member

    Just as a frame of reference I just ran the WiFi Speed Test. Ran server (.exe) on my Win7 PC which is attached to a Trendnet Gigabit switch which is then attached to a TP-Link Gigabit switch. <Big house lots of stuff on the network ;) > The U1 is connected to the TP-Link switch. My TP-Link Archer C5 Dual band AC router is also attached to the TP-Link switch. Ran the app on the U1 and tested both wired and wireless speeds. Ran the 1000 Mbyte file test. Using Ookla I max out my 60Mbps line using both wired and wireless.

    [​IMG]
    Dr Goodvibes likes this.
  15. newbie99

    newbie99 Moderator Moderator

    ~770 at wired (eth) and how much at ac?
  16. Sean369

    Sean369 Active Member

    Look at the right hand side of the picture. :) Test results. 300.03 Down and 271.85 Up wireless.
    Dr Goodvibes and newbie99 like this.
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Nice.


    Sent from my iPhone via Tapatalk
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I think your consistent results closing to 100Mbps is not a coincidence.
    Something must have limited your connection to 100Mbps.
    I couldn't help you find out though...
  19. newbie99

    newbie99 Moderator Moderator

    Shame on me ;)
    I should stop acting at the forum during my influenza (because it seems I'm a little bit "brain death" since the last 2-3 days) till I'm healthy again :)
  20. Kieran Morrissey

    Kieran Morrissey New Member

    @ MIMIX - Ken

    I went out and bough a TP-LINK TL-SG1005D Gigabit switch and connected my Gigabit PC via the switch to the U1 using brand new certified cat.5e rJ45 patch leads. I ran the Speed Test again with the server.exe running on the PC and I can only get 90 to 97 Mbps fron the U1.

    Ken, there has to be some problem with the U1, it just won't go over 100 Mbps - PLEASE HELP ME