1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Official Release NEO U1 FW009A - 20160816

Discussion in 'Official Firmwares' started by MINIX - Ken, Aug 8, 2016.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Let me rephrase it:
    Do you mean Ethernet doesn't reconnect after waking up from sleep?
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  3. blizzard

    blizzard New Member

  4. Frederick_99

    Frederick_99 Well-Known Member

    does it matter ?
    make a kodi backup and try it...nothing to lose
    kingsizept likes this.
  5. Menorca Man

    Menorca Man Active Member

    Can anyone confirm whether this version is compatible with the latest Minix X8-H Plus OTA firmware KOT49H-20160829 (Firmware 010?). It's impossible to tell because the X8-H Plus Official Firmware thread hasn't been brought up to date yet.
    Last edited: Sep 10, 2016
  6. sani0k

    sani0k New Member

    It have internet after sleep, but lose internet connection after 20-30 min watching movie. And if I switch on/off Ethernet in several minutes after sleep, connection will not lose. My other devices work good, it is not problem of router.
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We shall do some tests based on your problem description the coming week, thanks.
  8. Jeffers24

    Jeffers24 Active Member

    No problems with my Ethernet connect, when streaming, after sleep or after reboot. Maybe a localised issue.

    Is there some kind of basic soak test with logging that saniOK can do?
  9. Fox Mulder

    Fox Mulder Member

    Please upload the zip version ("U1_FW009A.zip") on a file sharing site (mediafire, userscloud, any of such sites) and give a link. your servers seems to time out when I try to download anything..

    thanks!
  10. newbie99

    newbie99 Moderator Moderator

    I actually tested the download at 2.6 MB/s without any problem... maybe you should try something like JDownloader...
  11. Villa

    Villa Trusted Helper Super Moderator

    No problem here either!
    Downloaded on U1 using Advanced Download Manager.
    Not as fast a @newbie99 but still only approx 7 minutes.

    Screenshot_2016-09-14-15-18-25.png
  12. Holly Colbert

    Holly Colbert New Member

    Hi, I've been having trouble with my U1 since this update.

    It did the 200+ FW009 update ok but it still has a ~70 meg update it wants to do (I think that is the FW009a?)

    Tried a few things but it keeps failing. I've cleared the cache in recovery mode.... I've cleared data/cache for the System Update app.....

    Today I did a factory reset, connected the wifi, went straight to update, and it failed again. It downloads the update fine, then after reboot get this error after about 20% of the install progress...

    IMG_20160916_133945.jpg

    ^As shown it is saying 'failed to verify whole-file signature.... But once I've also had 'Unable to unzip' error before it even trys to reboot and install.

    I get the feeling my firmware is corrupted or something as since the last update the minix has been quite unstable - freezing a few times even when just on the launcher screen - wifi performance incredibly slow sometimes when other devices are fine - the minix logo flickering sometimes on a reboot - the wallpaper randomly reset to the stock minix one.

    Suggestions for what to try next ? I was thinking flashing FW009a from the USB Tool thing is probably a good idea ?

    Thanks.
  13. Villa

    Villa Trusted Helper Super Moderator

    Yes, the best thing to do is a full system image flash!

    Full system image with USB flashing tool:
    http://www.minixforum.com/downloads/download.php?file=U1_FW009A.rar
    MD5 checksum: E6625C24CC0A8F890B7FEA5257855EFC

    Full system image flashing guide:
    http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/

    EDIT: I don't know if i will make a difference but do you have any external memory attached, USB flash drive or Micro SD card? If so remove them and clear the System Update app data/cache and see what happens.
  14. Holly Colbert

    Holly Colbert New Member

    Thanks Villa.

    Did the full system image flash and everything now seems to be working.

    I do have a 128 gb flash drive attached, will try what you said if a OTA update fails in future. thanks.
    Villa likes this.
  15. CyberMew

    CyberMew New Member

    How do I fakewifi and set my own DNS at the same time? Now it's using my wifi (because of fakewifi on) and now i can't turn my wifi off to go back to ethernet

    Also, the fake wifi seems to be faking as 3g/4g, because I often get a popup telling me that I will be streaming over phone data instead of wifi. How can i change it?
    Last edited: Sep 17, 2016
  16. Villa

    Villa Trusted Helper Super Moderator

    To switch off Fake WiFi you need to got to Ethernet, Ethernet Switch, Off
    Then WiFi will work as normal or you can switch on ethernet again.
    If you want to set up DNS settings on the device you need to go to Ethernet, Advanced Options, IP Settings
    Or if you want it when using WiFi then select the WiFi connection, Advanced Options, IP Settings

    If you want to use Fake WiFi then the DNS needs to be set up for ethernet!

    An alternative is to set up the DNS within your router.
  17. skynet

    skynet Active Member

    Nice work Ken ;)

    Works better on X264/X265 movies, 1 or 2 seconds max to recover smoothness.
    Anyway, some "ghost" effects in dark scenes into Xvid SD movies. It didn't exists on old versions, only the 2 last versions.
    To be sure i always compare the same scenes with my Freebox player.
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Any "ghost effects" sample?
  19. skynet

    skynet Active Member

    Yes, all clips provided by lost : http://www.minixforum.com/threads/bugtracker-for-neo-u1-fw004.9952/page-4#post-80616
    I've also a sample but at home (will send you in the end of week). It's quite horrible in dark scenes. When someone is moving you can see 3 or 4 "ghost" of the movment.
    Tried of course with another players, no more ghost.
    With last XMBC, HD quality is really improved, the stutters disapeared, we can now "move" into thoses files.
    Still bad quality on SD files (ghosting, smear, ...) unless you remove AMCodec hardware acceleration.
  20. John Dawson

    John Dawson New Member

    Hi
    has anyone else tried Beta 2 of Krypton with FW09A. As soon as I installed it pass thru stopped working.

    cheers

    John