1. We are having national holidays from 1/10 to 8/10, please note.

Official Release NEO U1 FW012 - 20170227

Discussion in 'Official Firmwares' started by MINIX - Ken, Feb 27, 2017.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all,

    We are going to release the official 012 firmware for NEO U1: FW012 (20170227).

    Users with FW011 may directly update to FW012 by OTA update.
    (via MINIX OTA app).

    Change log since FW011:
    1. Fixed power button long press bug
    2. Fixed Daydream sleep option bug
    3. Updated Android security patches
    4. Fixed USB web camera image is reversed problem
    5. Fixed an Ethernet bug during system startup
    6. Fixed a .avi playback bug found on FW011

    *Updated MINIX XBMC app (Manual update is required if you're updating by OTA method)
    http://www.minixforum.com/downloads/download.php?file=MINIX_XBMC_V16.3_20160911.apk

    1.) Fixed X264/X265/VC-1 playback/seek & audio out of sync issues;
    2.) Fixed HD audio passthrough 90-95 minutes sound loss issue;
    3.) Improved .mpg video playback smoothness;
    4.) Removed non-supported settings options;

    OTA update procedures:
    1.) All Apps -> System update (MINIX OTA app) -> Check for updates
    2.) Download the OTA update package
    3.) Confirm to update and let the system to reboot and complete the update process
    [Please clear the app cache and retry if the check update failed, or showing network error]

    To enable the new Kodi passthrough:
    1.) Go to Settings -> Audio -> Digital Sounds
    2.) Configure as "HDMI" or "SPDIF" depends on your amplifier type
    3.) If you don't have an amplifier, simply leave this option as "PCM"
    4.) In Settings -> Security & Restrictions -> Unknown sources -> On -> OK to confirm
    5.) Download and install the new MINIX XBMC V16.3.0 apk which supports the new passthrough mechanism
    http://www.minixforum.com/downloads/download.php?file=MINIX_XBMC_V16.3_20160911.apk
    6.) Enable passthrough in Kodi settings, you DON'T have to if you don't have an amplifier.
    (DO NOT enable those receiver options that your setup does not support.)

    Remote controller app for Android phones:
    http://minix.com.hk/downfile/U1_remote.apk
    http://minix.com.hk/downfile/RKRemote_V2.0.3.apk

    Alternatively, you may also update to FW012 by the following flashing methods:

    Full system image with USB flashing tool:
    http://www.minixforum.com/downloads/download.php?file=U1_FW012.rar
    MD5 checksum: B357817959F8BCB7645A851C0BEE34F1

    Full system image flashing guide:

    http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/

    USB.zip update package:
    http://www.minixforum.com/downloads/download.php?file=U1_FW012.zip
    MD5 checksum: 6C62C065056D39D5B581AB9E96A54A25

    USB .zip update guide:

    http://www.minixforum.com/threads/how-to-use-the-usb-zip-update-method-x6-x8-series.6828/

    Please use a download tool which support resume function to download the update package, and please make sure you verify the MD5 checksum before proceeding to update!!

    Regards,
    Team MINIX.
    damca, nininini3, kondemor and 14 others like this.
  2. Villa

    Villa Well-Known Member Super Moderator

    OTA update available now...

    Screenshot_2017-02-28-14-55-39.png


    The OTA package size is 24.58MB,
    please note.
  3. Villa

    Villa Well-Known Member Super Moderator

    @MINIX - Ken there is a new issue with Daydream!

    Settings, Display, Daydream period of inactivity was not accessible.
    I set Daydream to None and the Daydream setting is no longer accessible. It jumps back to Settings!
    I went to Advanced Settings, Display and switched on Daydream. But going back to Settings, Daydream is still not accessible.
    nininini3 likes this.
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Can you wipe the system cache and retry?
    It seems ok on our side.
  5. Villa

    Villa Well-Known Member Super Moderator

    Already did!
    I will have to perform a full system reflash and see if that fixes it.
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We are uploading the system image and .zip and will be available tomorrow.
    damca and Villa like this.
  7. blizzard

    blizzard Member

    Thanks for this FW, especially for fixing issue for movies encoded with XviD !
    @MINIX - Ken : Can we expect for Krypton XBMC for MINIX after official KODI 17.1 release?
    Grollz likes this.
  8. Grollz

    Grollz New Member

    Hello peeps, I'm struggling to upgrade my unit that was purchased july last year-----it appears to be FW 009. Could really use some support here pls.
  9. blizzard

    blizzard Member

    Hi @Grollz just follow the instrunctsions here, make sure you have your U1 connected to internet:
  10. synixus

    synixus New Member

    Hi Villa, fyi, upgraded FW011 to FW012 via OTA, tested Daydream on my side, so far so good.
    Villa likes this.
  11. Villa

    Villa Well-Known Member Super Moderator

    Yeah thanks, I'm definitely due a full system reflash as I have other issues too! :confused:
  12. Alessandro_Scotti

    Alessandro_Scotti New Member

    I can't see any OTA update...

    Inviato dal mio SM-N910F utilizzando Tapatalk
  13. Viggen66

    Viggen66 Member

    Ken,

    I can give congratulations to your team, this is by far the best firmware for this box, awesome work there.

    Thanks, I have no issues at all.
    redrabit and KellyND1 like this.
  14. Grollz

    Grollz New Member

    Hi Blizzard thanks for the response but I had already tried this method and it downloads but hangs when unpacking the download (as in the case of others here who've posted) What is my next choice, Ive read you can manually do it via a usb and a flash tool it also struggles this way ( maybe because Im doing it wrong) I do have experience doing these things but really finding it difficult for some silly reason.
  15. ibrahim

    ibrahim New Member

    Is there any xbmc v17 update?
  16. Grollz

    Grollz New Member

    For those who are still struggling..... Reset the unit back to factory release.... Connect to your WiFi, then upgrade firmware via OTA (you may have to do this twice) then reinstall your favourite apps you are good to go.
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  18. synixus

    synixus New Member

  19. Parambir

    Parambir Member

    Upgraded without any issues and works like a breeze... following this thread to see any issues
  20. habanajoe

    habanajoe New Member

    @Villa I have the same problem you described: if I try to change the time the Daydream should start (in Settings), it jumps back to Display!
    I tried with a clean reflash as well, but nothing... :-(
    I think it should be a bug in firmware #12: I hadn't this problem before upgrading..
    Last edited: Mar 7, 2017