1. Welcome to the official forum for MINIX devices!

Official Release NEO U9-H FW004A (20170412)

Discussion in 'Official Firmwares' started by MINIX - Ken, Apr 14, 2017.

  1. MrBig

    MrBig Active Member

    My experience with recent OTA update:
    First my personal configuration, U9, I plugged in the following:
    wired GB internet connection, 5TB external drive via USB, 64gb micro/sd card installed, A2 mouse remote, Logitech micro keyboard, both dongles plugged in.
    I started up the box, went into update, initiated update. Completed with No issues. SAMBA, LiveTV, streaming, etc all work perfect.

    May be off topic but I did some experimenting because one of my customers was having problems with slow processing, lagging, tiling, jerky videos, and more. I don't think it is related but he could not get the OTA. So I installed his KODI third party custom build, on my box, (way overkill, most movie, music, video addons were merely menus using the same movie addon). Even though the U9 is very powerful, most of the memory was used up, causing a lot of performance lagging.
    I find maintaining a clean box and only load addons I will actually use, keeps my U9 very fast and responsive.
    Thanks for the continued support.
  2. Jason kng

    Jason kng New Member

    Hi , I just purchased a minix u9 , but it won't show or let me upgrade the latest filmware . My box shows build no . MHC19J20161229 default . I go to OTA check for upgrade it only gives me one not so new update MHC19J20170216 , file size 105.06mb. I downloaded it anyway. But it always stuck at 4% and refuse to go any further. It says network connection fail. I have pressed retry but same result. Pls help me . Is there another way I can get the filmware, with my thumb drive ? Thank u in advance.
  3. Villa

    Villa Well-Known Member Super Moderator

    Try clearing the Data/Cache of the System update app then try again.
    If it works then after updating to MHC19J20170216 you will have to check for updates one more time to get to the latest firmware. OTA updates have to be installed sequentially!

    If you still have issues then try this method...

    USB.zip update package:
    http://www.minixforum.com/downloads/download.php?file=U9H_FW004A.zip
    MD5 checksum: C2FB1785441D2B615825D78BED509D5D

    USB .zip update guide:

    http://www.minixforum.com/threads/how-to-use-the-usb-zip-update-method-x6-x8-series.6828/
  4. Jason kng

    Jason kng New Member

    Thank you villa , tried to even reset the set with the same problem arise. I'll try your zip update , but it only shows the U1 method , I assume it's the same with U9?
  5. Villa

    Villa Well-Known Member Super Moderator

    It's the same method.
    Edited the post! :)
  6. Jason kng

    Jason kng New Member

    Bro villa, u know what !!! It works like a charm ! Even the brightness issue is solved . U guys are great people , I truly appreciate . Thank you again .
    sangaz and Villa like this.
  7. sparerib

    sparerib New Member

    Has HDCP 2.2 been enabled yet?
  8. Hoshin

    Hoshin New Member

    Helo MrBig,
    Personal config, U9 plugged in wired GB internet, 0,5TB external drive hooked-up to Asus AU68 router. Samba-share. USBstick 16GB, A3 mouse remote. Update works flawless. Until I started my VPN app. From then on the Samba-share with the HD is no longer accessible. The only way to get it back accessible is resetting connections. Doing so will stop the VPN Connection. Any suggestion how to solve this problem.
    Last edited by a moderator: Jun 13, 2017
  9. Villa

    Villa Well-Known Member Super Moderator

    You could try using an OpenVPN app.
  10. MrBig

    MrBig Active Member

    You may have to re-direct your traffic through the VPN. It may slow things down throughput, but it is a sacrifice you have to pay for VPN. Try editing the hosts file in windows to reflect the new ip for the VPN. Example: 10.2.0.1 MSHOME-PC
  11. Hoshin

    Hoshin New Member

    I did Ipvanish
  12. Villa

    Villa Well-Known Member Super Moderator

  13. Hoshin

    Hoshin New Member

    I just read the discussion on the beta update. IT Sems They adres the Samba connection problem. In the meantime I Will look for an open vpn manager to be used in Kodi. The Zomboided is excellent, however this one is not compatibel with Androi boxes.
  14. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

    just use the openvpn app that @Villa pointed you too and load your IPVanish config files.....simple solution ...done :whistle:

    alternatively run the VPN on your router...
    Villa likes this.
  15. Skemperlis

    Skemperlis New Member

    I have a problem to Start ..is Stack ..Does anyone know what to do ?

    Attached Files:

  16. MrBig

    MrBig Active Member

    Are you saying that your U9 is stuck on bootup? If so, wipe and factory reset should help.