1. Welcome to the official forum for MINIX devices!

Official Release NEO U9-H FW005 (20170623)

Discussion in 'Official Firmwares' started by MINIX - Ken, Jun 25, 2017.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all U9-H users,

    We're pleased to announce the official 005 firmware for NEO U9-H (20170623)

    Users with FW004A may update to FW005 simply by our MINIX OTA app.
    (OTA update window will be opened in the coming week)

    NOTE: Adoptive storage is not supported by our OTA.

    Here is the change log:

    1.) Fixed a .TS video playback issue
    2.) Fixed a .MP4 video playback issue
    3.) Fixed a playback bug related to Showtime app
    4.) Improved logic of the faked Wi-Fi status function
    5.) Removed the launching Camera app shortcut
    6.) Fixed some permission related issues
    7.) Fixed a SAMBA function bug after reboot
    8.) Default refresh rate switching level changed to level 1
    9.) Fixed Deep Color mode bug
    10.) Added PCM/AAC passthrough support in Kodi 17
    11.) Added the "CLEAR ALL" shortcut in recent apps list
    12.) Improved TF card read/write performance (exFAT, EXT4 format)
    13.) Fixed the greyscale inaccurate problem in Kodi 17
    14.) Improved some 4K VP9/HDR videos playback smoothness
    15.) Fixed the "Enter" key bug of some USB keyboards
    16.) Updated AirPin (PRO) app to support iOS 10.3.x


    OTA update procedures (will be available in the week coming):
    1.) All Apps -> System update (MINIX OTA app) -> Check for updates
    2.) Download the OTA update package
    3.) Confirm to update and let the system to reboot and complete the update process

    To enable the new Kodi 17 passthrough:
    1.) Go to Settings -> Audio -> Digital Sounds
    2.) If you use a HDMI amplifier, just leave it as "PCM"
    3.) If you use a SPDIF amplifier, choose "SPDIF"
    4.) If you don't have an amplifier, simply leave this option as "PCM" (default)
    5.) In Settings -> Security & Restrictions -> Unknown sources -> On -> OK to confirm
    6.) Download and install official Kodi 17.1 stable version or latest nightlies
    7.) Enable passthrough in Kodi settings, you DON'T have to if you don't have an amplifier.
    8.) Check those passthrough options supported by your amplifier.

    Remote controller app for Android phones:
    http://minix.com.hk/downfile/U1_remote.apk
    [​IMG]

    Full system image with USB flashing tool:
    http://www.minixforum.com/downloads/download.php?file=U9H_FW005.rar
    MD5 checksum: 7C7F942F4D354198D5DED4F98A6E7A8A

    Full system image flashing guide:

    http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/

    USB.zip update package:
    http://www.minixforum.com/downloads/download.php?file=U9H_FW005.zip
    MD5 checksum: 7AF562D2CF079DC9389943358CFDC62B

    USB .zip update guide:
    http://www.minixforum.com/threads/how-to-use-the-usb-zip-update-method-x6-x8-series.6828/

    Please use a download tool which supports resume function to download the update package, and please make sure you verify the MD5 checksum before proceeding to update!!

    P.S. FW006 is under development~! Schedule - July/Aug 2017.

    Thanks & regards,
    Team MINIX.
  2. stayloa

    stayloa New Member

    Thanks, guys! So glad I bought a minix!

    Will the update zip be out today or the same time as ota is available?
    Last edited: Jun 25, 2017
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Zip is released just now.
  4. KellyND1

    KellyND1 Member

    Excellent work. You guys are always on top of things. Thanks


    Sent from my XT1254 using Tapatalk
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Please note that default refresh rate switching level has been changed to level 1 in this build.
    As some users don't know why their screen goes black every time at the beginning of a playback and thought it's a hardware problem.

    Please switch back to level 2 if you like the switching feature.
  6. Kondor

    Kondor New Member

    - Bug with web TS (H.264) still not resolved (I have wrote solution here at forum, but you ignored it).
    - Stagefright demuxer bug with web (http/https) mkv,mp4, etc. still not resolved.
    Last edited by a moderator: Jun 26, 2017
  7. DarrenNewsgroup

    DarrenNewsgroup New Member

    Would I be correct in thinking that booting into recovery, performing a factory reset, then flashing via the USB.zip on an SD card is equivalent to the full system image flash? I ask because my U9-H is firmly embedded in my TV setup and I have to move a lot of bits around to get it out (well the PSU mainly) and I want to start again completely; I don't want to keep my data. I am hoping the new firmware and complete re-flash will solve my problem described in http://www.minixforum.com/threads/box-keeps-giving-no-video-after-a-while.16659/.

    Ken, if you say there are real differences then I might just have to bite the bullet and move all my TV equipment to get to the PSU and do a full system image flash.

    Thanks
    Darren
  8. KellyND1

    KellyND1 Member

    @ken. When you say "
    NOTE: Adoptive storage is not supported by our OTA.". Does this mean I need to pull my sd card out when doing OTA?
    Yes I'm currently using it for adaptive storage.
    thanks.much

    Sent from my XT1254 using Tapatalk
  9. WeK05

    WeK05 Audio Visual Master Specialist

    Yay! I can confirm that:
    1) Showtime playback issue is finally fixed.
    2) Multichannel LPCM works. Unlike the Zixxx device, multichannel LPCM also works with Dolby/DTS decode in Kodi/SPMC.

    Issues:
    1) HBO still has the pixelation issue at the start of playback. It may be worse on this firmware. It used to clear up within a couple of seconds, but now you have to use the 10 sec. skip.
    2) Deep Color mode is still not working properly. It requires a reboot for 10-bit output to be enabled, but it persists power cycling. Refresh rate switch breaks 10-bit output. If you disable refresh rate switching, 10-bit output works for all fps content, but you have the issue of getting stuck in HDR mode. Also, it looks like Kodi, SPMC is taking a long time to exit.
    3) WebView input problem on certain apps is still there.

    I also noticed that HDMI self adaption Level 2 works in SPMC. I don't remember whether this was the case with previous firmware.
    Last edited: Jun 25, 2017
    sangaz, Menorca Man and olive069 like this.
  10. DarrenNewsgroup

    DarrenNewsgroup New Member

    Ken - is my box faulty?

    I tried the USB.zip approach putting the image on a USB stick but couldn't do it since the box gave me no tv signal at all.

    I moved my TV equipment to get the PSU and the U9-H out and took them to my PC. I downloaded the system image .RAR file and followed the instructions. Initially I could not get the burning tool to recognise my U9-H but it turned out that I had it plugged into a USB 3 port. Plugging it into a USB 2 port it was detected fine (perhaps you can update your instructions to cover this). It flashed OK. I took the U9-H back to my TV and turned out on. Nothing happened.

    I repeated the flashing on my PC again and everything went fine. I took the U9-H back to the TV. Before turning the U9-H back on i tested my youview box could get a tv signal. I then used that HDMI cable and plugged it into my U9-H, turned on the PSU (at which point the U9-H green light came on for a fraction of a second and then went off). When I pressed the power button on the side of the U9-H the green light came on and stayed on. I got no tv signal at all. At this time I was expecting a tv signal and to see the box booting up for the first time since reflash. I appreciate that it can take some time, so I left it powered, green light, no tv signal for 18 minutes after which I turned the PSU off. I put the HDMI cable back in my youview box and turned that back on. I got a tv signal so the HDMI cable is fine.

    Again, is my box faulty and due to be returned to Minix/Amazon? What more can I do to test?

    I have not rooted the box, the only things I have done to it are OTA to rev 003 and 004A, installed a few apps from the Google play store and my woes with losing the tv signal.

    Darren



    Sent from my LG-H815 using Tapatalk
    Last edited: Jun 26, 2017
  11. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We (I) didn't ignore your feedback, before releasing the firmware we tested the THREE videos uploaded by you, e.g. Bollywood samples, AMEDIA Premium sample, with the video players you mentioned (MX Player, Gallery player.)

    I remember I told you we fixed the problem you reported with another method, I'm sure that I didn't ignore your feedback, it's a false accusation but I wouldn't blame you for this.

    <-- The answer is no.

    Stagefright demuxer bug with web, how to verify this?

    If this firmware still doesn't resolve your problem, please upload new sample videos to us again. We promise to fix them on FW005A/006!

    P.S. The stream sample you provided last time: https://drive.google.com/file/d/0B6v7_J0uqBiMX3NoRngxZ0RRRFU/view
    is a buggy one and losing audio on all players we tested (Android players, Dune HD, i7 PC)

    We tested the 3 samples you provided before with MX Player, Gallery player & Kodi 17,
    they are all ok, so what problems are you having now? Please submit some new sample files to us for verification.

    I've edited your message to make you less look like promoting other products here.
    frutiloopis likes this.
  12. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I'm creating the bug tracker thread this morning, please report problems related to fw005 there, thanks!
  13. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    If you flashed the firmware successfully with the tool, then the box should be fine, at least.

    If you have a monitor, try it.
  14. DarrenNewsgroup

    DarrenNewsgroup New Member

    I took the U9-H and PSU to work. I had removed the Wi-Fi aerial and the USB dongle for the A3 remote. Plugged the U9-H into my works monitor via a works HDMI cable. Turned the U9-H on and got a solid blue light instead of a green one. This was the second time that the box had been powered after the system image flash to 005. Still no signal on the monitor. I left the U9-H on for 15 minutes. I then turned the PSU off and on again (got a momentary blue light for less than a second when turning the PSU back on). I pressed the power button on the box and got a solid blue light but no signal on the monitor even after 5 minutes.

    To me this sounds like a faulty box. What is your view Ken? Where do we go from here?

    Darren

    Sent from my LG-H815 using Tapatalk
  15. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I've informed my colleague John to contact you soon.
    DarrenNewsgroup likes this.
  16. Runge

    Runge Member

    Damnit! Was really hoping this had finally been fixed :(
  17. robertus23

    robertus23 New Member

    Hello Ken
    I have on my minix u9-h Beta FW005 release(v005).Do i have to install official 005 firmware for NEO U9-H (20170623) or it`s not necessary?
    Thank you
  18. Villa

    Villa Well-Known Member Super Moderator

    You don't have to but I would recommend that you do so you can receive future OTA updates.
    I also believe the official release will be slightly different to the Beta!
    robertus23 likes this.
  19. robertus23

    robertus23 New Member

    Thanks for info Villa
  20. robertus23

    robertus23 New Member

    Hello again
    the MD5 checksum of the downloaded package not matches with the checksum you provided
    I downloaded file for flashing tool
    Last edited: Jun 26, 2017