1. Registration issues have now been resolved. New accounts are able to be created

Official Release NEO U9-H FW005 (20170623)

Discussion in 'Official Firmwares' started by MINIX - Ken, Jun 25, 2017.

  1. Villa

    Villa Well-Known Member Super Moderator

    I bet your wife thinks the same!!! :rolleyes::whistle:
    Surprised you're not dead yet! :ROFLMAO::cautious:
    skynet likes this.
  2. skynet

    skynet Well-Known Member Trusted Helper

    :ROFLMAO:
  3. riktorscale

    riktorscale New Member

    Cant get this to update. The update app fails everytime. Downloads, extracts, then fails. I even tried it after a favtory reset. No good.

    Tried a usb, also no good. Wouldn't recognize the contents of the zip folder


    Sent from my iPad using Tapatalk
  4. reaklif

    reaklif Member

    EDIT
    Looks like my SMB does not work on the U9. My U1 is working flwaless but the U9 cann't connect with SMB. Strange. Maybe the box is broken.

    I'm back to FW004A. 005 has a very annoying bug in my case. Regulary it loses connection with my NAS. Internet is fine but the NAS connection is lost several times now. It never happend on FW004A and in FW 005 the deepcolorbug is still present so one step back.

    I'll wait for FW006.
    Last edited: Jul 18, 2017
  5. Fretts

    Fretts New Member

    I just tried to watch an Amazon HD streaming video. Amazon does not recognize the U9-H, they will only stream SD to it. I'm putting 2 and 2 together here and supposing that what I just read a couple pages back has something to do with it -- that 10-bit colorspace is not sorted out in Marshmallow Android to Amazon's satisfaction, so they are 'blocking' this TV box. Am I missing something here or is there a good reason to expect the U9-H to be able to get Amazon HD video soon? If the answer is no, I have bought the wrong box for my purposes. I basically wanted something "like" a Roku only better. An 8-core hotrod like this looked like the right choice until this. Anybody have any knowledge about what's going on with Minix vs Amazon?
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Have you followed the instructions in post #1?
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I think Amazon have a list of devices that they would allow HD playback?
    Can't get HD unless spoofing the device's model name?
  8. riktorscale

    riktorscale New Member

    I did this
    OTA update procedures (will be available in the week coming):
    1.) All Apps -> System update (MINIX OTA app) -> Check for updates
    2.) Download the OTA update package
    3.) Confirm to update and let the system to reboot and complete the update process

    Which has previously been fine, worked with no issue. I had an x8 h plus previously, no issue until it wouldnt update to kodi 17 due to android compatibility issues. Got a neo U1 which has been also no issue. Sadly the U9 h has been the least impressive .




    Sent from my iPad using Tapatalk
  9. Villa

    Villa Well-Known Member Super Moderator

    @MINIX - Ken's question is regarding this...
    USB .zip update guide:
    http://www.minixforum.com/threads/how-to-use-the-usb-zip-update-method-x6-x8-series.6828/
  10. riktorscale

    riktorscale New Member

    As for the usb, the minix in recovery mode wouldnt find the flash drive at all, on the cord thingy to mini usb, and when plugged into the usb ports.

    I even copied the file onto a portable hard drive. Which i could at least see in recovery mode, but ut found no content in the folders

    This unit isnt even 6 montys old and is top of minix range.
  11. Villa

    Villa Well-Known Member Super Moderator

    Is the flash drive formatted to FAT32?
  12. riktorscale

    riktorscale New Member

    Yep fat 32 wont even recognize its plugged in.

    I did try the portable hard drive again. I discovered that for unknown reasons my mac unzipped the file when it downloaded it. Recompressing it got me as far as it starting to work but failing due to envelope format name or something along that. Mac set up here only got macs and minix

    So then I thought maybe it changed when it was downloaded by the Mac, so I need to download it on either a PC or something other than a Mac. So I downloaded it with the Minix in chrome, but because I was on the U9-h i was unable to write the file to the external hard drive.

    So then i went and re-downloaded the file on my other neo U1 , copied it to the external hard drive, etc etc. It appears to have preferred that. Android just updated, i think it might have finally worked.

    God i hope firmware 6 just updates with the app, lol





    Sent from my iPad using Tapatalk
    Villa likes this.
  13. MrBig

    MrBig Active Member

    Unfortunately your problem and frustration has nothing to do with the U9 or the firmware.
    Make sure you boot your U9 to the launcher. Do NOT launch KODI. After you download it via Chrome or your browser, copy it to your USB thumb drive, via file manager, and follow the directions at the above mentioned link.
  14. riktorscale

    riktorscale New Member

    You sound like a bad thriller conspiracy theorist.

    I have installed the update and rebooted. Update has been achieved, yay.

    How you think a factory reset u9-h unit that wont accept the update via the update app shows no issue, im unsure. If its factory reset whats stopping it accepting the update? Logic would say a virus or bug of some kind, something that a factory reset wont clear.

    As i say i really hope that the next update goes much smoother. Had no issue with either of my two previous minix, and dont intend starting now.


    Sent from my iPad using Tapatalk
  15. MrBig

    MrBig Active Member

    Actually, I work on these boxes daily. I don't eve remember how many boxes I have setup or updated. So I know a thing or 2 about why Shtuff happens.
    So again, Unfortunately your problem and frustration had nothing to do with the U9 or the firmware.
    It is usually the possible lack of knowledge or just plain user error. The file could have been bad, your connection at the time of the OTA may have had packet loss, something that was configured or loaded on the box was causing a problem, the procedure was wrong, etc. And finally you got it right, got it updated and rebooted.
    So using your mention of logic, was it a buggy malfunctioning U9, that all of a sudden corrected itself and started working without any malfunctions and possibly cleared the possible virus all by itself, allowing you to update? Or was it user error and/or maybe a bad download of the update file, etc.?
    But I'm glad you finally got i to work. I know it can be frustrating.
  16. npurgar

    npurgar New Member

    You know what's bad for me? The fact that we have to wait several months for whole new firmware just to, among other things, fix this tiny deep color issue, you have to wait a long for the whole package.
    You can't just download that particular fix, I guess it doesnt work like that...

    Poslano sa mog SM-G920F koristeći Tapatalk
  17. npurgar

    npurgar New Member

    Hi, Ken!

    I have to tell you about the weird subjective feeling I got about this frame skip/freeze when watching movies. This happens in every kind of video, whether hdrip or divx.
    I have a tiny feeling that moments right before frame freeze occurs, the audio and video don't quite match, they like separate for a fraction of second (almost unnoticeable), and right after the frame freeze, all goes back to normal, picture and sound follow each other well.
    I say once again, this is just my subjective feeling, the spoken words don't quite match actor's lips (or sounds of gunshots) moments before the frame freeze.

    Could it be that the whole time in between the frame freezes, video progressively plays faster than audio, but then software figures this out somehow and then makes this tiny frame freeze to 'slows' down video playback to match audio?
  18. sinchenkos

    sinchenkos New Member

    When using the proprietary Minix Neo A2 lite, the application menu button works only when using the Minix launcher, on the rest (even on Launcher 3) does not work.
  19. Villa

    Villa Well-Known Member Super Moderator

    Yes, that is correct, that is how it is. It is not a bug!
  20. Andrew

    Andrew Member

    I'm using FW005 on my U9-H and tried watching 2 different movies tonight in Kodi with X265 1080p 10bit and 6 channel audio. While I have not had any video freezes/stutters as others have mentioned my problem is video and audio out of sync when trying to play X265 1080p with 6 channel audio. So far I have put the audio ahead by 7 secs in Kodi and only now getting close but I don't think there's enough adjustment left in Kodi to resolve it.

    On previous advice here I adjusted the cache etc. quite some time back and as follows:
    -<advancedsettings>
    -<cache>
    <buffermode>1</buffermode>
    <memorysize>293601280</memorysize>
    <readfactor>8</readfactor>
    <curlclienttimeout>45</curlclienttimeout>
    </cache>
    -<video>
    <subsdelayrange>0</subsdelayrange>
    </video>
    <splash>false</splash>
    <enablemultimediakeys>true</enablemultimediakeys>
    </advancedsettings>

    Can anyone suggest any further changes I can make to resolve these audio sync issues wiwhen playing hires X265. X264 works fine btw.