1. Welcome to the official forum for MINIX devices!

Beta Release NEO U9-H FW005 beta release

Discussion in 'Beta Firmwares' started by MINIX - Ken, May 5, 2017.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all U9-H users,

    We are releasing a beta firmware (v005) for U9-H today.

    Most of the problems reported, suggestions are being addressed in this build and while there are many changes that we've made, we believe it's better to release this public beta for testing before we finalize the official FW005 release.

    Here is the change log since FW004A:

    1.) Added the "Clear All" button in the recent apps list page
    2.) Improved .avi video playback smoothness while using HW decoding
    3.) Fixed a bug that deep color is being switched off after restart
    4.) Fixed a bug that when deep color is enabled, you can't switch to some other resolutions
    5.) Improved TF card read/write performance (exFAT, EXT4 format)
    6.) Fixed the greyscale inaccurate problem in Kodi
    7.) Improved some 4K VP9/HDR videos playback smoothness (e.g. Curvature of Earth, Oblivion trailer)
    8.) Fixed the SAMBA server permission bug
    9.) Fixed the "Enter" key bug of some USB keyboards
    10.) Updated AirPin (PRO) app to support iOS 10.3.x
    11.) HDMI spoofing - still under development, for testing purpose only
    12.) Updated system apps


    To enable the new Kodi 17 passthrough:
    1.) Go to Settings -> Audio -> Digital Sounds
    2.) If you use a HDMI amplifier, just leave it as "PCM"
    3.) If you use a SPDIF amplifier, choose "SPDIF"
    4.) If you don't have an amplifier, simply leave this option as "PCM" (default)
    5.) In Settings -> Security & Restrictions -> Unknown sources -> On -> OK to confirm
    6.) Download and install official Kodi 17.1 stable version or latest nightlies
    7.) Enable passthrough in Kodi settings, you DON'T have to if you don't have an amplifier.
    8.) Check those passthrough options supported by your amplifier.

    Remote controller app for Android phones:
    http://minix.com.hk/downfile/U1_remote.apk
    [​IMG]

    Full system image with USB flashing tool:
    http://www.minixforum.com/downloads/download.php?file=U9H_FW005beta.rar

    MD5 checksum: A72392417CBD18C59CE5E9901757DB0C

    Full system image flashing guide:
    http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/

    Please use a download tool which supports resume function to download the update package, and please make sure you verify the MD5 checksum before proceeding to update!!


    Thanks & regards,
    Team MINIX.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We've tested all videos uploaded by users in the FW004A bugtracker thread with this firmware + Kodi v17.1 and they all play fine now.
    skynet and kingsizept like this.
  3. skynet

    skynet Well-Known Member Trusted Helper

    Many thanks Ken.
    Will try it this weekend and will give my feedbacks after that ;)

    Edit : No file available yet ...
    Last edited: May 5, 2017
    kingsizept likes this.
  4. olive069

    olive069 New Member

    Waiting for this update too. It seems to be a major release. (y)
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Download link & MD5 checksum updated in post #1, thank you all for help testing this release.
    kingsizept likes this.
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    It's ready now, thanks!
    sangaz, kingsizept and skynet like this.
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Forgot to mention that the "Showtime Anytime" app has a "Playback Interrupt" bug that we are looking into,
    and it's not related to HDMI spoofing, there is something wrong with Widevine authentication when going up to 1080p resolution.

    We are trying our bests to solve it in the coming final release of FW005, please note!
  8. tomeeli

    tomeeli Member

    SAMBA does not work again((
  9. olive069

    olive069 New Member

    So, did this release fixed stuttering/lagging 4K video files?
    I don't especially want to full flash and reset my app/config.
  10. Villa

    Villa Well-Known Member Super Moderator

    The point of a BETA release is to test it!
    If you don't want to test it then please do not post in this thread.

    Edit: I suppose those that don't want to test should ask questions for those who are willing to test to look for said issues. :)
    Last edited: May 6, 2017
    Rui Oliveira, olive069 and kingsizept like this.
  11. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

    :rolleyes:
  12. splitvs

    splitvs New Member

    Fixed it for me. Happy with this version.
    MINIX - Ken likes this.
  13. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    It works for me... are you sure your router has no filter?
    e.g. Some routers block such access.
    This time I tested with the same build... not our internal build....

    Anyway, let us check and make sure it's ok in our final release.
  14. tomeeli

    tomeeli Member

    See yourself Samba in Zxxxx works in Minix no. All devices connected to the same router and are on the same network.
    I noticed that enabling or disabling"Deep Color" not affect anything, guess what does not work. Although on my TV this setting has led to an unnatural and highly saturated color reproduction.
    Screenshot_2017-05-06-11-51-31-560_com.overlook.android.fing.png Screenshot_2017-05-06-11-51-15-811_com.overlook.android.fing.png 2017-05-06_115023.jpg
  15. skynet

    skynet Well-Known Member Trusted Helper

    Hi,

    Installed this beta version this morning.

    Working
    1) Best of all, it's finally smooth in 4K HDR / 4K / HD ! (y)(y)
    Tried with a lot of movies (23,967 fps) and clips
    Tried special difficult parts, with long scrollings to be sure. (Nasa clip, Oblivion, and even the bad encoded 4K Jason Bourne)
    Found only 1 or 2 SD movie which aren't smooth but other SD clips seem to be smooth enough.
    So Happy with that, as this is my main usage of this box.

    2) Samba is working fine, and is faster than U1 server :)


    Bugs
    1) There's still a color issue.
    a) Interface is darker than FW004a. It's like the first firmware effect.
    b) so 4K HDR movies look like a little bit darker. HDR is working, i could easily compare with a HDR movie played on a non-HDR device (U1, PC, ...)
    c) HD movies colors are bad, burnt. It's smooth but i can't watch a movie with thoses colors/contrast. It's like you push the contrast cursor fully o_O

    Perhaps i didn't choose the right setting, you can't have missed this horrible bug !
    Changed HDR setting from AUTO to Yes and NO.
    Any idea about this ?

    2) I selected fake wifi at the begining and after a reboot network connection is gone. Could'nt connect to samba, but Google Play worked ! :confused:o_O
    I had to move some cursors in network setting to restore "internet connection" then Samba.
    Will try again more reboot to test further

    3) Airdroid's icon is present at least 10 times in Metro's folder

    Not tried other functions yet, will try this week-end.

    Yep, something new : I installed last Minix XMBC and guess what ? amcodec is back !!! :D
    Everything is smooth too with it, except the colors bug ...
    Last edited: May 6, 2017
    Rui Oliveira and kingsizept like this.
  16. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I'm not sure why you think the color isn't right but we didn't change anything about color or contrast, in this build we simply force Kodi to play videos on the same layer that amcodec used to... this is it.
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We would be happy to test those 1-2 clips that are not smooth.
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Are you sure that switch has been turned on? Unlike last time we tested with the same image this time and you can see above that it's not just me get it working this time.

    To be honest I don't know why it's still not working on your side.

    I'll keep observing and wait for more reports to come in.
  19. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

    Samba works for me now @MINIX - Ken with 005 beta (n)
  20. tomeeli

    tomeeli Member

    Of course. Tried to disable and re-enable and reboot u9, that does not help. Why is not working?