1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

NEO U9-H Reset?

Discussion in 'NEO U9-H' started by Larry91, Jan 8, 2018.

  1. Larry91

    Larry91 New Member

    Where is the reset hole on a NEO U9-H . Mine is bricked. Blue power light but no video out of HDMI.
     
  2. Villa

    Villa Administrator Administrator

    Underneath the device to the left. But I'm not sure how that will help you?!
     
  3. Larry91

    Larry91 New Member

    Found the hole and pushed a pin in and held while I applied power. Screen would momentarily turn green but still wouldn't boot to the familiar Minix screen. Have the unit ready to return to Amazon. Is there anything worth trying? It worked flawlessly until I hooked it up to our 4k TV upstairs. Seems like a well designed box but it's pretty useless right now.
     
  4. Villa

    Villa Administrator Administrator

    Have you tried connecting to a different TV?
    I'm not sure what the reset does?
    With this device you can just press and hold the Power button for around 8 seconds and the device should enter the Recovery Menu.
     
  5. Larry91

    Larry91 New Member

    Yes, have two TVs both Samsung "smart" TVs. Same response when Minix connected. I did find that if I unplugged the power brick line, then plugged it back in, pushed the power button until the power blue led turned on, then held the power button, I could get the green Minix Android figure (with the two ant antennae). But then the screen went to black. Is it possible I commanded the MINIX box into 4K output. There was a sequence when I was setting it up on the Samsung 4k TV where it allowed me to specify 4k60hz (or something like that).
     
  6. Villa

    Villa Administrator Administrator

    Probably is related to that!

    To enter recovery...
    Unplug the power supply and reconnect. Then press and hold the power button for at least 8 seconds then release it.
    During the 8 secs you will see MINIX and the Android robot. After another 10 secs or so the screen will go black followed by the recovery menu appearing.
    If it does, I suggest you perform Wipe data/factory reset
     
  7. Larry91

    Larry91 New Member

    Alas! I see the Green MINIX and the little Android figure, then the screen goes black, stays black for a few seconds, then the Samsung TV gives it's "No Signal" text.
     
    Villa likes this.
  8. Villa

    Villa Administrator Administrator

    Bummer! :(

    Have you tried cycling the TV inputs?
     
  9. Larry91

    Larry91 New Member

    Cycling meaning trying a different HDMI input? Yes, TV downstairs has three and I've tried two HDMI inputs with the same results. Is it possible to reload the firmware from a USB stick? BTW when I put the pin down the "hole", I can definitely feel a switch sensation. I've looked for information on what this "possible hardware reset switch" does, found nothing so far. Found it: http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/
     
    Last edited: Jan 9, 2018
  10. Villa

    Villa Administrator Administrator

    No, I mean using the TV remote cycle through the TV inputs - eg switch the input to TV antenna (If you have one connected), then to the next input, until you're back to the HDMI input.

    You can reflash the device...
    Full system image with USB flashing tool:
    http://www.minixforum.com/downloads/download.php?file=U9H_FW007A.rar
    MD5 checksum: 8489FD4545EAFBD6DAC818503E6D0EFB

    Full system image flashing guide:

    http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/
     
  11. Larry91

    Larry91 New Member

    OK, understand "cycling". Yes, I've done that. I'll try reflashing with FW006 next. Thanks for your help and encouragement.
     
  12. Larry91

    Larry91 New Member

    I think I raised my U9-X from the dead! At least I have fw006 up and functioning. That "usb burning amlogic" windoze software (described in the guide above) is a godsend. Now to install my apps etc. Thanks again for your help.
     
    Villa and kingsizept like this.
  13. Clemery76

    Clemery76 Member

    Looks like I've got the same issue... I get the Minix logo on screen when first powering up, but then goes to a black screen and the TV says No Input.
    I have tried multiple inputs, another TV and a computer monitor... all exhibit the same issue though. I think I may have changed the display output to 4K on my last use, but cannot specifically remember. But even if this were the case, I do not understand why it would not display on my 4K TV where it was previously working, even when connected directly to HDMI 1 (primary 4K input).
    The reset button made no change, so will try the reflashing as described above.

    Gotta say... I have never had so many hassles with any other media player I've ever owned.
     
  14. Clemery76

    Clemery76 Member

    I seemed to have sorted this problem using the above advice also, so thanks. Re-flashed to FW007 and the device is displaying properly again. Now I just need to reinstall everything and set up my library again!
     
  15. Larry91

    Larry91 New Member

    Yes, a bit of a hassle but the USB flashing program made it easy. Much easier than putting the firmware on an SD card and all the gyrations that go with flashing a PI or similar. Since I reflashed the device with 007A, haven't had any problems but haven't tried to set it to 4k either. Looks just fine at 1080p. Only gripe is the .apk for plex is not very complete. Also, I thought I saw a means of saving your settings so after flashing they can be restored? Was it an .apk?