1. Welcome to the official forum for MINIX devices!

NEO X5 does not boot

Discussion in 'NEO X5' started by Supert8ch, Sep 6, 2014.

  1. Supert8ch

    Supert8ch New Member

    After I tried to up grade the NEO with 4.2.2 it went to having the MINIX on the screen for a few minutes and Droid image for a few and back and forth. So then have tried rolling it back to 4.1.1 and even the stock image and I get MINIX for a few minutes then it is blank. Any one have any ideas of fixing this as the forum is new not sure if the answers were in the old location?
    kenan likes this.
  2. sjc1963 Neox5

    sjc1963 Neox5 Member

    4.2.2. has never been fully stable on the x5. 4.1.1. has always been better with me it has been build 010 that has been the best.
  3. KAR

    KAR Developer Super Moderator

    Try http://www.freaktab.com/showthread.php?14982-MINIX-X5-android-4-4-2-KitKat-ROM-(beta)

    Running it at my x5 and pretty stable.

    Kar
  4. Supert8ch

    Supert8ch New Member

    Maybe the details may change as I am not sure about the 116a. My model says
    Model.:X5 ver B2 (16GB)
    WMFNEOX5
    I have tried many of the firmware versions and no luck. 010 version is sitting at MINIX screen. It is not the booting screen that you seen the blue color around it pulsing. Other version I see the MINIX and the blue pulsing shade and then after 5 minutes or so it gos blank. Screen still sees something attached but there is nothing displaying. When it boots up the screen shows 1080 60Hz in the upper right corner. I will give KitKat a try and see what happens.
    Last edited: Sep 6, 2014
  5. KAR

    KAR Developer Super Moderator

    Should work. Good luck!

    Kar
  6. Supert8ch

    Supert8ch New Member

    Ok so installed the KitKat 4.4.2 and after the firmware was done the box turned Pink. I then exit the RKBatch tool and unplugged the power cord and plugged it back in. It booted up with 2 Penguins in the upper left corner and screen resolution of 1080 in the upper right. Then it would flash and go blank then back to the 2 penguins. Then after about 10 minutes the screen went blank again. Nothing showing. So any more ideas of the problem? Thanks for the help so far.
  7. KAR

    KAR Developer Super Moderator

    Looks like a defect one.. Did you use the restore button on the rkbatch toolm

    Kar
  8. Supert8ch

    Supert8ch New Member

    Yes, every thing I have been reading says to only use it. It was operational before doing the firmware. It had custom config on it with password, it was a used unit. That was why I wanted to install factory firmware. Thinking about doing the shorting block to see if that will help any as explained in this post. Ok so I can not paste the link in here.
  9. Supert8ch

    Supert8ch New Member

    Ok after further review I think I have found the issue. It has to do with there is 2 models of the NEO X5, one is 116A and the other is 116i. The I has some added stuff for digital signage and serial, power on and jtag. I got the unit from a box of computer stuff I bought from a retail group. So they must have had some thing going there. So now I have to figure how this will work with changing the firmware with the unit I have. I thought this would be a nice thing to play with but now thinking that might be a larger issue.
  10. mavs69

    mavs69 New Member

    Hello Supert8ch, could you solve the problem?

    I am having the same issue with my NEO X5. After upgrading to 4.2.2 FW following tutorials, I just find an android and MINIX on screen. Nothing eles and the device does not reboot.
    When I tried to go back to 4.1.1 FW, a blank screen is all I get after booting the device.
    Could you please come back with any solution?
    Thanks
  11. armen

    armen New Member

    Hi, I also have the same issue, it just boots to the Minix logo or just keeps restarting. any suggestions? The tool recognizes the device and I am able to flash it, Is there anything else to flash other than the firmware?
  12. snisgav

    snisgav New Member

    I have the same problem, I upgrade to 4.2.2 and on reboot just the MINIX flash on my screen.
    Since it is not easy to go back I hope that some one can help
  13. KAR

    KAR Developer Super Moderator

    Try removing all device except the hdmi and reboot

    KAR
  14. snisgav

    snisgav New Member

    Thanks I already tried it, same result.
    I heard that there are two types of Minix X5 do you know what are the differences between them (16GB) or how to get over the loader.
  15. KAR

    KAR Developer Super Moderator

    You might have a x5i, can you see this somehow at the label ?

    Thx
    KAR
  16. snisgav

    snisgav New Member

    No the label specified:
    MINIX neo X5 [16GB]
    Dual Core Media Hub. Assembled in China
    FCC ID: WMFNEOX5
    And its S/N
    By the way do you know where I can get X5 scheme, I have another X5 that do not boot at all even through OTG
  17. snisgav

    snisgav New Member

    Hi
    I downgrade my X5 back to 4.2.2 Jellybean and then successfully update it to 4.4.2 Kitkat
    Thanks for your Prompt answer
  18. KAR

    KAR Developer Super Moderator


    So understand it is working now?
    KAR
  19. snisgav

    snisgav New Member

    Yes its OK
  20. Sorin Buliarca

    Sorin Buliarca New Member

    I had the same problems the days before, and it turns out I was trying to flash an X5 mini image on an X5 device (not mini).
    So, please be careful in choosing the firmware version you try to flash, as Google will feed you the mini version in the top results.
    HardwareGuru likes this.