1. Welcome to the official forum for MINIX devices!

neo x8-h does not turn on

Discussion in 'NEO X8-H, X8 Plus & X8 Guides and FAQs' started by ineagu, Nov 9, 2015.

  1. ineagu

    ineagu New Member

    hello,
    one day the box decided not to turn on anymore...
    how can I tell if there is a hardware or software problem ?
    do you know a shop that does repairs?
    thanks
    IN
  2. Villa

    Villa Well-Known Member Super Moderator

    Does the LED on the front illuminate? Can you see a red light from the SPDIF connection on the back?
  3. GAbor BElko

    GAbor BElko New Member

    Hello, I have a similar problem. From one day to another my MINIX X8H doesn't start. The first phenomenon was that it was freezed in the droid logo at startup and nothing happened even after 5-10 minutes. The only way to restart was to unplug and plug in again. But the result was same. Now I have nothing but a black screen the blue LED blinks once at startup just as the SPDIF LED but both switch off immediately. If I connect it to a PC it sound if the PC connection is in progress but no USB equip. appears. I can't reset (unplug > pres the reset button > press the power button while pressing the reset for a few secs) nothing happens

    I have to ideas:

    1. This MINIX X8H crapped :-(
    2. The power supply is crapped (I measured and it has 5,2 V output but still didn't check what happens if it gets charged)

    Do you have any idea?

    The only thing I've done was a firmware update from this forum and it still worked for a few weeks without serious problem.
  4. Wzul72

    Wzul72 New Member

    Hello, I have a similar problem..you unit ok now?

    Mr Villa you have any solution?
    Last edited by a moderator: May 17, 2016
  5. GAbor BElko

    GAbor BElko New Member

    I have no solution. :-( My MINIX is a beer mat now. I'm really disappointed and I don't think will ever buy a MINIX again.
  6. Brent Conway

    Brent Conway New Member

    i have the same issue. red spdif is on solid at the rear. no blue led at the front. worked this morning. im guessing the box is pooched?
  7. willson

    willson New Member

    Me too, happened a couple of weeks ago. Finally got around to try flashing the 009 img. The box is Not seen by the USB Burning tool (not the tv).:cry:
  8. Dennis_N

    Dennis_N Member

    Same here, i wanted to restart my device and got a freezed logo and a black screen.

    Anyone?
  9. datrh

    datrh Active Member

    i would try a reflash via the zip method or a libreelec build to figure out if it's hardware or software related.
  10. Dennis_N

    Dennis_N Member

    That wouldn't work, because my minix doesn't do anything anymore. The spdif led blinks twice and than nothing, no boot, nothing.