1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

NEO X8-H PLUS stock firmware

Discussion in 'NEO X8-H PLUS stock firmware' started by MINIX - Ken, Nov 30, 2014.

  1. Higgs

    Higgs Yellow Dude Super Moderator

    You should be able to unselect it after you load the firmware file. DO NOT start the burning process with it ticked.

    Sent using Tapatalk
  2. Healer

    Healer Member

    I think you have to load the image first for that option to be available.
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I repeat: Never check this option! And don't proceed if it's checked! Please!
    donotoverwritekey.jpg
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Merry Christmas!
    I need to go bed... zzz... zzz... good night.
  5. escape

    escape New Member

    Thank you for your support. I've restarted the process with hdmi cable plug in the TV (maybe an unnecessary step), and then everything was fine. Flashing worked smoothly and now I have the latest firmware. Thank you once again for your support and the new firmware. I’m going to test it right away
  6. Argyrios

    Argyrios Member

    Many thanks Ken. Just flushed it. Great work. Have a good rest.

    Please note that the following is not working with the new firmware:

    • DVBLink PVR Plugin does not play 1080 stream with MP3 audio. Keeps buffering (using wifi 802.11AC). Note that timeshift is not enabled, as when enabled the below issue appears...
    • DVBLink PVR Plugin force closes after 5 seconds when Timeshift is Enabled on the plugin.

    Let me know what information you would need to have this checked.

    Best wishes

    Argyrios
  7. Argyrios

    Argyrios Member

    Dear Ken

    One more issue...H264 Video with level 4.0 and AAC audio does not playback the audio part while video is playing fine when streaming from UPnP device (Synology). Same stream sounds fine with latest Kodi 14.0 stable release on the same firmware.
    Tried both HDMI passthrough and HDMI passthrough and SPDIFF passthrough options but same effect.

    Could you possibly have a look into that as well?

    Best wishes

    Argyrios
    Last edited: Dec 26, 2014
  8. mcln27

    mcln27 New Member

    Dear Minix

    my x8-h plus arrived a few days ago and everything workt great
    I got mail for the new firmware and installed it everything workt perfect
    I did it al on my bedroom tv witch is a sony
    I connected it on my samsung tv and only the android puppet appears and then everything went black
    I conected it again on my sony and everything was ok again
    back on my samsung black again ???????????
    My x5 and x7 and my x8-h plus al worked on my samsung tv so its offcourse not the tv

    The original firmware was from 14-11-14
    So maybe there is something wrong cause i read that there are more people who has a black screen
    Can you please gif me a link for the 14-11-14 firmware ? so i can check it out

    Greetings Marcel
  9. mcln27

    mcln27 New Member

    Hi There I have the same problem have you tried the box on an other tv cause on my sony tv the box works perfect but on my samsung tv i have a black screen so the box works but i think it has something to do with hdmi before i flashed i had no problem on my samsung
  10. mcln27

    mcln27 New Member

    Is there someone who has the 20141114 firmware so i can flash that one again
  11. J0tar0Kjo

    J0tar0Kjo Member

    file missing :/
  12. Higgs

    Higgs Yellow Dude Super Moderator

  13. agazza

    agazza New Member

    Does it work to flash the old firmware?

    When is Minix realesing a fix for this?
  14. anri

    anri New Member

    I have the same "black screen" problem with Samsung UE32F5020AK and 20121122 and 20141225 firmware.
  15. agazza

    agazza New Member

    Could we get som kind of ETA on this fix? I bought the box weeks ago and it´s useless like this
  16. Virion1

    Virion1 New Member

    I am also stuck with the same problem- android puppet followed by black screen. Unfortunately I only have Samsung tv . So x8 is practically dead for me. Please fix this issue with Samsung
  17. ghale

    ghale Member

    Hello,
    I've just downloaded the file from the forum mirror and the MD5/CRC/SHA1 code are different, even if the rar file is not corrupt!
    Anyone has the same issue?
  18. ghale

    ghale Member

    The MD5 is correct, the SHA1 NOT!

    I get:
    SHA1: 9cdc8623c1314a568855ec8d5c97555905bcf73a
    MD5: 58da279b1fb428e4602e3077c9d378c4
  19. gianka

    gianka New Member

    Can anyone tell me where I can check my firmware version?? Anyplace I look I see different numbers, but no reference to 002 or 003
  20. spec

    spec New Member

    Open "SettingsMbox" -> Other -> Build number