1. Welcome to the official forum for MINIX devices!

Neo X8 Plus suddenly stuck on start up screen

Discussion in 'NEO X8-H, X8 Plus & X8' started by Yagil, Oct 1, 2016.

  1. Yagil

    Yagil New Member

    My Neo X8 plus suddenly stuck on start screen.
    I have done many restarts with and without the recovery buttom pressed.
    The start up screen (Green Minix logo) stays for a couple of seconds on and then turns to black screen.
    I have tried again with the USB plugged with the latest software ZIP file in and again the same description as above.
    Please Help. I have no warranty for the unit.
    I have not made any updates from the time it was purchased in 2015.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Try reflashing the unit with a full system image.


    從我的iPhone使用Tapatalk 發送
  3. Yagil

    Yagil New Member

    Hi and thanks, Could you direct me to a guide how to do this and from where to take the image?
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Hi, please refer to the first post of this thread:
    http://minixforum.com/threads/x8-x8-plus-x8-h-official-firmware-009-20160324.11938/

    Which is:
    Full system image with USB flashing tool:
    http://www.minixforum.com/downloads/download.php?file=X8_X8PLUS_X8H_FW009.rar
    MD5 checksum: 5ff2182fc32fd13284ce5cff93be513f

    Guide:
    http://minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/
  5. Villa

    Villa Well-Known Member Super Moderator

    Can I just ask that it is an X8 Plus that you have? As you have posted in the X8-H Plus forum!
    If so then follow @MINIX - Ken's instruction above.
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    He said X8 Plus, I'm not sure if he owns X8 Plus or X8-H Plus, they use different firmware... you're right...
  7. Yagil

    Yagil New Member

    I probably been confusing, I don't know why I believed mine is a Plus... By looking at the box I see the wording "MINIX X8 H" There is no "PLUS" in it.
    How does it change the instructions above?
  8. Villa

    Villa Well-Known Member Super Moderator

    It doesn't! Go ahead and follow Ken's instructions. (y)

    I will move the thread to the correct forum.
  9. Yagil

    Yagil New Member

    Ken, Villa thanks.
    Worked like a charm. My Minix is back...(y)
    Villa likes this.
  10. dpak

    dpak New Member

    I am also facing the same problem in my Minix Neo X8-H. So I have tried as per your instruction but there is a compatibility issue in my Window 10. I have burn the image by through USB Flashing tool. As per instruction, I power up the device while holding the "Recover" button located at the back of the hub first. But unable to success the connection. The device unable to recognized in USB Flash tool. I have tried changing the USB hub of computer but no success. So here I need your kind support & sure shot guideline please. Thanks in advance
  11. mark2

    mark2 Active Member

    Try this connect your Minix box to pc with OTG cable plug in your box switch on then double click the USB flashing tool
    you should then be notified the tool has installed now unplug the box and start over following the flashing instructions
    it should now be recognised
  12. my_fiero

    my_fiero New Member

    I have the same problem.
    So I tryed USB burning tool to make install a new firmware.

    USB burning tool gives "HUB2-8 Connect success"
    Then I load "X8-X8PLUS-X8H_FW009"
    Press "Start"
    And it goes to 6% and stops

    On screen "6%:[0x30404004]UBOOT/Partition boot/Get download status/Error result" time 4 statistic 1/1

    And I can't update te miniX NEO X8

    What can I do, to fix this error?

    Also by other firmwares the same error
  13. my_fiero

    my_fiero New Member

    anny help please?