1. Official MINIX forum

Official Release NEO Z64 Android 20150930 firmware (update.zip)

Discussion in 'NEO Z64A Official Firmware Releases' started by MINIX - Ken, Oct 5, 2015.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all NEO Z64-A users,

    First of all, sorry about the delay of releasing September's firmware as we were having an exhibition in Berlin early last month and then got tied up with lots of following tasks, and then now we are having the National holidays here for a week. Apologies for that!

    We have uploaded the full zip update image to the forum server (EU).
    Please download the "update.zip" package, verify the checksum, no need to unpack it, copy to a USB drive and then running the update via "check local" of our built-in MINIX System update app.

    Note: FOTA update will be released right after National holidays finished,
    we can't do that now because the FOTA provider office is closed too.
    If you prefer updating by FOTA, please wait a few more days.


    Minix Forum Link:
    http://www.minixforum.com/downloads/download.php?file=update.zip
    MD5 checksum: 549438A3DB0CEA2409CA6104F0AE7D8C

    For the latest Kodi build released by us, please visit:
    http://minixforum.com/threads/kodi-15-1-x86-minix-edition-for-z64-android-august-2015.7250/

    Regards,
    Team MINIX.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Reserved for changelog, and some other information.

    1.) Please note that AirPin (PRO) will pop-up an update notice to version 2.9.5 which added support for iOS9.

    2.) Most features of this 2.9.5 version works, but do expect some minor bugs as iOS 9 is quite new and has many bugs itself also.

    3.) Audio output option problem is fixed. Your choice will be saved upon reboot.
  3. Apocalypso

    Apocalypso Member

    Just tried installing the update via the "check local" of the update app as per your instructions. I keep getting a "not found an update package" message.
  4. shurikello

    shurikello New Member

    Updated. Everything is good at first glance, thanks.
  5. Higgs

    Higgs Yellow Dude Super Moderator

    Did you check the Md5 checksum of the downloaded file?
  6. Talpaz

    Talpaz New Member

    Is there a log of all changes...

    Thanks

    Stefano
    mak90 likes this.
  7. schumpi

    schumpi New Member

    Thanks , great work (y)
  8. Apocalypso

    Apocalypso Member

    Yes. Actually did it twice with two different checksum apps on my Minix. Am I missing something additional?
  9. Higgs

    Higgs Yellow Dude Super Moderator

    Possibly. It seems to have worked okay for shurikello.
    What steps did you take?
  10. Apocalypso

    Apocalypso Member

    I downloaded the zip file then I verified it using an app called MD5 Checker from Google Play. Then once it was verified I tried to locate the file using the "local" option of the Minix updater. No luck.

    Admittedly I'm not familiar with the whole checking the MD5 checksum bit but as far as I know I followed the instructions according to what was posted. Still confused as to why it isn't working for me.
  11. Higgs

    Higgs Yellow Dude Super Moderator

    As long as the md5 checksum shown on your app matches the one given in post 1 then it should be okay. Did you download the file directly to the device?
    You could try downloading it on a pc then copying it over.
  12. Apocalypso

    Apocalypso Member

    Yep, they matched. I downloaded the file directly to the default download folder in my Minix. I'll try the PC method and post my results later this evening. Thanks for the help so far though.
  13. Higgs

    Higgs Yellow Dude Super Moderator

    Try copying/moiving the update.zip file from your download folder to the internal sdcard root.
  14. schumpi

    schumpi New Member

    @Apocalypso: Yes, your problem is the download folder. Move it to your sdcard root. I had the same problem ;-)
  15. Apocalypso

    Apocalypso Member

    Thanks Higgs and schumpi for the tip. I'll try that later this evening once I'm home from work.
  16. Higgs

    Higgs Yellow Dude Super Moderator

    I had the same issue when I upgraded this evening. Copying to the internal sdcard didn't work either so I copied to a usb drive and it worked from there.

    Sent from my XT1032 using Tapatalk
    Apocalypso and Talpaz like this.
  17. Talpaz

    Talpaz New Member

    Hi,
    I've successful updated with the same method used by Higgs, but I've noticed some things still not working and I wondered if Minix plan to fix them in the future:
    1) Play Movies doesn't play anything (Message: Playback is not supported on this device)
    2) When the system boot up with an externa HD plugged in, I have to wait several minutes before accessing it while the external HD is checked for errors
    3) Samba sharing is not available without rooting (while I've read that the Neo X8-H+ support this in firmware)

    I think that at least #3 should be addressed...

    And BTW, any hope to see an update to (at least) lollipop?

    Thank you

    Stefano
    Last edited: Oct 5, 2015
  18. Apocalypso

    Apocalypso Member

    I just tried the same method and it worked for me also. Thanks for the tip.
  19. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Yes, I forgot to mention, please use a USB drive to perform the update.
  20. PLAY911

    PLAY911 New Member

    Hi there, 1st thank you for the update and effort. I would like to report a problem that I have once with the new FW. All the apps that I have installed from Google Play are displayed as if it were an smartphone. Just a central strap in portrait. I have tried to uninstall and install and no solution. Also the Frame refresh for watching TV shows doesnt work. With the new Kodi everything turns 24fps but never to 50fps when should be to 50fps for a TV channel. Also for the apps when watching some TV show turns to 24fps. The app works fine in X8H plus the app mentioned is CLAN RTVE
    Thank you again for your support!!!