1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Custom ROM NEW - Finless 2.0 ROM for the Minix X8/X8-H

Discussion in 'X8-H & X8/Plus Custom ROMs, Kernels & Discussion' started by DaveB, Dec 4, 2014.

  1. DaveB

    DaveB Member

  2. genem

    genem Active Member

    It works the same as the official V2, tried it also on my spare system, tested it, compared results with the original V2 and find no diffirences.
    What i noticed is that the measured (Speedtest) Ethernet AND WiFi speed is slower compared with the 9.2 beta.

    Minix fw
    In 9.2 Ethernet WiFi 2.4 Ghz Wifi 5 Ghz
    speed 51 Mb/s 25 Mb/s 27 Mb/s

    In V2 41 Mb/s 21 Mb/s 29 Mb/s

    Finless fw
    In 9.2 Ethernet WiFi 2.4 Ghz Wifi 5 Ghz
    speed 85 Mb/s 48 Mb/s 54 Mb/s

    In V2 41 Mb/s 21 Mb/s 29 Mb/s
     
  3. NetAndif

    NetAndif Member

    Firstly i have to thank Finless for the hard work. The Rom is very good, have no problems so far (besides Amazon Prime Video not working).

    Now wanted to change the bootlogo and animation. For the animation, there was no problem to do it.
    But after many hours i am now out of ideas concerning the boot logo.
    I've managed to unpack logo.img using a tool called AMLResSpliter.exe. However, could'nt find a way to inject a proper logo bitmap and repack.
    Then i found a thread at freaktab where i followed the instruction to get the Amlogic Customisation Tool up and running.
    But the tool refuses to unpack logo.img (installed to a folder in the drive's root, run as administrator)
    What else could i do?
     
  4. Eryan

    Eryan New Member

    Hi DaveB

    I am thinking about giving a shot to your ROM. However, before installing, how is the HDMI-CEC in your ROM working. I am currently running Official FW2 and I can't control the X8-H using the receiver's remote control (can't use my TV remote since my TV is non-smart).

    Thanks!
     
  5. genem

    genem Active Member

    CEC only works If your tv support it, otherwise no succes no matter what fw you use.
     
    Last edited: Dec 11, 2014
  6. Eryan

    Eryan New Member

    So, HDMI-CEC control of the Minix works if and only if the TV is CEC capable? I mean, the receiver is between the minis and the TV, and the receiver is the one fully CEC capable. I don't see why the commands from the receiver can't be transmitted to the Minix thru CEC.

    In other words, if I want to get rid of all the controllers I have and control TV, Receiver and Minix with one single remote; I have to get a smart TV with full CEC support?
     
  7. genem

    genem Active Member

    CEC Goes through the HDMI, so your tv or receiver has to have the ability to send them thru.
    Unles you have your HDMI connected to your receiver and from receiver to the tv, and your receiver can send the signals back to your minix, iTS not gone work.
     
  8. pusb87

    pusb87 Well-Known Member Trusted Helper

    dont think TV has to be smart, my old Samsung isn't and CEC works
     
  9. genem

    genem Active Member

    Have you already tried to set in the minix setup under others, cec to enabelen.
     
  10. Eryan

    Eryan New Member

    @genem: Yes, I checked the CEC setting already. They are enabled.

    @ Frederick_99: My TV is a relatively old non-smart Thomson. It says it supports CEC, but from previous experience with my R-Pi, I know that the only CEC command it supports is turn on and off.

    I checked yesterday in the evening with different HDMI cables, just to discard that they were the issue. The thing is like this:

    -Receiver can control PS3 via HDMI (using receiver remote, all functions supported, can fully navigate thru the PS3 interface).
    -Receiver can turn on and off the TV (using receiver remote). No other functions are supported by the TV, it's a relatively old Thomson one.
    -When turning off the TV with its controller, receiver turns off and Minix go into sleep mode.

    In other words: The Minix can see the commands coming from the TV, but not from the receiver. However, I found yesterday that, in order for the PS3 to be controlled with the receiver, I had to register it into my receiver using a remote control code. I ended up using a "Sony bluray player" code that I found in the receiver's manual and Voilá! full control of the PS3 with the receiver controller. Remember that the PS3 has no IR, and the receiver remote is not Bluetooth, meaning that the only way the commands can be transmitted is via CEC. Perhaps the issue I am having is that I have to register the Minix in the same way as I did with my PS3, but I have no idea what code should I use to register it.
     
  11. bobulon

    bobulon New Member

    Well that's a total deal breaker for me if it's true, I don't want to cut my ethernet speed in half! 1080p's will start buffering again
     
  12. Lukas

    Lukas New Member

    There is no connection between Smart TV's & CEC both completely separate & independent technologies. My Sony TV is old (V4000 series) & none 'Smart' but is CEC compatible & works perfectly with my X8-H. As said above though your TV has to be CEC compatible or it simply isn't going to work no matter what you try.

    The Minix doesn't allow you to power the device on & off through CEC though. Can put to sleep & wake & obviously navigate, play/pause etc.
     
    Last edited: Dec 23, 2014
  13. Eryan

    Eryan New Member

    Hi Lukas

    Thanks for your answer. After playing a little with the box and my tv , I found that the TV is the problem. Not a huge issue, but using one single control is nice to have. Probably I'll get another TV at some point, so no big deal.

    Happy holidays!
     
  14. Weezerfan

    Weezerfan New Member

    Where is shutdownanimation located?

    Please let me know if you find a way to replace boot.img
     
  15. NetAndif

    NetAndif Member

    bootanimation.zip is located at /system/media so shutdownanimation.zip should go there too, i think. However, tried shutdownanimation but didn't work.

    Sorry, i've given up on this. Even though i managed to flash a modified logo.img, on next boot the logo is reverted back.
     
  16. rpgmaker

    rpgmaker Member

    Can anyone tell me how to flash this rom? I'm used to flashing roms on my phone but not sure how to go about it on this box. An url to a useful how to would be enough :)
     
  17. pusb87

    pusb87 Well-Known Member Trusted Helper

    see the 1st post in the thread ?
     
  18. rpgmaker

    rpgmaker Member

    There's nothing on the first post but the link to the rom.
     
  19. pusb87

    pusb87 Well-Known Member Trusted Helper

    well click the link then and read it, install instructions are provided there (y)
     
  20. Lionel

    Lionel New Member

    Hi
    I want to flash the Finless rom and I need a fat32 formatted sd card. So I have a micro SD card putted in a micro SD card adapter. But my minix won't read it. In my computer no problem to read but yeah my minix doesn't. Is It cause of the adapter? Should I buy an SD card that doesn't need an adapter to fit the minix? Is it so that I should see the SD card as an external SD card in a file Explorer on my minix? Can I flash the rom with a formatted USB stick? Or must it be an SD card? Thanks