1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

NEW! Minix U1 EZ root ZIP method

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by Rawhide85, Dec 17, 2015.

  1. Sam08861

    Sam08861 New Member

    Ok, trying again. Was able to revert back to the 'stock' recovery.img by flashing the recovery.img file from the EZroot zip file set to recovery. This allowed USB Burning Tool to connect again and I am back to vanilla FW13.

    Starting at the top now and following gbaker72's steps.
     
  2. Sam08861

    Sam08861 New Member

    Ok, Magisk installed and SuperSU also installed.

    Still getting the 'No enough space!' error on the file copy in either terminal emulator with su or using ES File Explorer with root privileges.

    So thinking this is Magisk not allowing the files to be modified in the /system area.

    Will have to search for a workaround, however, the system does seem to be rebooting fine.
     
  3. gbaker72

    gbaker72 New Member

    I tested moving an mp3 to internal storage with no problems using the file browser app. I also transferred a 369 mb mp4 movie and had no issues. The file browser app uses ES File Explorer "Share with ES save to". I should also mention that I have two sd cards: one with only the recovery on it (that I don't use unless I need root after a fresh install or perhaps after an manual update) and the other that I normally use that has my apk's and movies on it.
     
    Last edited: Jul 27, 2017
  4. Sam08861

    Sam08861 New Member

    Thanks gbakaer72, I was also able to save to internal storage for the non /system areas.

    Are you able to save anything on internal storage in /system folder? Seems that magisk prevents that to keep the original image intact and thus undiscovered as rooted for items that check this acting as a 'systemless root'. I'm certain there's a way to do this somehow, or perhaps magisk can be temporarily disabled with root enabled. I'll keep looking and see what I can find.
     
    Last edited: Jul 27, 2017
  5. gbaker72

    gbaker72 New Member

    Welcome,
    What is the full path on the local disk. I was able to move a file from sd card to "/storage/emulated/0/backups/system".
     
  6. Sam08861

    Sam08861 New Member

    Full path is

    /system/lib/modules/

    Was able to create that folder but not save or copy files.

    I was able to save to other folders outside of /system just fine.
     
  7. gbaker72

    gbaker72 New Member

    I assume you made each folder "/system/lib/modules/". My full path is "/storage/emulated/0/system/lib/modules". If we are on same page, then yes I was able to move a file into self-made folders on the internal disk. If you are accessing some deep hidden internal files then that is way beyond my knowledge.
     
  8. Sam08861

    Sam08861 New Member

    The folders already existed except for modules.

    The /system is the same level as /storage I believe. Worked fine in FW12 with the ezroot method to get my touchscreen working. Magisk, I believe protects this area as its the core kernel
     
  9. Sam08861

    Sam08861 New Member

    This thread has info on what I have to do to add the drivers for touch capability. Worked great on rooted FW12

    http://www.minixforum.com/threads/neo-u1-with-a-touchscreen-monitor.12965/


    And even allowed ota update, and fw 13 even ran well, but upon reboot got stuck on minix flashing screen due to root. I'll see if I can side load the files to the kernel and continue to use magisk
     
  10. gbaker72

    gbaker72 New Member

    I've decided to go back to the previous version. Too many issues & it's hard to say if it's a bug with FW13 or just a rooting issue.

    1st issue app Ad Away (not enough space on the partition msg).
    2nd issue can't access SuperSU (SU Binary occupied msg).

    I prefer to have my device rooted & stable.
     
    Last edited: Jul 27, 2017
  11. Sam08861

    Sam08861 New Member

    gbaker72, I also found I binary occupied when clicking super su from the apps menu, but could use it from the magisk manager menu. Not sure if that helps.
     
  12. Sam08861

    Sam08861 New Member

    Allright, I appear to be working and no more issues.

    Here's what I did. 1st, used usb burn tool to put on a fresh image 13 and then followed gbaker72's steps exactly.

    Opened Magisk manager.

    Clicked uninstall button at bottom and then system reboot button in same magisk console.

    After reboot, I was able to copy the necessary files into the /system/lib/modules folder (and /system/usr/idc, where I was able to copy to before, so wasn't a problem) and now my touchscreen is working in FW13.

    So reboots fine, and magisk manager still says magisk is installed, so go figure.

    Any, appears I am fully working again. Will try a couple of reboots to make sure.
     
  13. Sam08861

    Sam08861 New Member

    ps.. many thanks to torquewrench001 and gbaker72 for your help!
     
  14. gbaker72

    gbaker72 New Member

    I clicked Magisk Manager icon and selected uninstall. I still had issues with the AdAway app (version FW12 had no issues). This root method appears as valid when verifying via rootchecker app. You can also update SuperSU from the google playstore to get the latest version.

    Do not uninstall Magisk Manager going through settings-apps-downloaded apps as it will remove root! I think I will stay with FW12 (less issues). I hope the next revision is compatible with the original EZ-Root Method!
     
    Last edited: Jul 28, 2017
  15. torquewrench001

    torquewrench001 New Member

    I don't flash the recovery onto my box, I just boot it from the usb stick when I need it. That leaves the stock recovery intact. Have you flashed the SU 2.82 from XDA? I don't kow why you wouldn't be able to access all the root directories. I have only used Magisk one one of my boxes to try it out, for now I'm going to stay with SU as long as it works for me.

    Also I believe the original EZ root zip just uses an earlier version of SU. If you open the EZ Root zip in &zip you can find the SU apk in there. I was going to try to swap out the SU with the newer version but didn't get taht far. Might be an option.
     
    Last edited: Jul 31, 2017
  16. Sam08861

    Sam08861 New Member

    I had originally flashed the twrp recovery onto my box, but reverted to the original (or a work a like that allowed a stock firmware to be reflashed) by flasing recovery.img files that comes in the zip file for ezroot in this thread, using twrp, ironically.

    I've since learned that this can be run from the usb drive/sd card and am keeping it original for future firmware issues.

    I didn't try the SU 2.82 from xda but did try phhroot via the zip file on xda which didn't work out. (unable to save to /system)
     
  17. gbaker72

    gbaker72 New Member

    Here is what I read in xda forum about the SU Binary occupied message.

    "Since Magisk v13, there's no longer any compatibility for SuperSU. If you've flashed Magisk you're rooted with MagiskSU and that's why SuperSU is complaining about the binary being occupied. You're unfortunately going to have to choose one or the other."

    I have replaced Adaway with a different free ad blocker that is working with no errors while rooted in FW13.
     
    Last edited: Aug 2, 2017
  18. chcknsld

    chcknsld New Member

    Have you guys tried deleting some unnecessary Google apps to free up the system partition? It's what causing the boot loop in FW013. Cause it has bigger resources than FW012. And that's why you can install Magisk Manager but not SuperSU's UI. It's already full when you install Magisk but when you uninstall it, you freed up little space for the touch screen module to be copied over to the system. The same goes for AdAway, it can't make changes to the system because of insufficient system storage. So there's actually two options for FW013:

    1. Free up system partition by deleting apps you don't actually use. I use third party apps like Titanium Backup which also needs our device to be rooted. I already tried this because it's safe and you can always restore those deleted apps by flashing the official firmware.

    2. Repartitioning of system partition to more than 1.5GB but it's very risky and should not be recommended. I tried manual repartitioning on my Nexus 5 though.

    This is based on my observation and I stand to be corrected. I just received my U1 today and it's really the best TV box I bought!
     
  19. fffaj

    fffaj Member

    I've tried flashing Magisk via TWRP but i didn't quite like the setup as it didn't seem to play so well with my other root apps so I reverted back to FW13 and reflashed the latest SuperSu zip using TWRP and bingo, I am rooted on my FW13.


    Sent from my iPhone using Tapatalk
     
    Privatathome likes this.
  20. chcknsld

    chcknsld New Member

    My only problem is I can't install Viper properly. It only works on the system app "Music" and that is by using the Compatible Mode of Viper.