1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

NEW! Minix U1 EZ root ZIP method

Discussion in 'NEO U1 Custom ROMs, Kernels & Discussion' started by Rawhide85, Dec 17, 2015.

  1. Villa

    Villa Administrator Administrator

    Why single out the mods?! :whistle: :love:
     
  2. KingKong

    KingKong Member

    Note the U1 box wont OTA update to the latest fw12 version just released if your rooted. Also if you unroot the box it still wont ota fw update.
     
    Last edited: Feb 28, 2017
  3. RikD

    RikD Member

    If you try to update and you get the error: Warning Your hub has been root or modified!
    update_root_error.png

    The easiest way to update is to temporarily disable root with SuperSU. In SuperSu, go to Settings and uncheck the Enable Superuser box.
    disable_supersu.png

    Now open the update app and try again, the update process will now proceed normally.
    update_checking.png update_download.png

    After updating, you can simply enable root again in SuperSu by checking the same checkbox as before.
     
    DaCrazyOne, Hayo and skynet like this.
  4. 2jzFTW

    2jzFTW New Member

    After FW013 OTA update SuperSU stopped working!
    "Binary occupied" error, I tried to unroot and root again, got stuck on MINIX logo, factory reset didn't help! What to do now???

    Sent from my Redmi Note 3 using Tapatalk
     
  5. Pete_Repeat

    Pete_Repeat Member

    Oh. I might hold off until you find a solution then as root is very important for my boxes with home automation.

    Glad you posted this before I upgraded. Hope someone can help sort it for you.
     
  6. 2jzFTW

    2jzFTW New Member

    I bealive it happened when SuperSU updated to last version 2.82 i think, it seems it's not working well with last FW013 update obviously, now i fixed the problem with full system image flash! But not going to root it again till new solution or confirmation of safe root, I already lost all my data and apps!

    Sent from my Redmi Note 3 using Tapatalk
     
  7. falosi

    falosi New Member

    Try to root using TWRP. It worked with previous versions. I'm waiting for the full flash release, then i'm gonna try.
     
  8. Sam08861

    Sam08861 New Member

    Having the exact same problem as 2jzFTW.

    Reset using the prior firmware and the guide below got me going again. (It will be at the Minix flashing screen for a minute or two after reflashing)

    http://www.minixforum.com/threads/neo-u1-full-system-image-reflashing-guide.10046/

    However, seems ez root and even SuperSU are incompatible with FW 13.

    Staying at FW12 until there's a fix as I have custom drivers needed to use as car pc (since Minix doesn't ship with touch screen drivers).


     
  9. torquewrench001

    torquewrench001 New Member

    Wish I had looked here before flashing FW013. Moving back to FW012 also.
     
  10. Pingouin

    Pingouin New Member

    Thanks guys for the warning. I updated to FW13 and will hold on before attempting root again.
    I never updated to FW12 myself because it wouldn't let me do so from FW11. I tried many times the suggested trick of disabling root from SuperSU before launching an OTA update but it always complained about my system being modified. Eventually, I did a clean install to FW12 followed by OTA to FW13 and reinstalling everything, so I don't feel lucky enough to fiddle around and risk going back to square one again!
     
  11. torquewrench001

    torquewrench001 New Member

    @Privatathome what method did you use. Did you install FW013 by ota, usb or flash image? And how did you flash/install root?
     
  12. Tanyero

    Tanyero New Member

    How did this go for you?

    Edit: Nevermind, version SuperSU 2.82 fails at verification stage via TWRP. And EZ Root returns me to the hung glowing MINIX screen. Back to FW012...!
     
    Last edited: Jul 19, 2017
  13. Privatathome

    Privatathome New Member

  14. torquewrench001

    torquewrench001 New Member

    I just achieved root on FW013 using Magisk. Flashed FW013 using Amologic burning tool put the Magisk zip on usb with my TWRP recovery, booted into TWRP, flashed Magisk zip job done.
     
    Privatathome likes this.
  15. torquewrench001

    torquewrench001 New Member

    Ok root again SU 2.82
    Screenshot_2017-07-21-18-34-03.png
     
  16. Sam08861

    Sam08861 New Member

    Hi Torquewrench, could you post step by step instructions? I've flashed FW13, but am unable to install TWRP or Magisk as they both appear to have being rooted as a pre-requisite.

    Also, assuming your new setup reboots fine and doesn't get stuck at the Minix logo?
     
  17. gbaker72

    gbaker72 New Member

    I did a clean full install of FW13.
    Download (Latest Magisk) https://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445
    Move Magisk.zip to sd card.
    Download (TWRP Recovery for NEO U1, Pick External SD Card Version, Rename the img file to 'recovery' & hold power button after you have reinserted the sd card with the file on it) http://freaktab.com/forum/tv-player...u/568330-unofficial-twrp-3-0-2-0-minix-neo-u1
    You will see TWRP screen and follow instructions to install Magisk First & Then SU. After both install you will not be struck in Minix logo mode.
     
    lildishlvr and torquewrench001 like this.
  18. torquewrench001

    torquewrench001 New Member

    @Sam08861 Have you had any luck? gbaker72 post above spells it all out nicely. You need to use TWRP to flash either Magisk.zip or SU 2.82 from XDA. Developers. I usually put everything on a flash drive. Make sure your box is turned off. For me I turn the box on holding the on button in until I see the TWRP start up screen. (For me that's about 45 seconds) go to install, select storage where you put the zip file. Select the zip and the swipe to install. If you get zip verification failure just turn off zip verification in settings.
     
  19. Sam08861

    Sam08861 New Member

    Hey torquewrench001 and gbaker72,

    Thanks for the replies and info, was a big help so far. I had my usb stick formatted as NTFS, so that was keeping it from loading the recovery.img file. Formatting in fat32 worked so I got twrp working. Magisk was working until I tried installing phh per another forum thread earlier and under the magisk manager console it said 'not installed' so need to back out and start over.

    Going to reflash fw13, but I can't seem to connect to the USB Burning Tool that comes with it after installing TWRP. Will try the TWRP/USB stick method next and start fresh.

    Other problem I have is when trying to add a 283K ko file (for touchscreen driver) it keeps telling me there's not enough space (fresh install of fw13 using usb burning tool method). Not sure if that was because of magisk (perhaps a setting I need to change to allow that or because I installed phh on top of super su)

    However, other than that, it seems to boot just fine.

    Will let you know what I find out.

    Sam
     
  20. Sam08861

    Sam08861 New Member

    Looks like TWRP finds the zip file to be not the right type as I get an error that this "file is for Neo U1, this device is a p200"

    Will see if I can back out of TWRP.

    I got magisk working again by wiping the cache, but still can't copy the touchscreen ko file into the /system/lib/modules folder on the Minix.

    Unless I can find a way to copy this file, Seems I now need to reflash the recovery back to 'stock' or find another way to get back to a rooted FW12 or a clean FW13.

    Still reboots and works though.