1. Welcome to the official forum for MINIX devices!

NGC-1 SSD firmware

Discussion in 'NGC-1' started by Villa, Mar 1, 2017.

  1. Villa

    Villa Well-Known Member Super Moderator

  2. Stew2673

    Stew2673 New Member

    I have download the link but it is not unzipping. Is there a Windows 10 program that does this better then others?

    I was trying to use apps from the Windows store but a direct downloaded program seemed to work for unzipping. Unzipped now.
    Last edited: Mar 3, 2017
    Villa likes this.
  3. Villa

    Villa Well-Known Member Super Moderator

    I would have just said find a bit of software that supports 7z archives like WinRAR or 7-Zip. :)
  4. DavidEll

    DavidEll New Member

    Hi, I keep getting errors when trying to open the above. I've tried 2 different apps, ZIP RAR 7Z and 7Z Opener. What do you recommend I do next?

    Also, is there any chance that you can use a program (to zip files) which is included in the products you supply? I, like Stew2673, am not a computer dude so making it easier would be much appreciated. What would be great is a thread per device, for customers like me, which lists your recommended apps or the apps we need to update?
  5. Villa

    Villa Well-Known Member Super Moderator

    Did you try WinRAR or 7-Zip?
  6. Stew2673

    Stew2673 New Member

    I am using Windows 10 and find the apps thru the Windows Store do not work or work well.
    Use your web browser and find an app that will unzip the file and install that on the computer.
    That did it for me.
    Was very frustrating until I actualled installed a programs and not reply on the Windows apps.
  7. Kazoo

    Kazoo New Member

    How about a changelog or some idea of what has been changed/improved in this release??
  8. Higgs

    Higgs Yellow Dude Super Moderator

  9. wpggwd

    wpggwd New Member

    The link does not work for me. I dont get a download prompt, rather it takes me to a webpage with random characters.
    Can another link be provided?

    What are the instructions for completing this update?
  10. mark2

    mark2 Active Member

  11. wpggwd

    wpggwd New Member

    Thanks mark2. My bad, I was using Firefox. It worked with IE

    Hopefully this fix stops by Minix from freezing up every 20 minutes!
    mark2 likes this.
  12. mark2

    mark2 Active Member

    Welcome (y)
  13. mrceolla

    mrceolla New Member

    I'm confused. Was this thread started almost a year after the v1.3 bios thread which includes the description of this SSD firmware update and link? Or is this a more recent SSD firmware update and the post in the v1.3 thread has been updated with the new information? I can understand wanting to put the SSD firmware in it's own sticky thread, but seeing the March 2017 date made me think this was something new.

    I want to know if I'm missing an SSD firmware update as I've already gone through the v1.3 thread when I upgraded my bios and I believe I upgraded the SSD firmware at that time as well. Is there any way I can confirm which SSD firmware I'm running?

    Thanks,
    Mike
  14. Villa

    Villa Well-Known Member Super Moderator

    v2.9 is the latest

    In the BIOS thread my post was relevant at the time with v2.6 and Ken has updated his earlier post with v2.9 which lead me to create this thread to avoid confusion. :ROFLMAO:

    I have since edited my post...
    http://www.minixforum.com/threads/ngc-1-v1-3-bios-update.13217/#post-105744
    Last edited: Jul 7, 2017