1. Registration issues have now been resolved. New accounts are able to be created

No Kodi audio passthrough after update to FW005

Discussion in 'Official Firmwares' started by Frangelis, Jul 4, 2017.

  1. Frangelis

    Frangelis New Member

    After updating my firmware to version 005 the audio passthrough function does not work anymore from Kodi 17.3. From Plex (another great streaming app) the passtrough works perfectly for all audio-formats, including the HD-ones. However, the overall performance of Plex on this device is not as good as the Kodi performance, I prefer to use Kodi.
    Before updating the firmware, passthrough from Kodi did work perfectly also for all audio formats.
    By the way: I use HDMI audio passthrough and the receiver is a Pioneer SC-LX89 (but the receiver is not the problem here in my opinion).

    Of cource I use Kodi's Expert setting with passthrough enabled for all audio formats. My receiver can handle all formats. The result is no sound at all or abnormal sounds from the speakers.

    As a workaround I use stereo upmixing in high quality with a 7.1 speaker setting, leaving passthrough disabled. The receiver displays a 7.1 channel, PCM, input signal. The sound is great, but I would like if the passthrough option becomes fixed.

    Or do I miss something?

    Thanks in advance for any suggestions.
  2. Higgs

    Higgs Yellow Dude Super Moderator

  3. Frangelis

    Frangelis New Member

    Thanks for your quick reaction.
    I allready tried the solution in this thread, but this did not solve the problem.

    If I change the channel-values (2.0, 7.1 etc.) this results in my receiver displaying the corresponding number of channels during play in non-passthrough mode. So I think this channel-setting is related to the number of speakers in use (and NOT the number of data-channels...)

    Any other thoughts?
  4. Higgs

    Higgs Yellow Dude Super Moderator

    If you are using audio passthrough you must have the number of channels set to 2.0 (not 5.1 or 7.1)
  5. Frangelis

    Frangelis New Member

    I have no reason not to believe you, but I tried the setting on 2.0: In my case this makes no difference (doesn't solve the problem)...
  6. Higgs

    Higgs Yellow Dude Super Moderator

    Did you;
    1. reset kodi audio settings to default,
    2. set passthrough to on
    3. set the passthrough options you want
    4. restart Kodi
  7. MrBig

    MrBig Active Member

    Check your passthrough settings in KODI/Android settings. That may have change with the update.
    That's not totally true. It doesn't matter anymore as psssthrough will ignore what you have your channels set to.
  8. Frangelis

    Frangelis New Member

    I tried this earlier, but did try it again. It didn't work the first time, so I decided to reboot the box before restarting Kodi. And now: It WORKS!
    I watched Dolby True HD-content with the receiver in Dolby Atmos-mode. I'm very happy with this, it's a great device!
    Maybe you can add the 'reboot device'-line in your to-do-list if you advice this to others, just for sure. ;)

    Thank you much!
    Higgs likes this.