1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

No picture on TV

Discussion in 'NEO U9-H' started by jonnyben, Jul 30, 2018.

  1. jonnyben

    jonnyben New Member

    I’ve had my box for 3 days, got it all working. Now when I turn it on (the blue light is on) there is no signal to the TV!?

    I’ve tried using it on my dell monitor, still nothing!

    Any ideas of what I should do? I don't have Immediate access to a windows machine as everything I do is mac based and i'm in China.

    Thanks
     
  2. jackie999

    jackie999 Member

    Have you tried another HDMI cable?
     
  3. jonnyben

    jonnyben New Member

    This HDMI is brand new and I tried holding the power button for 6 seconds, after which the minis logo appeared then distorted and disappeared. Then my monitor went into sleep mode.
     
  4. Villa

    Villa Administrator Administrator

    It could be the PSU?!
     
  5. jonnyben

    jonnyben New Member

    But the unit is powering up and the minix logo pops up for a few seconds so I doubt it's the PSU .
    Looks like it has to go back to the seller.

    I've seem numerous people have this problem ,so if and when it happens in future, is there a way for me to back up my programs and settings to a USB stick so that I can clone them to a new minix box?
     
  6. keanustar

    keanustar Active Member

    The only way to fix this is to flash the latest FW. This happened to me shortly after every update the box had and I had to manually re-install the FW.
    I would recommend flashing the custom Android TV FW. It is way better and smoother.
     
  7. jonnyben

    jonnyben New Member

    The unit has gone gone back to the seller now who has confirmed there is a problem and will put the latest firmware on it. Can I stop the box from auto updating? Because I don't have access to a windows computer to do these firmware flashes everytime the thing crashes.

    What is the custom Android TV Firmware? Is that like the LibreELEC FW?
     
  8. Villa

    Villa Administrator Administrator