1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

No sound after System Update today

Discussion in 'NEO X8-H, X8 Plus & X8 Official Firmware Releases' started by Jo8862, Jul 12, 2015.

  1. Frederick_99

    Frederick_99 Well-Known Member

    I was thinking along those lines that somehow the jack switch is left in a state that thinks it is still connected.

    How about loading your older firmware where it "worked" and then make sure you power off the minix in a state that worked ie you got audio through your HDMI/SPDIF connection .

    Then reload 006A firmware using USB flash tool and prior to inserting headphones see if you have audio

    ......clutching at straws now.....:unsure:
  2. Jo8862

    Jo8862 New Member

    Hi,
    Tried inserting and re-inserting headphones and cleaning with a Q tip whilst still running old version and everything still worked perfectly.
    Thought I'd give it one last go before my brain is fried. Closed box down with everything fine, reloaded new version of firmware via flashing from PC (I believe this is the most reliable method?). Started it up and...No sound, except through headphones. Then re-loaded previous version of software via PC and have sound working again - no problems.

    So as the box runs just fine on the previous version of firmware I am going to just stick with it for the time being :)
    The problem must be related to this now turning off the sound when the headphone socket is in use (or thinks it is in use). All other software updates have gone without a hitch.
    Thanks again for all your help! Much appreciated! Time for a lie down.............
  3. Villa

    Villa Trusted Helper Super Moderator

    Hopefully if we get a switch option as mentioned earlier then you will have no problems.

    I don't know!
  4. ru4freetv

    ru4freetv New Member

    I have no sound after installing new update also. Never had a problem before.Sorry just unplugged headphone and all is fine now .
  5. ywen

    ywen New Member

    I got surprised by the update because I kind of depended on the bug of the last firmware, since I could just switch on/off my jack speakers when I wanted to use my Spdif headphones. Now I have to manually unplug my speakers. It's weird since in minix settings I'm forcing the spdif passthrough...
    I'm also in favor of a software switch!
    Last edited: Jul 19, 2015
  6. Cecilia

    Cecilia New Member

    Guys, I have no sound either. What can we do? I did not touch anything. Just updated, and after the update there is no sound.
  7. Higgs

    Higgs Yellow Dude Super Moderator

    Do you also have something plugged into the headphone jack?
  8. Cecilia

    Cecilia New Member

    Yes, I have a sony home theater connected via headphones output.
  9. Higgs

    Higgs Yellow Dude Super Moderator

    The bug that allowed simultaneous sound via headphone jack and hdmi was fixed in the last firmware. You should still have sound through your headphone jack when connected or sound through hdmi when headphone jack not connected, but not both together.
  10. Cecilia

    Cecilia New Member

    Oh, ok, I disconnected headphone a sound is back, thank you. I'd prefer both sounds together. Anyway, you are doing a great job, I love my minix.
  11. Darbyram

    Darbyram New Member

    i have no audio also, its been happening since last update. though it has been intermittent i have previously got around it by changing the audio settings. x8-h plus
    Last edited: Jul 21, 2015
  12. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    The MINIX team is working on the ON/OFF switch for simultaneous hdmi & headphone output.
  13. Darbyram

    Darbyram New Member

    found a work around for now. thanks to the post
    WeK05 suggested
  14. Carlos Delgado

    Carlos Delgado New Member

    I have no audio also, its been happening since last update FW006 - The solution for me was also to go back to the last release FW005 that fixed it.
  15. Fis2

    Fis2 New Member

    Same problem here: no sound after update.
    Any news about a solution?
  16. Higgs

    Higgs Yellow Dude Super Moderator

    Do you anything plugged into the headphones jack?
  17. Fis2

    Fis2 New Member

    No.
  18. Higgs

    Higgs Yellow Dude Super Moderator

    You need to give more information then on your sound setup and settings, if you have any sound on any apps, do you have sound using headphones etc

    Sent from my HUAWEI Y550-L01 using Tapatalk
  19. Villa

    Villa Trusted Helper Super Moderator

    Check Digital sound output settings.
  20. Fis2

    Fis2 New Member

    I think it is solved. Changed digital audio output to HDMI passthrough.