1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

No Video Signal with FW07A

Discussion in 'Official Firmwares' started by keanustar, Oct 21, 2017.

  1. keanustar

    keanustar Active Member

    I'm going to start a new thread since the FW07A BugTracker is not up and the FW06 BugTracker is already too crowded.
    The FW07A, released on October 21, fixed for me the Play Store issue, but introduced some other issues that were not in the FW06 or FW07.
    On FW06 and FW07, I used to get no Video Signal when waking up the U9 from sleep 3 out of 5 times. Apparently, this was not fixed with the HDCP change that happened in FW07.
    In FW07A, besides the No Video when waking the U9 from sleep, I started getting this issue in other situations as well.
    1. I was playing Baywatch 4K HDR. The video flickered 2 times during the first hour and a little bit after I got No Signal, although the U9 was still playing and the sound was present over Optical.
    2. I was playing Smurfs The Lost Village 4K HDR Remux file. It played fine until the end. When the video stopped, I got No Signal, but the U9 was still on and working fine.
    Each time I had to restart the U9 to get back the Video signal.
    When I played the movies I had all Refresh Rate and Adaptive Refresh Off from U9 settings as well as from Kodi. The U9's resolution was set to 4K 60Hz, as I had it before.
    I am also getting the No Video Signal when switching the U9 to 4K 23.976Hz.

    The TV I have the U9 connected to is an LG B6.

    Is there anyone else having these type of issues?
     
  2. skynet

    skynet Moderator Moderator

    I had the No Signal issue but only when i started videos.
    I resolved this issue by changing 4:4:4 to 4:4:2 10 bits
    Never had no issue during a movie or even after a wakeup.
     
  3. keanustar

    keanustar Active Member

    I should add that I use the default 10bit YCbCr420, which worked fine until FW07A.
     
  4. skynet

    skynet Moderator Moderator

    Have you tried another HDMI input ? Another cable ?

    I already had a lot of issue with a cheap and bad HDMI cable.
     
  5. keanustar

    keanustar Active Member

    Did that on FW05, when I realized that the cable which U9 came with was rubbish and caused No Signal and flicker when selecting Deep Color On.
     
  6. keanustar

    keanustar Active Member

    Update: on Sunday I watched 2 4K HDR movies and a few 1080p shows with no issue, as described in 1st post. I even woke up U9 from sleep 2-3 times without video signal issues.
    On Monday, I Powered On the U9 and it went to No Video Signal after the Android Logo. Same thing happen when I restarted it. It only fully booted into the Menu the 3rd time.
    On each first 2 power ons the player was working in the background, since I was able to hear the sound over Optical when clicking the remote.

    Minix Devs, please look into this. My guess is that the HDCP implemented on the U9 is faulty and the fix you applied in FW07 made it worse.
     
  7. skynet

    skynet Moderator Moderator

    So it should happen to every U9 ... It's definitively not the case
    I had the No Signal issue but only after launching a movie with Kodi AND with YCbCr444 10 bits
    If you have this issue after Android logo it may be a hardware issue.
     
  8. keanustar

    keanustar Active Member

    I would still like a confirmation from Ken that the HDCP cannot cause these issues.
    You know that it depends on the TV you have and how good the both shake heands between them, right? And I thouth that you know that if you don't have an issue, it does not mean that someone else doesn't have it.
    I understood your opinion and would be nice if you can comment something constructive, rather than repeating yourself.
     
  9. skynet

    skynet Moderator Moderator

    I just try to help and find what should be the real problem. You have to go by elimination : I agree with you, if i don't have this issue it does not mean that someone else doesn't have it, but if it was the case (HDCP issue) then most of us would have this issue too.
    So wait for Ken'answer :whistle:
     
    kingsizept likes this.
  10. Villa

    Villa Administrator Administrator

    I don't have the issue with two U9-H devices! ;)
    I didn't have the Play Store issue either with the FW007 update. :)

    I do occasionally have a no signal issue but it is usually sorted by switching or cycling through the TV input signal. It also depends if I am using a HDMI switch.
     
    skynet likes this.
  11. keanustar

    keanustar Active Member

    As someone else mention on a similar thread, where he had no video with AVR, he put the Minix on a HDMI input that did not have HDCP 2.2 and the issues are gone. My TV has all 4 HDMIs with HDCP 2.2. Maybe your TV has only 1.4.
    Would be great to have Ken's opinion on how the U9 handles HDCP 2.2, but lately he went into complete silence.
     
  12. skynet

    skynet Moderator Moderator

  13. keanustar

    keanustar Active Member

    Yes, this is what I was talking about. So my point about HDCP stands. It is a high probability that it is causing my U9 to stop the video signal.
     
  14. wrxtasy

    wrxtasy Well-Known Member

    No Video signal after the Android Logo is definitely a failure of HDCP handshaking on Android platforms that implement some sort of HDCP - audio and picture copy protection measures

    HDCP 2.2 is needed for 4K copy protected Netflix and Amazon Video content.

    Normally when HDCP 2.2 fails a media player should try and re-negotiate at the 1080p only - HDCP 1.x
    Unfortunately as I discovered on another media player HDCP 2.2 can be buggy with AMLogic boxes and when HDCP 2.2 fails it will not always fallback to HDCP 1.x

    Subsequently you end up with a No Video Signal for those TV's with HDCP 2.2 only ports.
    I really do not know why MINIX would even be using HDCP 2.2 to begin with tho.

    A Symbolic link from the HDCP 2.2 binary to the HDCP 1.x binary bypasses the issue. MINIX will need to fix this problem.
     
    keanustar likes this.
  15. WeK05

    WeK05 Audio Visual Master Specialist

    It doesn't seem to negotiate HDCP 2.2 at any time. For that matter, I don't even think that it is enabled in the firmware.
     
  16. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

    Our engineers are looking into this issue now.
     
    keanustar and kingsizept like this.
  17. keanustar

    keanustar Active Member

    Thanks, Ken. Will wait for an update from your side then.
     
  18. damole

    damole Member

    I just found this thread after posting in a different one. Was anything discovered by the engineers?
     
  19. damole

    damole Member

    Should I roll back to 6?