1. Welcome to the official forum for MINIX devices!

Not possible to write on NTFS disk with FW 002

Discussion in 'X8 - X8H Official Firmware 002' started by deiviz, Dec 13, 2014.

  1. deiviz

    deiviz New Member

    I reported my problem in another place, this may be the best sub-forum to post it.

    I updated the X8 to the new FW 002 but I found problems when I tried to write on an external hard disk in NTFS format. I was not able to copy files on it. I have updated the system three times with the FW 002 but I have observed a very strange behaviour: after updating the system it was possible to write on the disk at first. But after several reboots and power off/on the device, it was not possible to write on the disk.

    I have simply tried to copy files and folders with ES File Explorer from the X8 internal memory to the USB external hard disk. When I try to copy files, it seems they are copied but I cannot open them (so they are actually not copied). When I try to copy a folder the following error message appears:

    "Your system forbids ES from writing on external SD card (check https://code.google.com/p/android/issues/detail?id=67570), so ES can only write on it after rooted."

    I have no problem with other USB memoris in FAT32, so it seems a problem when writing in NTFS. Have you seen the same problem? One of the FW 002 fixes was to write on NTFS disks, but it seems that it is not properly fixed.
  2. Tengujin

    Tengujin Member

    It not a firmware problem but rather a Android limitation by default.
    Any android version higher than 4.3 (so basically from KitKat) prevents writing to external media, so i would suggest you root your X8 and download (and run) kitkat SD fix from the play store (several apps you can choose from)

    The fix app requires root access to modify /system/etc/permissions/platform.xml, which is blocking access to external media.
    Last edited: Dec 20, 2014
  3. deiviz

    deiviz New Member

    I'm not sure it is an Android limitation. It only happens if the drive is formatted in NTFS, and what I have observed is that if the drive is connected to the X8 when I power it on, then I can write on the drive. It's very strange...

    I have read that many users can write on external drives without root. In addition, one of the fixes stated in the FW 002 change log is: "Fixed NTFS/NFS disk writing issue". I personally think that it is not properly fixed. However, I have not received any feedback from Minix team about this issue.
  4. ARS

    ARS New Member

    I have 002 fw and an NTFS formatted 750GB external USB2 HDD attached to the box, having no problem writing it (XBMC, tTorrent, etc..).
    Have you tried to format another USB stick to NTFS and test it on the X8?
    If that stick can be written than the problem is with your current NTFS drive.
  5. Mavors

    Mavors Member

    I have a NTFS formatted drive, it's a Seagate Exp 3Tb.
    With the Fw002 I can confirm that it writes in the NTFS drive. I've not tried yet the 002A but I belive that will behave the same.
  6. deiviz

    deiviz New Member

    I have tried with another USB stick in NTFS and I have the same problem: I can't write if I connect it once the X8 is running. So I don't think that the problem was the USB drive.

    So after all these tests what I have noticed is that if I plug the external USB drive (either a 1 TB HDD or an USB stick) once the X8 is running, I can't write on the USB drive. But if I plug first the external drive and then I switch on the X8, I can write on the USB drive. I have always observed the same behaviour. I think it's a FW problem.

    Just a question for those who have no problems when writing on external drives in NTFS: do you start the X8 with the external drive attached? In this case, would you please start the X8 with no external drive attached, then plug it and try to write on it?
  7. Fox Mulder

    Fox Mulder Member

    I don't have issues writing to the attached USB drive, but since updating to 002A I've been having issues writing to SMB shared drives from my Minix. I was able to before, but not since firmware 002 update.
    Ideas?