1. Welcome to the official forum for MINIX devices!

X7 Not turning on

Discussion in 'NEO X7' started by Adambob, May 11, 2017.

  1. Adambob

    Adambob New Member

    Hi I updated my minix box a while ago and I use it every night but last night it turned off by itself and doesn't come back on I tried it with other plugs but it doesn't come on no blue light or anything can someone please help me I have the minix neo x7 16gb version with this update on it
  2. EdT586

    EdT586 Member

    I have seen this a few times on my X7 and X7 Mini.
    First make sure there is current coming from the power adapter, unplug it from your X7 and check with a volt meter if you have one, it should read 5VDC.
    These switching power supplies sometimes do not provide current if there is no load.

    Next if the power adapter is good, plug it back to the X7 while pressing the reset and power button simultaneously, then unplug and replug the power adapter again after 5-10 seconds.
    99% of the time the X7 will boot back to life, sometimes the blue LED will not light, but everything still works.
  3. Villa

    Villa Well-Known Member Super Moderator

    My concern is with what other plugs did you try?
  4. Adambob

    Adambob New Member

    the same type of plug with same wattage in and out everything was the same as the plug I use
  5. Higgs

    Higgs Yellow Dude Super Moderator

    Wattage isn't as important as the correct voltage.

    Sent from my MotoG3 using Tapatalk
    Villa likes this.
  6. Villa

    Villa Well-Known Member Super Moderator

    You read my mind! :)
  7. Adambob

    Adambob New Member

    it didn't work
    I mean voltage
  8. Adambob

    Adambob New Member

    It didnt work any other ideas
  9. Adambob

    Adambob New Member

    Hi Is any still out there to help me
  10. Adambob

    Adambob New Member

    Is anyone even looking at this page I need help but it looks like no one is out there
  11. Phil

    Phil New Member

    Mine was powered off for a month or so. Now I get the recovery screen - at the bottom it says "E: Failed to mount /mnt/external_sd (no such device)" Is it really the internal memory that's dead? Can the X7 still be used?
    Last edited: Jun 9, 2017
  12. EdT586

    EdT586 Member

    Does the blue LED light up ?
    The only other thing you can try now is to reflash the firmware with a PC.
    Best to reflash it with a XP machine and your X7 should be recognized once all the proper drivers are loaded.
    I have played with tons of these boxes and only once was the firmware ever corrupted and I had to reflash, but it was still able to boot into the home screen.
  13. Adambob

    Adambob New Member

    I tried to flash from windows 7 with the tool from this thread http://www.minixforum.com/threads/is-my-neo-x7-dead-another-not-powering-up-thread.16590/ and the tool doent support windows xp do you have a tool that can flash xp and what do you mean reflash do you mean reinstall my current software or after flashing it should work ?
  14. Phil

    Phil New Member

    UPDATE:

    I tried all the options on the recovery menu. None worked. So I did a restore using the RK tool. That worked. I did get the recovery screen briefly with the external_sd message, but this time it did a reformat and proceeded with a normal boot. All is now working. Reboot posed no problems.

    But I won't let it remain unplugged for long any more...
    Last edited: Jun 9, 2017