1. Registration issues have now been resolved. New accounts are able to be created

Official X8-H PLUS 005 firmware (20150506)

Discussion in 'NEO X8-H PLUS 005 firmware via MINIX FOTA' started by MINIX - Ken, May 8, 2015.

  1. Jeffers24

    Jeffers24 Active Member

    Hi Ken,

    Towards the end of support would you release a latest version of the Minix OS using latest Android OS, so we can use with Kodi for as long as possible as Kodi migrates to later Android OSs and ceases support on older Android OSs
  2. toxic

    toxic New Member

    After following instructions on how to update, it just reboots after you press "update" button and nothing seems to happen. What Should one look for to verify update was successful?
  3. Dr Goodvibes

    Dr Goodvibes Active Member Trusted Helper

    Settings -> About MediaBox.

    This will show you the current version which should match what you just upgraded to.

    Sent from a Minix NEO X8-H Plus
  4. Dr Goodvibes

    Dr Goodvibes Active Member Trusted Helper

    @Jeffers24 as you see from the following statement from Ken, Minix is making a firm commitment to support the Minix X8H-Plus firmware for some time to come.
    Given over 70% of Android users (1-Jun-2015) are using JB 4.1(~38%) and KK 4.4(~39%), I don't think Kodi will be losing focus of it's largest demographic any time soon. :D

    It's the gamers that may have to keep either eye open, as the Mali-450MP does not support many of the newer graphics API such as DirectX 11 and OpenGL ES 3.0 etc.

  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    "as Kodi migrates to later Android OSs and ceases support on older Android OSs"
    I doubt if this would ever happen.
  6. Jeffers24

    Jeffers24 Active Member

    Hi Ken,

    Most companies stop support of their product on old OS releases, most OS companies stop support of their old OSs at some point.

    Current minimum requirement for the Isengard release of Kodi on Android is stated as:-

    * Android
    • - Minimum Android 4.2 Jelly Bean MR1 required
    • - Android API 17 as minimum with SDK 14 and NDK 10e
    • - Removed the need for root/SU on Android. Some hardware/firmware might not like that. Please contact your hardware supplier
    • - Android PIL packaging fixed
    That's not to say Isengard won't run on previous versions of Android it may/may not, but if you want support or to use latest features you will normally be told to upgrade the Android OS, which in this case will be the MINIX OS.

    Does the current 005 MINIX OS meet the above minimum requirements?
  7. Jeffers24

    Jeffers24 Active Member

    Hi Dr V,

    Agree with all your comments, however Kodi will leave KK behind at some point.

    Would be good if MINIX move the X8H+ OS to Lollipop before they stop support, giving us a little bit of extra runway :)
    Bob Howard likes this.
  8. Bob Howard

    Bob Howard New Member

    Does anyone know how to get the Minix Neo x8H plus to play YouTube 4k and export in 4K? I have been unable to find a way to do it. If anyone has done it, and is sure that they are actually exporting a true 4k signal (not a 720p YouTube video upscaled by the Minix to 4K) please let me know how you have done it. Thank you to anyone who has the answer for this.

    Edit: Of course you can download the video and play it through one of several apps available to the Minix. Still, would really like to find a way to play it direct in 4k.

    Edit 2: I have been able to Miracast 1440 Youtube to the Minix. I guess if I had a phone or tablet that could cast 2160 I could do it that way. Not the best but it did work.
    Last edited: Jul 4, 2015
  9. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Yes current firmware fulfills all the above requirements.
  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    The standard youtube app doesn't support 4K output at the moment.
  11. Hi all, sorry if I ask a probabilly old question, but I don't understand how to update.
    Just recived an x8-h plus KOT49H.20141122 , how to update at latest firmware? i've tried with no success the online update
  12. Higgs

    Higgs Yellow Dude Super Moderator

    sangaz and silentscreambt like this.
  13. benster

    benster Member

    Ken ??!! Why do you make a 006 topic when the firmware isnt online yet!!
    Got me al excited man!! Hahah

    Verstuurd vanaf mijn SM-G920F met Tapatalk
  14. Turner68

    Turner68 New Member

    Just want to make sure I understand this correctly. I am currently on 002FW 20151225 and want to get to 005FW.
    If I use an update method like .zip/usb or FOTA (which isn't working for me), I have to update incrementally.
    If I use the full image (.rar) with the burning tool, I can go directly to 005FW. -Do not pass "Go", Do not collect $200.

    Correct?
  15. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

    If I use the full image (.rar) with the burning tool, I can go directly to 005FW. -Do not pass "Go", Do not collect $200.

    thats the cleanest method, but 006A FW is out now
    and you need to unrar the download file and use the flash tool to load the .img file contained in the .rar
  16. Giovanni Casucci

    Giovanni Casucci New Member

    HELP PLEASE

    I CANNOT DOWNLOAD THE FIRMWARE VIA FOTA.. IT STUCKS ON PROGRESS RATE 0%..ANY SUGGESTIONS?
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    can you retry? there was a server maintenance today.
  18. Cless09

    Cless09 New Member

    Can i direct update to 006 even if i have only 20141122?
  19. Villa

    Villa Trusted Helper Super Moderator

    Yes! (y)