1. Official MINIX forum

Official X8-H PLUS 009 firmware (20160328)

Discussion in 'NEO X8-H PLUS 009 firmware via MINIX FOTA' started by MINIX - Ken, Apr 9, 2016.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all NEO X8-H PLUS users,

    Official firmware 009 has been released, you may now update from firmware 008A via MINIX OTA.
    For those who prefer to keep your existing data, you may enjoy this update first.

    Full system image with USB flashing tool:
    http://www.minixforum.com/downloads/download.php?file=X8H_PLUS_FW009_20160328.rar
    MD5 checksum: 0CB59BF4CB7A1EA0DDCB3137CA5A71CB

    USB .zip update package (keeping exisiting data, requires FAT32 USB drive):
    http://www.minixforum.com/downloads/download.php?file=X8H_PLUS_FW009.zip
    MD5 checksum: 628352DEE58311F748CC641E3E0AC18B

    Update instruction:
    http://www.minixforum.com/threads/how-to-use-the-usb-zip-update-method-x6-x8-series.6828/

    Change log (since FW008A 20160114 firmware):

    1.) Fixed PVR channel switch problem within XBMC/Kodi
    2.) Fixed Google Play Store bug
    3.) Fixed Livestream app streaming issue
    4.) Updated MINIX UI
    5.) Added long press power button entering recovery menu option (~8s)

    Extra:
    New MINIX XBMC release candidate build (based on Kodi Isengard 15.3):
    http://www.minixforum.com/downloads/download.php?file=MINIX_XBMC_20160313.apk

    NEVER DISCONNECT THE POWER DURING THE UPDATE PROCESS!!

    Cheers,
    Team MINIX.
  2. aziz330

    aziz330 New Member

    thankyou
  3. Hayo

    Hayo New Member

    Thank you!
    aziz330 likes this.
  4. elpopa

    elpopa New Member

    If I update via USB will I loose data?
  5. MacB

    MacB Member

    as long as you use the update.zip on the SD you won't loose any data - as it is an update ;-)
    or use OTA...
    Last edited: Apr 9, 2016
  6. Villa

    Villa Trusted Helper Super Moderator

    If you are referring to the USB .zip update package, then No, you don't lose data!
    If you use the USB flashtool and a PC, then Yes, you lose data!

    Neither of these options (for this firmware version 009) are available at the moment. Only OTA ;)
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Links to both full system image & .zip update package are updated in post #1!
    Menorca Man and Villa like this.
  8. elpopa

    elpopa New Member

    Ok thanks, then I shall go in recovery an update via recovery (not via USB burning tool)

    Ps: OTA doesnt work since device is rooted
  9. Slaventiy

    Slaventiy Member

    So installed fw009, but i have same bug with mediaserver (fw008A) cpu usage ~100%
    Maybe i try downgrade <008a
  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We can't copy the issue, and nobody else report this so...
    you have to tell us what combination may be causing it.
  11. Slaventiy

    Slaventiy Member

    Combination is very easy - just change channels (multicast, hls, etc) on mx player 1.7.34... I can give you link with hls (iptv) (already send to you private message) - in this link you see more bugs, example: some stream playing in hw decoder, but didn't switch "self adaptive refresh rate switching", another stream change "self adaptive refresh rate switching" from 60hz to 60hz.... If you more change channels on this link (not a 5 minutes!!!), you must catch this bug (mediaserver).
    PS I did not power off on my tv box, so I see this often.

    +1 bug (fw 008a-009, i do not know of other firmware) - after reflash firmware i put tv box on Samsung SyncMaster BX2431 (HDMI) = when i start tv box, i see "android robot" on monitor screen and after 1 second i have no signal. If put tv box on TV = this problem does not exist.
    My previous tv box work fine with monitor screen Samsung SyncMaster BX2431

    This is software problem or hardware on tv box?
    Last edited: Apr 11, 2016
  12. Strikey

    Strikey New Member

    I've tried the update and it failed, keep resseting with failed massage
    I disconnect the power and now it is stuck on the minix logo
    What can i do?
  13. Higgs

    Higgs Yellow Dude Super Moderator

  14. Strikey

    Strikey New Member

    Thanks a lot! i will try it.
    Is this the full firmware / the last firmware update?
  15. Strikey

    Strikey New Member

    The second option didn't work... it seem it doesn't boot in recovery mode (pressing RECOVERY and POWER botton)
    Is that normal?
  16. Higgs

    Higgs Yellow Dude Super Moderator

    No but then getting stuck at the Minix logo isn't normal either. Try the other option.
  17. Strikey

    Strikey New Member

    I've tried the first option - it stuck on 6% when trying to download the image then failed
    DARN! is there a way to fix it??
    ----------
    [21:24:19 328][HUB5-4][Inf]--0-7-0-16
    [21:24:19 328][HUB5-4][Inf]--download store boot normal 8762330
    [21:24:19 328][HUB5-4][Inf]--Send download command success
    [21:24:19 343][HUB5-4][Inf]--Read command status success
    [21:24:19 468][HUB5-4][Err]--Return buffer=media error 1 at seq 0, resend 3

    [21:24:19 468][HUB5-4][Err]--Download file failed, sequence 0
    [21:24:19 468][HUB5-4][Inf]--Failure : 1, FailureMax : 3
    [21:24:20 875][HUB5-4][Inf]--Transfer complete
    [21:24:20 875][HUB5-4][Inf]--Send download get_status command succeed
    [21:24:20 890][HUB5-4][Err]--failed:[21:24:20 937][HUB5-4][Err]--[0x30404004]UBOOT/Partition boot/Get download status/Error result
    [21:24:20 937][HUB5-4][Inf]--Close device handle 0x000002e8
  18. HardwareGuru

    HardwareGuru Developer Administrator

    try a usb 2.0 (3.0 are mostly blue) port if you have... or change to another cable if posible and try again.
  19. Strikey

    Strikey New Member

    Tried it right now... a new USB cable and even other computer running WINDOWS 7
    Still the same error.... now the MINIX not even display a thing on the monitor - it is blank.
    What is wrong with my MINIX? could it be repaired?
    Thanks
  20. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Did you check the MD5 of the image you downloaded?